FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Studio User

 
 
LinkBack Thread Tools
 
Old 11-29-2009, 08:08 PM
James Pollard
 
Default Jack Crashes With "Bus Error"

Hi All,

Have recently installed karmic koala ubuntu studio and have been very happy with the overall feel of the system. Got a couple of strange niggles. The first is that Jack often won't start either from using QJackctl or from the command line. Often it starts up first time, but if it is stopped it won't restart until I shut down the computer and start again (loging out doesn't help). Starting from the command line gives me a "Bus Error" and no further information. I've tried googling this but have not got anywhere.



The sound card I'm using is a USB m-audio MobilePre.

Any ideas appreciated. Not sure where to start with this.

thanks,
James.
PS: Command line output below:
/usr/bin/jackd -R -dalsa -r44100 -p64 -n4 -D -Chw:1 -Phw:1


no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details



JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:1|hw:1|64|4|44100|0|0|nomon|swmeter|-|32bit
control device hw:1
Bus error





--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-29-2009, 08:49 PM
Oleg Ivanenko
 
Default Jack Crashes With "Bus Error"

Hi, James!

I had similar behavior --
https://lists.ubuntu.com/archives/ubuntu-studio-users/2009-November/005617.html

Seems like my situation become slightly better(but not completly
solved) with these rows added in /etc/security/limits.conf

@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -19

2009/11/30 James Pollard <pollardjm@gmail.com>:
>
> Hi All,
>
> Have recently installed karmic koala ubuntu studio and have been very happy
> with the overall feel of the system. Got a couple of strange niggles. The
> first is that Jack often won't start either from using QJackctl or from the
> command line. Often it starts up first time, but if it is stopped it won't
> restart until I shut down the computer and start again (loging out doesn't
> help). Starting from the command line gives me a "Bus Error" and no further
> information. I've tried googling this but have not got anywhere.
>
> The sound card I'm using is a USB m-audio MobilePre.
>
> Any ideas appreciated. Not sure where to start with this.
>
> thanks,
> James.
> PS: Command line output below:
> /usr/bin/jackd -R -dalsa -r44100 -p64 -n4 -D -Chw:1 -Phw:1
> no message buffer overruns
> jackd 0.116.1
> Copyright 2001-2005 Paul Davis and others.
> jackd comes with ABSOLUTELY NO WARRANTY
> This is free software, and you are welcome to redistribute it
> under certain conditions; see the file COPYING for details
>
> JACK compiled with System V SHM support.
> loading driver ..
> apparent rate = 44100
> creating alsa driver ... hw:1|hw:1|64|4|44100|0|0|nomon|swmeter|-|32bit
> control device hw:1
> Bus error
>
>
>
>
> --
> Ubuntu-Studio-users mailing list
> Ubuntu-Studio-users@lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>
>



--
Truly yours, Oleg Ivanenko aka Ash
[if it wasn't so sad, it would be funny]

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-30-2009, 05:23 AM
Kenneth Koym
 
Default Jack Crashes With "Bus Error"

James:
�� Can't answer your question directly but I have an operating ubuntu studio 9.10 w/o sound. I mention this as a possible work around that may be of use to you. Study it.
�� my ubuntu-studio 9.10 amounts to an update of ubuntu 9.04 Jaunty which became ubuntu studio 9.04 by first opening terminal> & writing in









sudo aptitude search ubuntu studio
AMD 64

sudo aptitude install ubuntu
studio AMD 64 followed by


Yes continue

� Then, to get what appears to be a safe working results I secondly opened terminal and wrote in




#!/bin/sh
gksudo "aptitude -y install
ubuntustudio-audio ubuntustudio-audio-plugins ubuntustudio-controls
ubuntustudio-default-settings ubuntustudio-desktop
ubuntustudio-gdm-theme ubuntustudio-icon-theme ubuntustudio-graphics
ubuntustudio-look ubuntustudio-menu ubuntustudio-screensaver
ubuntustudio-sounds ubuntustudio-theme ubuntustudio-video
ubuntustudio-wallpapers usplash-theme-ubuntustudio linux-rt
linux-restricted-modules-rt linux-image-rt linux-headers-rt";


By giving my password appropriately, powering down and rebooting, I had ubuntu-studio 9.04, which when updated with ubuntu 910, I had an OS that boots up without problems with exception of having no sound at the moment.


Being a bit challenged I haven't done the work around needed to
��� 1) Perfect the sound issue or load skype etc. or,
��� 2) burn the 1.2 gig .iso sitting on my desktop.
If I can break loose some time, I'd like to see the light of day on ripping and posting somethings that need produceing copy now on my Sony camcorder

�� Hope the two work around methods may give you an idea how to proceed
�keep at it James!

On Sun, Nov 29, 2009 at 3:08 PM, James Pollard <pollardjm@gmail.com> wrote:


Hi All,

Have recently installed karmic koala ubuntu studio and have been very happy with the overall feel of the system. Got a couple of strange niggles. The first is that Jack often won't start either from using QJackctl or from the command line. Often it starts up first time, but if it is stopped it won't restart until I shut down the computer and start again (loging out doesn't help). Starting from the command line gives me a "Bus Error" and no further information. I've tried googling this but have not got anywhere.




The sound card I'm using is a USB m-audio MobilePre.

Any ideas appreciated. Not sure where to start with this.

thanks,
James.
PS: Command line output below:
/usr/bin/jackd -R -dalsa -r44100 -p64 -n4 -D -Chw:1 -Phw:1



no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details




JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:1|hw:1|64|4|44100|0|0|nomon|swmeter|-|32bit
control device hw:1
Bus error






--

Ubuntu-Studio-users mailing list

Ubuntu-Studio-users@lists.ubuntu.com

Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users




--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 

Thread Tools




All times are GMT. The time now is 09:28 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org