FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Studio User

 
 
LinkBack Thread Tools
 
Old 11-16-2009, 10:44 AM
Hartmut Noack
 
Default Availability of Ardour 2.8.4 on Ubuntu Studio?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Erik Rasmussen schrieb:
> In Ubuntu Studio, what is the upgrade frequency for key apps like Ardour? I
> see that Ardour 2.8.4 was just released, but it looks like Ardour 2.8.2 is
> the latest version available through Ubuntu Studio. Is there anyone using
> Ardour 2.8.4 on Ubuntu Studio 9.10?

I built it from SVN - works very well with Ubuntu Studio 9.10 -
dev-packages installed with synaptic.

>
> While I'm asking these questions I might also ask if anyone has tried or is
> using Ardour 3.x on Ubuntu Studio? If anyone is using Ardour 3.x on Ubuntu

built it from SVN too (see above)


> Studio, how does it work for you?

as an early pre-alpha version is supposed to work I guess ;-)

>
> Thanks!
> -Erik
>
>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAksBOzMACgkQ1Aecwva1SWOorACeOcs00fZupT Ett54qRVc8XzAE
j20An2hOwPIUV4D1LigFxYHV96VwTy2C
=McfL
-----END PGP SIGNATURE-----

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-16-2009, 01:01 PM
teza
 
Default Availability of Ardour 2.8.4 on Ubuntu Studio?

Hi, could you tell me how you did install Ardour 2.8.4 on Karmic studio
9.10.
thanks
Regards
Teza


.................................................. ............
Le lundi 16 novembre 2009 à 12:44 +0100, Hartmut Noack a écrit :
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Erik Rasmussen schrieb:
> > In Ubuntu Studio, what is the upgrade frequency for key apps like Ardour? I
> > see that Ardour 2.8.4 was just released, but it looks like Ardour 2.8.2 is
> > the latest version available through Ubuntu Studio. Is there anyone using
> > Ardour 2.8.4 on Ubuntu Studio 9.10?
>
> I built it from SVN - works very well with Ubuntu Studio 9.10 -
> dev-packages installed with synaptic.
>
> >
> > While I'm asking these questions I might also ask if anyone has tried or is
> > using Ardour 3.x on Ubuntu Studio? If anyone is using Ardour 3.x on Ubuntu
>
> built it from SVN too (see above)
>
>
> > Studio, how does it work for you?
>
> as an early pre-alpha version is supposed to work I guess ;-)
>
> >
> > Thanks!
> > -Erik
> >
> >
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
>
> iEYEARECAAYFAksBOzMACgkQ1Aecwva1SWOorACeOcs00fZupT Ett54qRVc8XzAE
> j20An2hOwPIUV4D1LigFxYHV96VwTy2C
> =McfL
> -----END PGP SIGNATURE-----
>





--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-16-2009, 01:27 PM
Hartmut Noack
 
Default Availability of Ardour 2.8.4 on Ubuntu Studio?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

teza schrieb:
> Hi, could you tell me how you did install Ardour 2.8.4 on Karmic studio
> 9.10.

1.) open synaptic and install build-essentials and svn
2.) open your browser and go to http://ardour.org/download_full
3.) the link to this: http://ardour.org/building brings up a page that
shows, what you need to install to build ardour - open it in a tab and
read it
4.) install every package mentioned on http://ardour.org/building -
remember to always install the -dev package of fftw, gtk+, gtkmm,
gnomecanvas and all the others. Also install scons and slv2. If you
really want VST get wine-dev also.
5.)return to http://ardour.org/download_full and fetch the sourcecode
6.)open a terminal in the dir you have stored the sourcecode and build
ardour with scons - if scons complains that a package is missing,
install this package and restart scons. In some cases it might be
neccessary to erase the ardour-source-dir and unpack the code-tarball
again or fetch the svn anew.
7.) if scons is done do this: sudo scons install

now you can run ardour ;-)


> thanks
> Regards
> Teza
>
>
> .................................................. ............
> Le lundi 16 novembre 2009 à 12:44 +0100, Hartmut Noack a écrit :
> Erik Rasmussen schrieb:
>>>> In Ubuntu Studio, what is the upgrade frequency for key apps like Ardour? I
>>>> see that Ardour 2.8.4 was just released, but it looks like Ardour 2.8.2 is
>>>> the latest version available through Ubuntu Studio. Is there anyone using
>>>> Ardour 2.8.4 on Ubuntu Studio 9.10?
> I built it from SVN - works very well with Ubuntu Studio 9.10 -
> dev-packages installed with synaptic.
>
>>>> While I'm asking these questions I might also ask if anyone has tried or is
>>>> using Ardour 3.x on Ubuntu Studio? If anyone is using Ardour 3.x on Ubuntu
> built it from SVN too (see above)
>
>
>>>> Studio, how does it work for you?
> as an early pre-alpha version is supposed to work I guess ;-)
>
>>>> Thanks!
>>>> -Erik
>>>>
>>>>
>>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAksBYVIACgkQ1Aecwva1SWMyyQCggr4HKSj7z4 P4PEsBGL3uGFA8
AXsAn2HnPIyi3aEJ/DYFemmpxfXXR04w
=QtkE
-----END PGP SIGNATURE-----

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-16-2009, 01:40 PM
Asmo Koskinen
 
Default Availability of Ardour 2.8.4 on Ubuntu Studio?

Hartmut Noack kirjoitti:

> 1.) open synaptic and install build-essentials and svn
> 2.) open your browser and go to http://ardour.org/download_full
> 3.) the link to this: http://ardour.org/building brings up a page that
> shows, what you need to install to build ardour - open it in a tab and
> read it
> 4.) install every package mentioned on http://ardour.org/building -
> remember to always install the -dev package of fftw, gtk+, gtkmm,
> gnomecanvas and all the others. Also install scons and slv2. If you
> really want VST get wine-dev also.

I think you can make also a shortcut here with this command:

http://www.debian.org/doc/manuals/apt-howto/ch-sourcehandling.en.html#s-build-dep

'-s' is here as 'simulation', nothing really happens, so you can see
what is going to happen.

sudo apt-get build-dep -s ardour

> 5.)return to http://ardour.org/download_full and fetch the sourcecode
> 6.)open a terminal in the dir you have stored the sourcecode and build
> ardour with scons - if scons complains that a package is missing,
> install this package and restart scons. In some cases it might be
> neccessary to erase the ardour-source-dir and unpack the code-tarball
> again or fetch the svn anew.
> 7.) if scons is done do this: sudo scons install
>
> now you can run ardour ;-)

Best Regards Asmo Koskinen.

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-16-2009, 02:23 PM
teza
 
Default Availability of Ardour 2.8.4 on Ubuntu Studio?

Hello and thanks a lot, just one more thing, should I remove the Ardour
I've got now on my system first, before building 2.8.4?
Thanks
Regards from Paris
Teza


.................................................. ................................
Le lundi 16 novembre 2009 à 15:27 +0100, Hartmut Noack a écrit :
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> teza schrieb:
> > Hi, could you tell me how you did install Ardour 2.8.4 on Karmic studio
> > 9.10.
>
> 1.) open synaptic and install build-essentials and svn
> 2.) open your browser and go to http://ardour.org/download_full
> 3.) the link to this: http://ardour.org/building brings up a page that
> shows, what you need to install to build ardour - open it in a tab and
> read it
> 4.) install every package mentioned on http://ardour.org/building -
> remember to always install the -dev package of fftw, gtk+, gtkmm,
> gnomecanvas and all the others. Also install scons and slv2. If you
> really want VST get wine-dev also.
> 5.)return to http://ardour.org/download_full and fetch the sourcecode
> 6.)open a terminal in the dir you have stored the sourcecode and build
> ardour with scons - if scons complains that a package is missing,
> install this package and restart scons. In some cases it might be
> neccessary to erase the ardour-source-dir and unpack the code-tarball
> again or fetch the svn anew.
> 7.) if scons is done do this: sudo scons install
>
> now you can run ardour ;-)
>
>
> > thanks
> > Regards
> > Teza
> >
> >
> > .................................................. ............
> > Le lundi 16 novembre 2009 à 12:44 +0100, Hartmut Noack a écrit :
> > Erik Rasmussen schrieb:
> >>>> In Ubuntu Studio, what is the upgrade frequency for key apps like Ardour? I
> >>>> see that Ardour 2.8.4 was just released, but it looks like Ardour 2.8.2 is
> >>>> the latest version available through Ubuntu Studio. Is there anyone using
> >>>> Ardour 2.8.4 on Ubuntu Studio 9.10?
> > I built it from SVN - works very well with Ubuntu Studio 9.10 -
> > dev-packages installed with synaptic.
> >
> >>>> While I'm asking these questions I might also ask if anyone has tried or is
> >>>> using Ardour 3.x on Ubuntu Studio? If anyone is using Ardour 3.x on Ubuntu
> > built it from SVN too (see above)
> >
> >
> >>>> Studio, how does it work for you?
> > as an early pre-alpha version is supposed to work I guess ;-)
> >
> >>>> Thanks!
> >>>> -Erik
> >>>>
> >>>>
> >>
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
>
> iEYEARECAAYFAksBYVIACgkQ1Aecwva1SWMyyQCggr4HKSj7z4 P4PEsBGL3uGFA8
> AXsAn2HnPIyi3aEJ/DYFemmpxfXXR04w
> =QtkE
> -----END PGP SIGNATURE-----
>





--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-16-2009, 02:41 PM
Asmo Koskinen
 
Default Availability of Ardour 2.8.4 on Ubuntu Studio?

teza kirjoitti:

> Hello and thanks a lot, just one more thing, should I remove the Ardour
> I've got now on my system first, before building 2.8.4?

Not necessary. You can use 'stable' one from repositories and
'unstable/testing' from source in same machine. Just put
'unstable/testing' in /usr/local/bin, that is default, I think, so you
know which one you are using.

Best Regards Asmo Koskinen.

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-17-2009, 04:31 PM
Brian David
 
Default Availability of Ardour 2.8.4 on Ubuntu Studio?

On Sun, Nov 15, 2009 at 3:08 AM, Erik Rasmussen <MailForErik@gmail.com> wrote:

In Ubuntu Studio, what is the upgrade frequency for key apps like Ardour?* I see that Ardour 2.8.4 was just released, but it looks like Ardour 2.8.2 is the latest version available through Ubuntu Studio.* Is there anyone using Ardour 2.8.4 on Ubuntu Studio 9.10?*




While I'm asking these questions I might also ask if anyone has tried or is using Ardour 3.x on Ubuntu Studio?* If anyone is using Ardour 3.x on Ubuntu Studio, how does it work for you?
Thanks!



-Erik


--

Ubuntu-Studio-users mailing list

Ubuntu-Studio-users@lists.ubuntu.com

Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users



In the past, I have been able to install new versions of Ardour using a package downloaded from www.getdeb.net.* To do this, you will need to remove the old version of Ardour, and to do that you will need to remove the ubuntustudio-audio metapackage (NOTE: This does not remove any of the other programs associated with the package, although it will probably change your /etc/security/limits.conf settings, so be sure to check that.)* You can use Add/Remove software to uninstall Ardour, but you will need to use Synaptic or apt-get to remove ubuntustudio-audio.


Then, just double-click the .deb for the new Ardour, and you're good to go.* I prefer this way because I'm not very comfortable building things from source.* I should also say that I have not yet done this with Karmic, so I don't know if it works the same.

--
-Brian David

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-17-2009, 04:57 PM
Erik Rasmussen
 
Default Availability of Ardour 2.8.4 on Ubuntu Studio?

Yes, I looked for Ardour at*getdeb.net*also, but I did not see any version of Ardour at GetDeb.net. *Do you find it there? *If yes, what URL do you go to to find it?

Thanks!


-Erik

On Tue, Nov 17, 2009 at 11:31, Brian David <beejunk@gmail.com> wrote:


On Sun, Nov 15, 2009 at 3:08 AM, Erik Rasmussen <MailForErik@gmail.com> wrote:



In Ubuntu Studio, what is the upgrade frequency for key apps like Ardour?* I see that Ardour 2.8.4 was just released, but it looks like Ardour 2.8.2 is the latest version available through Ubuntu Studio.* Is there anyone using Ardour 2.8.4 on Ubuntu Studio 9.10?*






While I'm asking these questions I might also ask if anyone has tried or is using Ardour 3.x on Ubuntu Studio?* If anyone is using Ardour 3.x on Ubuntu Studio, how does it work for you?
Thanks!





-Erik


--

Ubuntu-Studio-users mailing list

Ubuntu-Studio-users@lists.ubuntu.com

Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users



In the past, I have been able to install new versions of Ardour using a package downloaded from www.getdeb.net.* To do this, you will need to remove the old version of Ardour, and to do that you will need to remove the ubuntustudio-audio metapackage (NOTE: This does not remove any of the other programs associated with the package, although it will probably change your /etc/security/limits.conf settings, so be sure to check that.)* You can use Add/Remove software to uninstall Ardour, but you will need to use Synaptic or apt-get to remove ubuntustudio-audio.




Then, just double-click the .deb for the new Ardour, and you're good to go.* I prefer this way because I'm not very comfortable building things from source.* I should also say that I have not yet done this with Karmic, so I don't know if it works the same.



--
-Brian David


--

Ubuntu-Studio-users mailing list

Ubuntu-Studio-users@lists.ubuntu.com

Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users




--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 11-17-2009, 05:10 PM
Brian David
 
Default Availability of Ardour 2.8.4 on Ubuntu Studio?

On Tue, Nov 17, 2009 at 11:57 AM, Erik Rasmussen <MailForErik@gmail.com> wrote:

Yes, I looked for Ardour at*getdeb.net*also, but I did not see any version of Ardour at GetDeb.net. *Do you find it there? *If yes, what URL do you go to to find it?


Thanks!


-Erik


You're right, I can't seem to find it on GetDeb, either.* It looks like they've updated their site since the last time I visited, and no longer seem to have Ardour.* I wonder if they're still in the process of adding software?


Building from source it is!

--
-Brian David

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 

Thread Tools




All times are GMT. The time now is 09:05 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org