Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Ubuntu Server Development (http://www.linux-archive.org/ubuntu-server-development/)
-   -   Xen in Hardy (http://www.linux-archive.org/ubuntu-server-development/63157-xen-hardy.html)

"Todd Deshane" 04-02-2008 11:36 PM

Xen in Hardy
 
On Wed, Apr 2, 2008 at 5:43 PM, Leandro Pereira de Lima e Silva
<leandro@limaesilva.com.br> wrote:
> Sander,
>
> That's what I did:
> - I was trying to create a virtual machine with hardy on it (hardy on the
> host too) using xen-create-image.
> - xen-tools isn't coming with hooks for installing hardy (I've already
> filled a bug report about that), so I tried symlinking hardy.d to edgy.d
> just like the symlinks from feisty.d and gutsy.d.
> - Runned: xen-create-image --force --fs ext3 --image-dev
> /dev/group/volume_root --memory 512 --passwd --swap-dev
> /dev/group/volume_swap --dist hardy --mirror
> http://br.archive.ubuntu.com/ubuntu --gateway gateway_ip_addr --ip ip_addr
> --netmask netmask_addr --hostname hostname_addr, where "group/volume_root",
> "group/volume_swap", "gateway_ip_addr", "ip_addr", "netmask_addr",
> "hostname_addr" are actually other things that I've changed to get some
> privacy.
> - Tried to boot, but initramfs can't find the root.
> - Fixed a few things on the configuration file generated by xen-create-image
> (tried different combinations, this is how it ended):
> - Add "root = '/dev/sda2 ro'" after the memory line.
> - Fixed the disk section that just contained "',sda1,w'," inside of it,
> at the end it became:
> disk = [ 'phy:group/volume_swap,sda1,w',
> 'phy:group/volume_root,sda2,w' ]
> - Add "xenblk" to /etc/initramfs-tools/modules and recreated the initrd
> file. (the same as the above item, what seemd to work after a few
> tentatives)
> - Runned xm create -c hostname_addr
> - Machine starts to boot and hangs at:
> * Running local boot scripts (/etc/rc.local) [
> OK ]
>
> - Switched to gutsy (in xen-create-image), thinking that maybe it hangs
> because of some new hook needed for hardy.
> - Got the same problem that I had with hardy.
>
> The LVM group and the volumes existed previously, the machine is an Athlon
> 64 X2 with 3.5gb of ram. I'm using a custom linux kernel version 2.6.24.3
> based on the available source for 2.6.24-12-xen. Tried also using the
> official kernel (2.6.24-12-xen) with the original initrd but failed on the
> initrd problem that I described above, tried it with a new initrd and it got
> stuck in the same "Running local boot scripts [ OK ]" as above.
>
> I'm using xen-tools version 3.8-4ubuntu2 and xen-hypervisor-3.2 version
> 3.2.0-0ubuntu9.
>
> I tried to cover every aspect that may be relevant to the setup, please tell
> me if I've missed anything.
>
>

try hda instead of sda.

Also there are some bugs on
https://bugs.launchpad.net/ubuntu/+source/xen-3.2/+bugs

that have at least workarounds for many of the problems that I ran
into initially.

Todd

> Cheers, Leandro.
>
>
> 2008/4/2, Sander van Vugt <mail@sandervanvugt.nl>:
> > I've done some, don't know if I can help, but tell us some more about the
> issues you're having.
> >
> > Sander van Vugt
> >
> >
> > Leandro Pereira de Lima e Silva schreef:
> >
> >
> > > Is anyone here using Xen (3.2) on Hardy? I'm having some problems with a
> machine created using xen-tools and I would like discuss that.
> > >
> > > Cheers,
> > >
> > > --
> > > Leandro Pereira de Lima e Silva
> > >
> >
> >
>
>
>
>
> --
> Leandro Pereira de Lima e Silva
> --
> ubuntu-server mailing list
> ubuntu-server@lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
> More info: https://wiki.ubuntu.com/ServerTeam
>

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam

Henri Cook 04-02-2008 11:38 PM

Xen in Hardy
 
I'm successfully running Xen 3.2 with a few VMs on Ubuntu Hardy - i've
made many of the changes you describe, although unfortunately i've never
encountered your error
I've only converted VMs that ran on Gutsy to work on Hardy; I have not
yet tried to create a new VM.

Let me know if you have any specific questions,

Henri



Leandro Pereira de Lima e Silva wrote:
> Sander,
>
> That's what I did:
> - I was trying to create a virtual machine with hardy on it (hardy on
> the host too) using xen-create-image.
> - xen-tools isn't coming with hooks for installing hardy (I've already
> filled a bug report about that), so I tried symlinking hardy.d to
> edgy.d just like the symlinks from feisty.d and gutsy.d.
> - Runned: xen-create-image --force --fs ext3 --image-dev
> /dev/group/volume_root --memory 512 --passwd --swap-dev
> /dev/group/volume_swap --dist hardy --mirror
> http://br.archive.ubuntu.com/ubuntu --gateway gateway_ip_addr --ip
> ip_addr --netmask netmask_addr --hostname hostname_addr, where
> "group/volume_root", "group/volume_swap", "gateway_ip_addr",
> "ip_addr", "netmask_addr", "hostname_addr" are actually other things
> that I've changed to get some privacy.
> - Tried to boot, but initramfs can't find the root.
> - Fixed a few things on the configuration file generated by
> xen-create-image (tried different combinations, this is how it ended):
> - Add "root = '/dev/sda2 ro'" after the memory line.
> - Fixed the disk section that just contained "',sda1,w'," inside of
> it, at the end it became:
> disk = [ 'phy:group/volume_swap,sda1,w',
> 'phy:group/volume_root,sda2,w' ]
> - Add "xenblk" to /etc/initramfs-tools/modules and recreated the
> initrd file. (the same as the above item, what seemd to work after a
> few tentatives)
> - Runned xm create -c hostname_addr
> - Machine starts to boot and hangs at:
> * Running local boot scripts
> (/etc/rc.local) [ OK ]
>
> - Switched to gutsy (in xen-create-image), thinking that maybe it
> hangs because of some new hook needed for hardy.
> - Got the same problem that I had with hardy.
>
> The LVM group and the volumes existed previously, the machine is an
> Athlon 64 X2 with 3.5gb of ram. I'm using a custom linux kernel
> version 2.6.24.3 <http://2.6.24.3> based on the available source for
> 2.6.24-12-xen. Tried also using the official kernel (2.6.24-12-xen)
> with the original initrd but failed on the initrd problem that I
> described above, tried it with a new initrd and it got stuck in the
> same "Running local boot scripts [ OK ]" as above.
>
> I'm using xen-tools version 3.8-4ubuntu2 and xen-hypervisor-3.2
> version 3.2.0-0ubuntu9.
>
> I tried to cover every aspect that may be relevant to the setup,
> please tell me if I've missed anything.
>
>
> Cheers, Leandro.
>
>
> 2008/4/2, Sander van Vugt <mail@sandervanvugt.nl
> <mailto:mail@sandervanvugt.nl>>:
>
> I've done some, don't know if I can help, but tell us some more
> about the issues you're having.
>
> Sander van Vugt
>
>
> Leandro Pereira de Lima e Silva schreef:
>
> Is anyone here using Xen (3.2) on Hardy? I'm having some
> problems with a machine created using xen-tools and I would
> like discuss that.
>
> Cheers,
>
> --
> Leandro Pereira de Lima e Silva
>
>
>
>
>
> --
> Leandro Pereira de Lima e Silva

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam


All times are GMT. The time now is 09:54 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.