FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Server Development

 
 
LinkBack Thread Tools
 
Old 09-18-2011, 05:21 PM
Paweł Szubert
 
Default Setting up Ubuntu Server 11.04 on dell PowerEdge 2600

Hello, this is my first post to the list, so please forgive me if
something goes wrong.

I've found some difficulties when installing Ubuntu Server 11.04 on Dell
PowerEdge 2600. The source of problem is PERC 4/DC SCSI Raid controller.
Common situation: install process goes smooth, but after initial restart
system cannot boot, the monitor LED goes orange after a short time.
After some googling and my experiments I've found a solution, so I post
this short tutorial - perhaps it will save someone's time.
The solution should work on every server platform with LSI Logic PERC
Raid controller.

- configure raid using Webbios (CTRL-H) or in text mode (Ctrl-M)
- start system installation
- when install proces is finished and installer ask You to reboot the
system, switch to the second console (Alt-F2), press enter to activate
it. You'll be given a root shell. Perform theese steps:

# cd target
# chroot .
# mount /sys
# mount /proc
# cd /etc
# nano modules
at the end of file, add 2 lines:
megaraid_mm
megaraid_mbox
save file and exit editor
megaraid_mm module is used by megaraid_mbox, so I think direct loading
isn't necessary but haven't tried.

# cd default
# nano grub
change the line:
GRUB_TIMEOUT=1
to any reasonable value (5 seconds should be enough) so You can see GRUB
screen (monitor will have enough time to synchronise and display it)
Change the line:
GRUB_CMDLINE_LINUX="" to
GRUB_CMDLINE_LINUX="rootdelay=60" (maybe more, I've started from higher
value, when rootdelay was to short got some errors)
Uncomment the line:
GRUB_TERMINAL=CONSOLE
or alternatively:
GRUB_GFX_MODE=640x480
Uncomment the line at the end of file:
GRUB_INIT_TUNE="480 440 1"
(if something goes wrong and Your monitor cannot handle video at least
You can hear a short beep when GRUB is loading ;-)

save file and exit

#cd /etc/initramfs-tools
# nano modules
add 2 lines at the end:
megaraid_mm
megaraid_mbox

so GRUB can access boot partition on PERC drive.
save file and exit


The steps below can be omitted, You can go directly to creating
initramfs

# apt-get install console-common console-setup unicode-data console-data
# dpkg-reconfigure console-data
choose keybord layout and exit
# dpkg-reconfigure console-data
choose encoding for console, caharacter set, font and size

On finish update-initramfs is called, You can call it directly without
installing above packages (and without reconfiguring them):

# update-initramfs -k all -u
and the last step:
# update-grub

Then:
# umount /sys
# umount /proc
# Ctrl D to exit chroot, switch to the first console and request system
reboot.

System should restart without problems.

Hope this will help.
Regards
Szubi



--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 

Thread Tools




All times are GMT. The time now is 01:06 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org