FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Server Development

 
 
LinkBack Thread Tools
 
Old 05-16-2011, 02:05 PM
carlopmart
 
Default I can't install ubuntu natty server on a iscsi root device

Hi all,

I am trying to install natty server edition on a iscsi root drive
(iscsi target is a rhel6 host). During installation all works ok, I can
connect to iscsi target, partition disk, install packages, etc. But when
ubuntu reboots, nothing appears, screen is black.


How can I debug this?? or Is this a bug?? I am installing this natty
server as a kvm guest under a rhel6 kvm host.


Thanks.

--
CL Martinez
carlopmart {at} gmail {d0t} com

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 05-16-2011, 06:48 PM
Serge Hallyn
 
Default I can't install ubuntu natty server on a iscsi root device

Quoting carlopmart (carlopmart@gmail.com):
> Hi all,
>
> I am trying to install natty server edition on a iscsi root drive
> (iscsi target is a rhel6 host). During installation all works ok, I
> can connect to iscsi target, partition disk, install packages, etc.
> But when ubuntu reboots, nothing appears, screen is black.
>
> How can I debug this?? or Is this a bug?? I am installing this
> natty server as a kvm guest under a rhel6 kvm host.

It sounds like a bug, but to talk about it intelligently it'd be
nice to have precise reproduction instructions. I'd encourage you
to file a bug, so we can collect all the information there. Feel
free to file it against 'qemu-kvm (Ubuntu)'. If it turns out to
be something else, we'll re-target it.

To see how I tested iscsi last year, search for 'iscsi boot' at
https://wiki.ubuntu.com/VirtFeatureVerification.

thanks,
-serge

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 05-16-2011, 07:22 PM
carlopmart
 
Default I can't install ubuntu natty server on a iscsi root device

On 05/16/2011 08:48 PM, Serge Hallyn wrote:

Quoting carlopmart (carlopmart@gmail.com):

Hi all,

I am trying to install natty server edition on a iscsi root drive
(iscsi target is a rhel6 host). During installation all works ok, I
can connect to iscsi target, partition disk, install packages, etc.
But when ubuntu reboots, nothing appears, screen is black.

How can I debug this?? or Is this a bug?? I am installing this
natty server as a kvm guest under a rhel6 kvm host.


It sounds like a bug, but to talk about it intelligently it'd be
nice to have precise reproduction instructions. I'd encourage you
to file a bug, so we can collect all the information there. Feel
free to file it against 'qemu-kvm (Ubuntu)'. If it turns out to
be something else, we'll re-target it.

To see how I tested iscsi last year, search for 'iscsi boot' at
https://wiki.ubuntu.com/VirtFeatureVerification.

thanks,
-serge


Thanks Serge ... I didn't tried to make an iscsi install like appears here:

http://berrange.com/posts/2010/05/05/provisioning-kvm-virtual-machines-on-iscsi-the-hard-way-part-2-of-2/

I have tried to install it directly to iscsi san like a physical host.
Using berrange procedure is like to use RDM in vmware ... Very interesting.


But one question, can I use virtio device instead of ide like in
berrange's doc appears for iscsi disk??


Thanks.
--
CL Martinez
carlopmart {at} gmail {d0t} com

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 05-16-2011, 08:33 PM
Serge Hallyn
 
Default I can't install ubuntu natty server on a iscsi root device

Quoting carlopmart (carlopmart@gmail.com):
> On 05/16/2011 08:48 PM, Serge Hallyn wrote:
> >Quoting carlopmart (carlopmart@gmail.com):
> >>Hi all,
> >>
> >> I am trying to install natty server edition on a iscsi root drive
> >>(iscsi target is a rhel6 host). During installation all works ok, I
> >>can connect to iscsi target, partition disk, install packages, etc.
> >>But when ubuntu reboots, nothing appears, screen is black.
> >>
> >> How can I debug this?? or Is this a bug?? I am installing this
> >>natty server as a kvm guest under a rhel6 kvm host.
> >
> >It sounds like a bug, but to talk about it intelligently it'd be
> >nice to have precise reproduction instructions. I'd encourage you
> >to file a bug, so we can collect all the information there. Feel
> >free to file it against 'qemu-kvm (Ubuntu)'. If it turns out to
> >be something else, we'll re-target it.
> >
> >To see how I tested iscsi last year, search for 'iscsi boot' at
> >https://wiki.ubuntu.com/VirtFeatureVerification.
> >
> >thanks,
> >-serge
>
> Thanks Serge ... I didn't tried to make an iscsi install like appears here:
>
> http://berrange.com/posts/2010/05/05/provisioning-kvm-virtual-machines-on-iscsi-the-hard-way-part-2-of-2/
>
> I have tried to install it directly to iscsi san like a physical
> host. Using berrange procedure is like to use RDM in vmware ... Very
> interesting.
>
> But one question, can I use virtio device instead of ide like in
> berrange's doc appears for iscsi disk??

Should be able to, yes. In the end kvm will just treat it as any
raw backing device. If it doesn't work, please do file a bug.

-serge

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 05-16-2011, 09:11 PM
carlopmart
 
Default I can't install ubuntu natty server on a iscsi root device

On 05/16/2011 10:33 PM, Serge Hallyn wrote:

Quoting carlopmart (carlopmart@gmail.com):

On 05/16/2011 08:48 PM, Serge Hallyn wrote:

Quoting carlopmart (carlopmart@gmail.com):

Hi all,

I am trying to install natty server edition on a iscsi root drive
(iscsi target is a rhel6 host). During installation all works ok, I
can connect to iscsi target, partition disk, install packages, etc.
But when ubuntu reboots, nothing appears, screen is black.

How can I debug this?? or Is this a bug?? I am installing this
natty server as a kvm guest under a rhel6 kvm host.


It sounds like a bug, but to talk about it intelligently it'd be
nice to have precise reproduction instructions. I'd encourage you
to file a bug, so we can collect all the information there. Feel
free to file it against 'qemu-kvm (Ubuntu)'. If it turns out to
be something else, we'll re-target it.

To see how I tested iscsi last year, search for 'iscsi boot' at
https://wiki.ubuntu.com/VirtFeatureVerification.

thanks,
-serge


Thanks Serge ... I didn't tried to make an iscsi install like appears here:

http://berrange.com/posts/2010/05/05/provisioning-kvm-virtual-machines-on-iscsi-the-hard-way-part-2-of-2/

I have tried to install it directly to iscsi san like a physical
host. Using berrange procedure is like to use RDM in vmware ... Very
interesting.

But one question, can I use virtio device instead of ide like in
berrange's doc appears for iscsi disk??


Should be able to, yes. In the end kvm will just treat it as any
raw backing device. If it doesn't work, please do file a bug.



Ok, I have tested and I works ...

many thanks.


--
CL Martinez
carlopmart {at} gmail {d0t} com

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 

Thread Tools




All times are GMT. The time now is 10:50 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org