FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Server Development

 
 
LinkBack Thread Tools
 
Old 04-23-2011, 10:56 PM
Asif Iqbal
 
Default one of the virtual interface did not come up after the last kernel upgrade on 10.04.2 LTS

I am running ubuntu 10.04.2 LTS on SUN FIRE X2250.
I rebooted the server, after upgrading from 2.6.32-30-server to
2.6.32-31-server, and the eth0:1 did not come up.

I had to manually run ifup eth0:1 to bring it up.

Here is how my interface file looks like

# cat /etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0 eth0:1 eth0:2 eth0:3 eth0:4
iface eth0 inet static
address 192.168.0.84
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 192.168.3.65 192.168.2.65
dns-search example.net ip.example.net inet.example.net
iface eth0:1 inet static
address 192.168.0.80
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
iface eth0:2 inet static
address 192.168.0.249
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
iface eth0:3 inet static
address 192.168.0.239
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
iface eth0:4 inet static
address 192.168.0.240
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255


Here is the dmesg

http://pastebin.com/UT0U9rFF

any suggestion what could have caused it? and if there is a fix for it?

Thanks

--
Asif Iqbal
PGP Key: 0xE62693C5 KeyServer: pgp.mit.edu
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 04-24-2011, 09:31 PM
Dave Walker
 
Default one of the virtual interface did not come up after the last kernel upgrade on 10.04.2 LTS

On 23/04/11 23:56, Asif Iqbal wrote:

I am running ubuntu 10.04.2 LTS on SUN FIRE X2250.
I rebooted the server, after upgrading from 2.6.32-30-server to
2.6.32-31-server, and the eth0:1 did not come up.

I had to manually run ifup eth0:1 to bring it up.

Here is how my interface file looks like

# cat /etc/network/interfaces


<SNIP>

Hi,

Have you tried reverting to the previous kernel in the boot grub menu?
This will help identify if the issue is infact kernel related, or
something else.


Kind Regards,
Dave Walker

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 

Thread Tools




All times are GMT. The time now is 07:09 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org