FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Server Development

 
 
LinkBack Thread Tools
 
Old 02-28-2009, 03:11 PM
sean darcy
 
Default trouble updating 7.04 -> 7.10

I have running an asterisk voip server on 7.04. I want to upgrade to a
current release. I understand I need first to upgrade to 7.10. I
followed the instructions on
https://help.ubuntu.com/community/GutsyUpgrades

I included the old-releases repos to sources.list, and commented out the
original repos. apt-get update and apt-get upgrade went fine.

But do-release-upgrade didn't.

I'm an ubuntu newbie, so probably missed something obvious. Any help
appreciated.

sean

do-release-upgrade
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
extracting '/tmp/tmpbosIup/gutsy.tar.gz'
authenticate '/tmp/tmpbosIup/gutsy.tar.gz' against
'/tmp/tmpbosIup/gutsy.tar.gz.gpg'

Reading cache

Checking package manager

Continue running under SSH?
This session appears to be running under ssh. It is not recommended to
perform a upgrade over ssh currently because in case of failure it is
harder to recover.

If you continue, a additional ssh daemon will be started at port '9004'.
Do you want to continue?
Continue [yN] y

Starting additional sshd
To make recovery in case of failure easier a additional sshd will be
started on port '9004'. If anything goes wrong with the running ssh you
can still connect to the additional one.

Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
Ignored http://us.archive.ubuntu.com feisty Release.gpg
Failed http://us.archive.ubuntu.com feisty Release.gpg
Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
Done http://old-releases.ubuntu.com feisty Release.gpg
Done http://old-releases.ubuntu.com feisty-updates Release.gpg
Ignored http://us.archive.ubuntu.com feisty Release
Failed http://us.archive.ubuntu.com feisty Release
Done http://old-releases.ubuntu.com feisty-security Release.gpg
Done http://old-releases.ubuntu.com feisty-backports Release.gpg
Hit http://old-releases.ubuntu.com feisty Release
Ignored http://us.archive.ubuntu.com feisty-backports Release
Failed http://us.archive.ubuntu.com feisty-backports Release
Done http://old-releases.ubuntu.com feisty Release
Hit http://old-releases.ubuntu.com feisty-updates Release
Hit http://old-releases.ubuntu.com feisty-security Release
Done http://old-releases.ubuntu.com feisty-updates Release
Done http://old-releases.ubuntu.com feisty-security Release
Ignored http://us.archive.ubuntu.com feisty/multiverse Packages
Failed http://us.archive.ubuntu.com feisty/multiverse Packages
Ignored http://us.archive.ubuntu.com feisty/multiverse Sources
Failed http://us.archive.ubuntu.com feisty/multiverse Sources
Hit http://old-releases.ubuntu.com feisty-backports Release
Done http://old-releases.ubuntu.com feisty-backports Release
Ignored http://us.archive.ubuntu.com
feisty-backports/main/debian-installer Packages
Failed http://us.archive.ubuntu.com
feisty-backports/main/debian-installer Packages
Hit http://old-releases.ubuntu.com feisty/main Packages
Hit http://old-releases.ubuntu.com feisty/restricted Packages
Hit http://old-releases.ubuntu.com feisty/universe Packages
Failed http://us.archive.ubuntu.com feisty/multiverse Packages
Hit http://old-releases.ubuntu.com feisty/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-updates/main Packages
Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
Failed http://us.archive.ubuntu.com feisty/multiverse Sources
Hit http://old-releases.ubuntu.com feisty-security/main Packages
Hit http://old-releases.ubuntu.com feisty-security/restricted Packages
Hit http://old-releases.ubuntu.com feisty-security/universe Packages
Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-backports/main Packages
Failed http://us.archive.ubuntu.com
feisty-backports/main/debian-installer Packages
Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-backports/main Sources
Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources
Hit http://old-releases.ubuntu.com feisty-backports/universe Sources
Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources
Done downloading
Done http://old-releases.ubuntu.com feisty Release.gpg
Done http://old-releases.ubuntu.com feisty-updates Release.gpg
Done http://old-releases.ubuntu.com feisty-security Release.gpg
Ignored http://us.archive.ubuntu.com feisty Release.gpg
Failed http://us.archive.ubuntu.com feisty Release.gpg
Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
Done http://old-releases.ubuntu.com feisty-backports Release.gpg
Hit http://old-releases.ubuntu.com feisty Release
Ignored http://us.archive.ubuntu.com feisty Release
Failed http://us.archive.ubuntu.com feisty Release
Done http://old-releases.ubuntu.com feisty Release
Hit http://old-releases.ubuntu.com feisty-updates Release
Hit http://old-releases.ubuntu.com feisty-security Release
Done http://old-releases.ubuntu.com feisty-updates Release
Ignored http://us.archive.ubuntu.com feisty-backports Release
Failed http://us.archive.ubuntu.com feisty-backports Release
Done http://old-releases.ubuntu.com feisty-security Release
Hit http://old-releases.ubuntu.com feisty-backports Release
Done http://old-releases.ubuntu.com feisty-backports Release
Ignored http://us.archive.ubuntu.com feisty/multiverse Packages
Failed http://us.archive.ubuntu.com feisty/multiverse Packages
Ignored http://us.archive.ubuntu.com feisty/multiverse Sources
Failed http://us.archive.ubuntu.com feisty/multiverse Sources
Hit http://old-releases.ubuntu.com feisty/main Packages
Hit http://old-releases.ubuntu.com feisty/restricted Packages
Hit http://old-releases.ubuntu.com feisty/universe Packages
Hit http://old-releases.ubuntu.com feisty/multiverse Packages
Ignored http://us.archive.ubuntu.com
feisty-backports/main/debian-installer Packages
Failed http://us.archive.ubuntu.com
feisty-backports/main/debian-installer Packages
Hit http://old-releases.ubuntu.com feisty-updates/main Packages
Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
Failed http://us.archive.ubuntu.com feisty/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-security/main Packages
Hit http://old-releases.ubuntu.com feisty-security/restricted Packages
Hit http://old-releases.ubuntu.com feisty-security/universe Packages
Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-backports/main Packages
Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
Failed http://us.archive.ubuntu.com feisty/multiverse Sources
Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-backports/main Sources
Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources
Hit http://old-releases.ubuntu.com feisty-backports/universe Sources
Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources
Failed http://us.archive.ubuntu.com
feisty-backports/main/debian-installer Packages
Done downloading
Ignored http://us.archive.ubuntu.com feisty Release.gpg
Failed http://us.archive.ubuntu.com feisty Release.gpg
Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
Done http://old-releases.ubuntu.com feisty Release.gpg
Done http://old-releases.ubuntu.com feisty-updates Release.gpg
Done http://old-releases.ubuntu.com feisty-security Release.gpg
Done http://old-releases.ubuntu.com feisty-backports Release.gpg
Ignored http://us.archive.ubuntu.com feisty Release
Failed http://us.archive.ubuntu.com feisty Release
Hit http://old-releases.ubuntu.com feisty Release
Done http://old-releases.ubuntu.com feisty Release
Ignored http://us.archive.ubuntu.com feisty-backports Release
Failed http://us.archive.ubuntu.com feisty-backports Release
Hit http://old-releases.ubuntu.com feisty-updates Release
Hit http://old-releases.ubuntu.com feisty-security Release
Done http://old-releases.ubuntu.com feisty-updates Release
Done http://old-releases.ubuntu.com feisty-security Release
Ignored http://us.archive.ubuntu.com feisty/multiverse Packages
Failed http://us.archive.ubuntu.com feisty/multiverse Packages
Ignored http://us.archive.ubuntu.com feisty/multiverse Sources
Failed http://us.archive.ubuntu.com feisty/multiverse Sources
Hit http://old-releases.ubuntu.com feisty-backports Release
Done http://old-releases.ubuntu.com feisty-backports Release
Ignored http://us.archive.ubuntu.com
feisty-backports/main/debian-installer Packages
Failed http://us.archive.ubuntu.com
feisty-backports/main/debian-installer Packages
Hit http://old-releases.ubuntu.com feisty/main Packages
Hit http://old-releases.ubuntu.com feisty/restricted Packages
Hit http://old-releases.ubuntu.com feisty/universe Packages
Hit http://old-releases.ubuntu.com feisty/multiverse Packages
Failed http://us.archive.ubuntu.com feisty/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-updates/main Packages
Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-security/main Packages
Hit http://old-releases.ubuntu.com feisty-security/restricted Packages
Failed http://us.archive.ubuntu.com feisty/multiverse Sources
Hit http://old-releases.ubuntu.com feisty-security/universe Packages
Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-backports/main Packages
Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
Failed http://us.archive.ubuntu.com
feisty-backports/main/debian-installer Packages
Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-backports/main Sources
Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources
Hit http://old-releases.ubuntu.com feisty-backports/universe Sources
Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources
Done downloading
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done

Getting upgrade prerequisites failed
The system was unable to get the prerequisites for the upgrade. The
upgrade will abort now and restore the original system state.

Please report this as a bug against the 'update-manager' package and
include the files in /var/log/dist-upgrade/ in the bugreport.

Restoring original system state

Aborting
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done


--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 02-28-2009, 05:03 PM
sean darcy
 
Default trouble updating 7.04 -> 7.10

sean darcy wrote:
> I have running an asterisk voip server on 7.04. I want to upgrade to a
> current release. I understand I need first to upgrade to 7.10. I
> followed the instructions on
> https://help.ubuntu.com/community/GutsyUpgrades
>
> I included the old-releases repos to sources.list, and commented out the
> original repos. apt-get update and apt-get upgrade went fine.
>
> But do-release-upgrade didn't.
>
> I'm an ubuntu newbie, so probably missed something obvious. Any help
> appreciated.
>
> sean
>
> do-release-upgrade
> Checking for a new ubuntu release
> Done Upgrade tool signature
> Done Upgrade tool
> Done downloading
> extracting '/tmp/tmpbosIup/gutsy.tar.gz'
> authenticate '/tmp/tmpbosIup/gutsy.tar.gz' against
> '/tmp/tmpbosIup/gutsy.tar.gz.gpg'
>
> Reading cache
>
> Checking package manager
>
> Continue running under SSH?
> This session appears to be running under ssh. It is not recommended to
> perform a upgrade over ssh currently because in case of failure it is
> harder to recover.
>
> If you continue, a additional ssh daemon will be started at port '9004'.
> Do you want to continue?
> Continue [yN] y
>
> Starting additional sshd
> To make recovery in case of failure easier a additional sshd will be
> started on port '9004'. If anything goes wrong with the running ssh you
> can still connect to the additional one.
>
> Reading package lists: Done
> Reading state information: Done
> Reading state information: Done
> Reading state information: Done
> Ignored http://us.archive.ubuntu.com feisty Release.gpg
> Failed http://us.archive.ubuntu.com feisty Release.gpg
> Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
> Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
> Done http://old-releases.ubuntu.com feisty Release.gpg
> Done http://old-releases.ubuntu.com feisty-updates Release.gpg
> Ignored http://us.archive.ubuntu.com feisty Release
> Failed http://us.archive.ubuntu.com feisty Release
> Done http://old-releases.ubuntu.com feisty-security Release.gpg
> Done http://old-releases.ubuntu.com feisty-backports Release.gpg
> Hit http://old-releases.ubuntu.com feisty Release
> Ignored http://us.archive.ubuntu.com feisty-backports Release
> Failed http://us.archive.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty Release
> Hit http://old-releases.ubuntu.com feisty-updates Release
> Hit http://old-releases.ubuntu.com feisty-security Release
> Done http://old-releases.ubuntu.com feisty-updates Release
> Done http://old-releases.ubuntu.com feisty-security Release
> Ignored http://us.archive.ubuntu.com feisty/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Ignored http://us.archive.ubuntu.com feisty/multiverse Sources
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty-backports Release
> Ignored http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty/main Packages
> Hit http://old-releases.ubuntu.com feisty/restricted Packages
> Hit http://old-releases.ubuntu.com feisty/universe Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-updates/main Packages
> Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
> Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-security/main Packages
> Hit http://old-releases.ubuntu.com feisty-security/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-security/universe Packages
> Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Sources
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources
> Hit http://old-releases.ubuntu.com feisty-backports/universe Sources
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources
> Done downloading
> Done http://old-releases.ubuntu.com feisty Release.gpg
> Done http://old-releases.ubuntu.com feisty-updates Release.gpg
> Done http://old-releases.ubuntu.com feisty-security Release.gpg
> Ignored http://us.archive.ubuntu.com feisty Release.gpg
> Failed http://us.archive.ubuntu.com feisty Release.gpg
> Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
> Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
> Done http://old-releases.ubuntu.com feisty-backports Release.gpg
> Hit http://old-releases.ubuntu.com feisty Release
> Ignored http://us.archive.ubuntu.com feisty Release
> Failed http://us.archive.ubuntu.com feisty Release
> Done http://old-releases.ubuntu.com feisty Release
> Hit http://old-releases.ubuntu.com feisty-updates Release
> Hit http://old-releases.ubuntu.com feisty-security Release
> Done http://old-releases.ubuntu.com feisty-updates Release
> Ignored http://us.archive.ubuntu.com feisty-backports Release
> Failed http://us.archive.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty-security Release
> Hit http://old-releases.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty-backports Release
> Ignored http://us.archive.ubuntu.com feisty/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Ignored http://us.archive.ubuntu.com feisty/multiverse Sources
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty/main Packages
> Hit http://old-releases.ubuntu.com feisty/restricted Packages
> Hit http://old-releases.ubuntu.com feisty/universe Packages
> Hit http://old-releases.ubuntu.com feisty/multiverse Packages
> Ignored http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty-updates/main Packages
> Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
> Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-security/main Packages
> Hit http://old-releases.ubuntu.com feisty-security/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-security/universe Packages
> Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Packages
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Sources
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources
> Hit http://old-releases.ubuntu.com feisty-backports/universe Sources
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Done downloading
> Ignored http://us.archive.ubuntu.com feisty Release.gpg
> Failed http://us.archive.ubuntu.com feisty Release.gpg
> Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
> Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
> Done http://old-releases.ubuntu.com feisty Release.gpg
> Done http://old-releases.ubuntu.com feisty-updates Release.gpg
> Done http://old-releases.ubuntu.com feisty-security Release.gpg
> Done http://old-releases.ubuntu.com feisty-backports Release.gpg
> Ignored http://us.archive.ubuntu.com feisty Release
> Failed http://us.archive.ubuntu.com feisty Release
> Hit http://old-releases.ubuntu.com feisty Release
> Done http://old-releases.ubuntu.com feisty Release
> Ignored http://us.archive.ubuntu.com feisty-backports Release
> Failed http://us.archive.ubuntu.com feisty-backports Release
> Hit http://old-releases.ubuntu.com feisty-updates Release
> Hit http://old-releases.ubuntu.com feisty-security Release
> Done http://old-releases.ubuntu.com feisty-updates Release
> Done http://old-releases.ubuntu.com feisty-security Release
> Ignored http://us.archive.ubuntu.com feisty/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Ignored http://us.archive.ubuntu.com feisty/multiverse Sources
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty-backports Release
> Ignored http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty/main Packages
> Hit http://old-releases.ubuntu.com feisty/restricted Packages
> Hit http://old-releases.ubuntu.com feisty/universe Packages
> Hit http://old-releases.ubuntu.com feisty/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-updates/main Packages
> Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
> Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-security/main Packages
> Hit http://old-releases.ubuntu.com feisty-security/restricted Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-security/universe Packages
> Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Packages
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Sources
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources
> Hit http://old-releases.ubuntu.com feisty-backports/universe Sources
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources
> Done downloading
> Reading package lists: Done
> Reading state information: Done
> Reading state information: Done
> Reading state information: Done
>
> Getting upgrade prerequisites failed
> The system was unable to get the prerequisites for the upgrade. The
> upgrade will abort now and restore the original system state.
>
> Please report this as a bug against the 'update-manager' package and
> include the files in /var/log/dist-upgrade/ in the bugreport.
>
> Restoring original system state
>
> Aborting
> Reading package lists: Done
> Reading state information: Done
> Reading state information: Done
> Reading state information: Done
>
>
I don't understand why it tries to use //us.archive.ubuntu.com.

FWIW here's main.log:

cat dist-upgrade/main.log
2009-02-28 12:57:06,594 INFO release-upgrader version '0.81' started
2009-02-28 12:57:06,657 DEBUG lsb-release: 'feisty'
2009-02-28 12:57:10,415 DEBUG _pythonSymlinkCheck run
2009-02-28 12:57:11,005 DEBUG checkViewDepends()
2009-02-28 12:57:11,005 DEBUG getRequiredBackports()
2009-02-28 12:57:11,975 ERROR IOError in cache.update(): 'Failed to
fetch
http://us.archive.ubuntu.com/ubuntu/dists/feisty-backports/main/debian-installer/binary-i386/Packages.gz
404 Not Found [IP: 91.189.88.31 80]
'. Retrying (currentRetry: 0)
2009-02-28 12:57:12,901 ERROR IOError in cache.update(): 'Failed to
fetch
http://us.archive.ubuntu.com/ubuntu/dists/feisty-backports/main/debian-installer/binary-i386/Packages.gz
404 Not Found [IP: 91.189.88.46 80]
'. Retrying (currentRetry: 1)
2009-02-28 12:57:13,841 ERROR IOError in cache.update(): 'Failed to
fetch
http://us.archive.ubuntu.com/ubuntu/dists/feisty-backports/main/debian-installer/binary-i386/Packages.gz
404 Not Found [IP: 91.189.88.45 80]
'. Retrying (currentRetry: 2)
2009-02-28 12:57:13,841 ERROR doUpdate() failed complettely
2009-02-28 12:57:14,487 ERROR Can not find backport 'release-upgrader-apt'

sean


--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 02-28-2009, 05:22 PM
Ante Karamatić
 
Default trouble updating 7.04 -> 7.10

U Sub, 28. 02. 2009., u 13:03 -0500, sean darcy je napisao/la:

> I don't understand why it tries to use //us.archive.ubuntu.com.

I've just installed feisty in my virtual system, and I'll be able to
check upgrade problems in couple of hours. So, get back later for
information.



--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 02-28-2009, 05:52 PM
Victor Padro
 
Default trouble updating 7.04 -> 7.10

On Sat, Feb 28, 2009 at 10:11 AM, sean darcy <seandarcy2@gmail.com> wrote:

I have running an asterisk voip server on 7.04. I want to upgrade to a

current release. I understand I need first to upgrade to 7.10. I

followed the instructions on

https://help.ubuntu.com/community/GutsyUpgrades



I included the old-releases repos to sources.list, and commented out the

original repos. apt-get update and apt-get upgrade went fine.



But do-release-upgrade didn't.



I'm an ubuntu newbie, so probably missed something obvious. Any help

appreciated.



sean



do-release-upgrade

Checking for a new ubuntu release

Done Upgrade tool signature

Done Upgrade tool

Done downloading

extracting '/tmp/tmpbosIup/gutsy.tar.gz'

authenticate '/tmp/tmpbosIup/gutsy.tar.gz' against

'/tmp/tmpbosIup/gutsy.tar.gz.gpg'



Reading cache



Checking package manager



Continue running under SSH?

This session appears to be running under ssh. It is not recommended to

perform a upgrade over ssh currently because in case of failure it is

harder to recover.



If you continue, a additional ssh daemon will be started at port '9004'.

Do you want to continue?

Continue [yN] y



Starting additional sshd

To make recovery in case of failure easier a additional sshd will be

started on port '9004'. If anything goes wrong with the running ssh you

can still connect to the additional one.



Reading package lists: Done

Reading state information: Done

Reading state information: Done

Reading state information: Done

Ignored http://us.archive.ubuntu.com feisty Release.gpg

Failed http://us.archive.ubuntu.com feisty Release.gpg

Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg

Failed http://us.archive.ubuntu.com feisty-backports Release.gpg

Done http://old-releases.ubuntu.com feisty Release.gpg

Done http://old-releases.ubuntu.com feisty-updates Release.gpg

Ignored http://us.archive.ubuntu.com feisty Release

Failed http://us.archive.ubuntu.com feisty Release

Done http://old-releases.ubuntu.com feisty-security Release.gpg

Done http://old-releases.ubuntu.com feisty-backports Release.gpg

Hit http://old-releases.ubuntu.com feisty Release

Ignored http://us.archive.ubuntu.com feisty-backports Release

Failed http://us.archive.ubuntu.com feisty-backports Release

Done http://old-releases.ubuntu.com feisty Release

Hit http://old-releases.ubuntu.com feisty-updates Release

Hit http://old-releases.ubuntu.com feisty-security Release

Done http://old-releases.ubuntu.com feisty-updates Release

Done http://old-releases.ubuntu.com feisty-security Release

Ignored http://us.archive.ubuntu.com feisty/multiverse Packages

Failed http://us.archive.ubuntu.com feisty/multiverse Packages

Ignored http://us.archive.ubuntu.com feisty/multiverse Sources

Failed http://us.archive.ubuntu.com feisty/multiverse Sources

Hit http://old-releases.ubuntu.com feisty-backports Release

Done http://old-releases.ubuntu.com feisty-backports Release

Ignored http://us.archive.ubuntu.com

feisty-backports/main/debian-installer Packages

Failed http://us.archive.ubuntu.com

feisty-backports/main/debian-installer Packages

Hit http://old-releases.ubuntu.com feisty/main Packages

Hit http://old-releases.ubuntu.com feisty/restricted Packages

Hit http://old-releases.ubuntu.com feisty/universe Packages

Failed http://us.archive.ubuntu.com feisty/multiverse Packages

Hit http://old-releases.ubuntu.com feisty/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-updates/main Packages

Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages

Hit http://old-releases.ubuntu.com feisty-updates/universe Packages

Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages

Failed http://us.archive.ubuntu.com feisty/multiverse Sources

Hit http://old-releases.ubuntu.com feisty-security/main Packages

Hit http://old-releases.ubuntu.com feisty-security/restricted Packages

Hit http://old-releases.ubuntu.com feisty-security/universe Packages

Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-backports/main Packages

Failed http://us.archive.ubuntu.com

feisty-backports/main/debian-installer Packages

Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages

Hit http://old-releases.ubuntu.com feisty-backports/universe Packages

Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-backports/main Sources

Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources

Hit http://old-releases.ubuntu.com feisty-backports/universe Sources

Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources

Done downloading

Done http://old-releases.ubuntu.com feisty Release.gpg

Done http://old-releases.ubuntu.com feisty-updates Release.gpg

Done http://old-releases.ubuntu.com feisty-security Release.gpg

Ignored http://us.archive.ubuntu.com feisty Release.gpg

Failed http://us.archive.ubuntu.com feisty Release.gpg

Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg

Failed http://us.archive.ubuntu.com feisty-backports Release.gpg

Done http://old-releases.ubuntu.com feisty-backports Release.gpg

Hit http://old-releases.ubuntu.com feisty Release

Ignored http://us.archive.ubuntu.com feisty Release

Failed http://us.archive.ubuntu.com feisty Release

Done http://old-releases.ubuntu.com feisty Release

Hit http://old-releases.ubuntu.com feisty-updates Release

Hit http://old-releases.ubuntu.com feisty-security Release

Done http://old-releases.ubuntu.com feisty-updates Release

Ignored http://us.archive.ubuntu.com feisty-backports Release

Failed http://us.archive.ubuntu.com feisty-backports Release

Done http://old-releases.ubuntu.com feisty-security Release

Hit http://old-releases.ubuntu.com feisty-backports Release

Done http://old-releases.ubuntu.com feisty-backports Release

Ignored http://us.archive.ubuntu.com feisty/multiverse Packages

Failed http://us.archive.ubuntu.com feisty/multiverse Packages

Ignored http://us.archive.ubuntu.com feisty/multiverse Sources

Failed http://us.archive.ubuntu.com feisty/multiverse Sources

Hit http://old-releases.ubuntu.com feisty/main Packages

Hit http://old-releases.ubuntu.com feisty/restricted Packages

Hit http://old-releases.ubuntu.com feisty/universe Packages

Hit http://old-releases.ubuntu.com feisty/multiverse Packages

Ignored http://us.archive.ubuntu.com

feisty-backports/main/debian-installer Packages

Failed http://us.archive.ubuntu.com

feisty-backports/main/debian-installer Packages

Hit http://old-releases.ubuntu.com feisty-updates/main Packages

Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages

Hit http://old-releases.ubuntu.com feisty-updates/universe Packages

Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages

Failed http://us.archive.ubuntu.com feisty/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-security/main Packages

Hit http://old-releases.ubuntu.com feisty-security/restricted Packages

Hit http://old-releases.ubuntu.com feisty-security/universe Packages

Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-backports/main Packages

Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages

Failed http://us.archive.ubuntu.com feisty/multiverse Sources

Hit http://old-releases.ubuntu.com feisty-backports/universe Packages

Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-backports/main Sources

Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources

Hit http://old-releases.ubuntu.com feisty-backports/universe Sources

Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources

Failed http://us.archive.ubuntu.com

feisty-backports/main/debian-installer Packages

Done downloading

Ignored http://us.archive.ubuntu.com feisty Release.gpg

Failed http://us.archive.ubuntu.com feisty Release.gpg

Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg

Failed http://us.archive.ubuntu.com feisty-backports Release.gpg

Done http://old-releases.ubuntu.com feisty Release.gpg

Done http://old-releases.ubuntu.com feisty-updates Release.gpg

Done http://old-releases.ubuntu.com feisty-security Release.gpg

Done http://old-releases.ubuntu.com feisty-backports Release.gpg

Ignored http://us.archive.ubuntu.com feisty Release

Failed http://us.archive.ubuntu.com feisty Release

Hit http://old-releases.ubuntu.com feisty Release

Done http://old-releases.ubuntu.com feisty Release

Ignored http://us.archive.ubuntu.com feisty-backports Release

Failed http://us.archive.ubuntu.com feisty-backports Release

Hit http://old-releases.ubuntu.com feisty-updates Release

Hit http://old-releases.ubuntu.com feisty-security Release

Done http://old-releases.ubuntu.com feisty-updates Release

Done http://old-releases.ubuntu.com feisty-security Release

Ignored http://us.archive.ubuntu.com feisty/multiverse Packages

Failed http://us.archive.ubuntu.com feisty/multiverse Packages

Ignored http://us.archive.ubuntu.com feisty/multiverse Sources

Failed http://us.archive.ubuntu.com feisty/multiverse Sources

Hit http://old-releases.ubuntu.com feisty-backports Release

Done http://old-releases.ubuntu.com feisty-backports Release

Ignored http://us.archive.ubuntu.com

feisty-backports/main/debian-installer Packages

Failed http://us.archive.ubuntu.com

feisty-backports/main/debian-installer Packages

Hit http://old-releases.ubuntu.com feisty/main Packages

Hit http://old-releases.ubuntu.com feisty/restricted Packages

Hit http://old-releases.ubuntu.com feisty/universe Packages

Hit http://old-releases.ubuntu.com feisty/multiverse Packages

Failed http://us.archive.ubuntu.com feisty/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-updates/main Packages

Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages

Hit http://old-releases.ubuntu.com feisty-updates/universe Packages

Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-security/main Packages

Hit http://old-releases.ubuntu.com feisty-security/restricted Packages

Failed http://us.archive.ubuntu.com feisty/multiverse Sources

Hit http://old-releases.ubuntu.com feisty-security/universe Packages

Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-backports/main Packages

Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages

Failed http://us.archive.ubuntu.com

feisty-backports/main/debian-installer Packages

Hit http://old-releases.ubuntu.com feisty-backports/universe Packages

Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages

Hit http://old-releases.ubuntu.com feisty-backports/main Sources

Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources

Hit http://old-releases.ubuntu.com feisty-backports/universe Sources

Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources

Done downloading

Reading package lists: Done

Reading state information: Done

Reading state information: Done

Reading state information: Done



Getting upgrade prerequisites failed

The system was unable to get the prerequisites for the upgrade. The

upgrade will abort now and restore the original system state.



Please report this as a bug against the 'update-manager' package and

include the files in /var/log/dist-upgrade/ in the bugreport.



Restoring original system state



Aborting

Reading package lists: Done

Reading state information: Done

Reading state information: Done

Reading state information: Done





--

ubuntu-server mailing list

ubuntu-server@lists.ubuntu.com

https://lists.ubuntu.com/mailman/listinfo/ubuntu-server

More info: https://wiki.ubuntu.com/ServerTeam


Why don't you consider a fresh install instead of updrading 7.04 to 7.10, then 7.10 to 8.04, and finally 8.04 to 8.10(optional)?
Things could get broken in the path, specially if it's server related upgrade.

Cheers.

--
"It is human nature to think wisely and act in an absurd fashion."

"Todo el desorden del mundo proviene de las profesiones mal o mediocremente servidas"

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 02-28-2009, 06:46 PM
sean darcy
 
Default trouble updating 7.04 -> 7.10

Ante Karamatić wrote:
> U Sub, 28. 02. 2009., u 13:03 -0500, sean darcy je napisao/la:
>
>> I don't understand why it tries to use //us.archive.ubuntu.com.
>
> I've just installed feisty in my virtual system, and I'll be able to
> check upgrade problems in couple of hours. So, get back later for
> information.
>
>
>
Thanks. In the mean time I've think I've narrowed it down.

Each time it runs do-release-upgrade sticks the name of the local mirror in:

cat sources.list.d/prerequists-sources.list
# sources.list fragment for pre-requists (one with countrymirror, one
fallback)
deb http://us.archive.ubuntu.com/ubuntu feisty-backports
main/debian-installer

It'll overwrite whatever is there. And, of course,
us.archive.ubuntu.com does have feisty.

I tried the trick in https://help.ubuntu.com/community/UpgradeProblems
of setting the ip address for us.archive.ubuntu.com to the address for
old-releases. That didn't work because because the nslookup ip address
doesn't actually resolve to the same place as old-releases.ubuntu.com.

sean


--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 02-28-2009, 06:48 PM
sean darcy
 
Default trouble updating 7.04 -> 7.10

Victor Padro wrote:
>
>
> On Sat, Feb 28, 2009 at 10:11 AM, sean darcy <seandarcy2@gmail.com
> <mailto:seandarcy2@gmail.com>> wrote:
>
> I have running an asterisk voip server on 7.04. I want to upgrade to a
> current release. I understand I need first to upgrade to 7.10. I
> followed the instructions on
> https://help.ubuntu.com/community/GutsyUpgrades
>
> I included the old-releases repos to sources.list, and commented out the
> original repos. apt-get update and apt-get upgrade went fine.
>
> But do-release-upgrade didn't.
>
> I'm an ubuntu newbie, so probably missed something obvious. Any help
> appreciated.
>
> sean
>
> do-release-upgrade
> Checking for a new ubuntu release
> Done Upgrade tool signature
> Done Upgrade tool
> Done downloading
> extracting '/tmp/tmpbosIup/gutsy.tar.gz'
> authenticate '/tmp/tmpbosIup/gutsy.tar.gz' against
> '/tmp/tmpbosIup/gutsy.tar.gz.gpg'
>
> Reading cache
>
> Checking package manager
>
> Continue running under SSH?
> This session appears to be running under ssh. It is not recommended to
> perform a upgrade over ssh currently because in case of failure it is
> harder to recover.
>
> If you continue, a additional ssh daemon will be started at port '9004'.
> Do you want to continue?
> Continue [yN] y
>
> Starting additional sshd
> To make recovery in case of failure easier a additional sshd will be
> started on port '9004'. If anything goes wrong with the running ssh you
> can still connect to the additional one.
>
> Reading package lists: Done
> Reading state information: Done
> Reading state information: Done
> Reading state information: Done
> Ignored http://us.archive.ubuntu.com feisty Release.gpg
> Failed http://us.archive.ubuntu.com feisty Release.gpg
> Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
> Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
> Done http://old-releases.ubuntu.com feisty Release.gpg
> Done http://old-releases.ubuntu.com feisty-updates Release.gpg
> Ignored http://us.archive.ubuntu.com feisty Release
> Failed http://us.archive.ubuntu.com feisty Release
> Done http://old-releases.ubuntu.com feisty-security Release.gpg
> Done http://old-releases.ubuntu.com feisty-backports Release.gpg
> Hit http://old-releases.ubuntu.com feisty Release
> Ignored http://us.archive.ubuntu.com feisty-backports Release
> Failed http://us.archive.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty Release
> Hit http://old-releases.ubuntu.com feisty-updates Release
> Hit http://old-releases.ubuntu.com feisty-security Release
> Done http://old-releases.ubuntu.com feisty-updates Release
> Done http://old-releases.ubuntu.com feisty-security Release
> Ignored http://us.archive.ubuntu.com feisty/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Ignored http://us.archive.ubuntu.com feisty/multiverse Sources
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty-backports Release
> Ignored http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty/main Packages
> Hit http://old-releases.ubuntu.com feisty/restricted Packages
> Hit http://old-releases.ubuntu.com feisty/universe Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-updates/main Packages
> Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
> Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-security/main Packages
> Hit http://old-releases.ubuntu.com feisty-security/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-security/universe Packages
> Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Sources
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources
> Hit http://old-releases.ubuntu.com feisty-backports/universe Sources
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources
> Done downloading
> Done http://old-releases.ubuntu.com feisty Release.gpg
> Done http://old-releases.ubuntu.com feisty-updates Release.gpg
> Done http://old-releases.ubuntu.com feisty-security Release.gpg
> Ignored http://us.archive.ubuntu.com feisty Release.gpg
> Failed http://us.archive.ubuntu.com feisty Release.gpg
> Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
> Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
> Done http://old-releases.ubuntu.com feisty-backports Release.gpg
> Hit http://old-releases.ubuntu.com feisty Release
> Ignored http://us.archive.ubuntu.com feisty Release
> Failed http://us.archive.ubuntu.com feisty Release
> Done http://old-releases.ubuntu.com feisty Release
> Hit http://old-releases.ubuntu.com feisty-updates Release
> Hit http://old-releases.ubuntu.com feisty-security Release
> Done http://old-releases.ubuntu.com feisty-updates Release
> Ignored http://us.archive.ubuntu.com feisty-backports Release
> Failed http://us.archive.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty-security Release
> Hit http://old-releases.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty-backports Release
> Ignored http://us.archive.ubuntu.com feisty/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Ignored http://us.archive.ubuntu.com feisty/multiverse Sources
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty/main Packages
> Hit http://old-releases.ubuntu.com feisty/restricted Packages
> Hit http://old-releases.ubuntu.com feisty/universe Packages
> Hit http://old-releases.ubuntu.com feisty/multiverse Packages
> Ignored http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty-updates/main Packages
> Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
> Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-security/main Packages
> Hit http://old-releases.ubuntu.com feisty-security/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-security/universe Packages
> Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Packages
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Sources
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources
> Hit http://old-releases.ubuntu.com feisty-backports/universe Sources
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Done downloading
> Ignored http://us.archive.ubuntu.com feisty Release.gpg
> Failed http://us.archive.ubuntu.com feisty Release.gpg
> Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
> Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
> Done http://old-releases.ubuntu.com feisty Release.gpg
> Done http://old-releases.ubuntu.com feisty-updates Release.gpg
> Done http://old-releases.ubuntu.com feisty-security Release.gpg
> Done http://old-releases.ubuntu.com feisty-backports Release.gpg
> Ignored http://us.archive.ubuntu.com feisty Release
> Failed http://us.archive.ubuntu.com feisty Release
> Hit http://old-releases.ubuntu.com feisty Release
> Done http://old-releases.ubuntu.com feisty Release
> Ignored http://us.archive.ubuntu.com feisty-backports Release
> Failed http://us.archive.ubuntu.com feisty-backports Release
> Hit http://old-releases.ubuntu.com feisty-updates Release
> Hit http://old-releases.ubuntu.com feisty-security Release
> Done http://old-releases.ubuntu.com feisty-updates Release
> Done http://old-releases.ubuntu.com feisty-security Release
> Ignored http://us.archive.ubuntu.com feisty/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Ignored http://us.archive.ubuntu.com feisty/multiverse Sources
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-backports Release
> Done http://old-releases.ubuntu.com feisty-backports Release
> Ignored http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty/main Packages
> Hit http://old-releases.ubuntu.com feisty/restricted Packages
> Hit http://old-releases.ubuntu.com feisty/universe Packages
> Hit http://old-releases.ubuntu.com feisty/multiverse Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-updates/main Packages
> Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
> Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
> Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-security/main Packages
> Hit http://old-releases.ubuntu.com feisty-security/restricted Packages
> Failed http://us.archive.ubuntu.com feisty/multiverse Sources
> Hit http://old-releases.ubuntu.com feisty-security/universe Packages
> Hit http://old-releases.ubuntu.com feisty-security/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Packages
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
> Failed http://us.archive.ubuntu.com
> feisty-backports/main/debian-installer Packages
> Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
> Hit http://old-releases.ubuntu.com feisty-backports/main Sources
> Hit http://old-releases.ubuntu.com feisty-backports/restricted Sources
> Hit http://old-releases.ubuntu.com feisty-backports/universe Sources
> Hit http://old-releases.ubuntu.com feisty-backports/multiverse Sources
> Done downloading
> Reading package lists: Done
> Reading state information: Done
> Reading state information: Done
> Reading state information: Done
>
> Getting upgrade prerequisites failed
> The system was unable to get the prerequisites for the upgrade. The
> upgrade will abort now and restore the original system state.
>
> Please report this as a bug against the 'update-manager' package and
> include the files in /var/log/dist-upgrade/ in the bugreport.
>
> Restoring original system state
>
> Aborting
> Reading package lists: Done
> Reading state information: Done
> Reading state information: Done
> Reading state information: Done
>
>
> --
> ubuntu-server mailing list
> ubuntu-server@lists.ubuntu.com <mailto:ubuntu-server@lists.ubuntu.com>
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
> More info: https://wiki.ubuntu.com/ServerTeam
>
>
> Why don't you consider a fresh install instead of updrading 7.04 to
> 7.10, then 7.10 to 8.04, and finally 8.04 to 8.10(optional)?
> Things could get broken in the path, specially if it's server related
> upgrade.
>
> Cheers.
>
This machine is long long way away. If it breaks, it's cheaper to send
another. In any event, it's a server. the whole idea is not mess with it
directly. It's headless, and may not even have a dvd drive.

sean


--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 02-28-2009, 08:22 PM
sean darcy
 
Default trouble updating 7.04 -> 7.10

sean darcy wrote:
> Ante Karamatić wrote:
>> U Sub, 28. 02. 2009., u 13:03 -0500, sean darcy je napisao/la:
>>
>>> I don't understand why it tries to use //us.archive.ubuntu.com.
>> I've just installed feisty in my virtual system, and I'll be able to
>> check upgrade problems in couple of hours. So, get back later for
>> information.
>>
>>
>>
> Thanks. In the mean time I've think I've narrowed it down.
>
> Each time it runs do-release-upgrade sticks the name of the local mirror in:
>
> cat sources.list.d/prerequists-sources.list
> # sources.list fragment for pre-requists (one with countrymirror, one
> fallback)
> deb http://us.archive.ubuntu.com/ubuntu feisty-backports
> main/debian-installer
>
> It'll overwrite whatever is there. And, of course,
> us.archive.ubuntu.com does have feisty.
>
> I tried the trick in https://help.ubuntu.com/community/UpgradeProblems
> of setting the ip address for us.archive.ubuntu.com to the address for
> old-releases. That didn't work because because the nslookup ip address
> doesn't actually resolve to the same place as old-releases.ubuntu.com. Probably vhost.
>
> sean
>

Turns out this is bug 153980, which has been known for over a year. And
not fixed.

seam


--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 02-28-2009, 09:06 PM
sean darcy
 
Default trouble updating 7.04 -> 7.10

sean darcy wrote:
> Ante Karamatić wrote:
>> U Sub, 28. 02. 2009., u 13:03 -0500, sean darcy je napisao/la:
>>
>>> I don't understand why it tries to use //us.archive.ubuntu.com.
>> I've just installed feisty in my virtual system, and I'll be able to
>> check upgrade problems in couple of hours. So, get back later for
>> information.
>>
>>
>>
> Thanks. In the mean time I've think I've narrowed it down.
>
> Each time it runs do-release-upgrade sticks the name of the local mirror in:
>
> cat sources.list.d/prerequists-sources.list
> # sources.list fragment for pre-requists (one with countrymirror, one
> fallback)
> deb http://us.archive.ubuntu.com/ubuntu feisty-backports
> main/debian-installer
>
> It'll overwrite whatever is there. And, of course,
> us.archive.ubuntu.com does have feisty.
>

And, of course, us.archive.ubuntu.com does _NOT_ have feisty.

sean


--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 02-28-2009, 10:00 PM
TJ
 
Default trouble updating 7.04 -> 7.10

On Sat, 2009-02-28 at 17:06 -0500, sean darcy wrote:

> > It'll overwrite whatever is there. And, of course,
> > us.archive.ubuntu.com does have feisty.
> >
>
> And, of course, us.archive.ubuntu.com does _NOT_ have feisty


Sean, how about using a read-only file system to prevent the unwanted
change?

*If* it doesn't cause do-release-upgrade to throw a wobbly this might
work:

sudo -i

dd if=/dev/zero of=/tmp/sources.list.d bs=1024 count=2048
losetup /dev/loop1 /tmp/sources.list.d
mkfs.ext2 /dev/loop1
mkdir /mnt/apt
mount /dev/loop1 /mnt/apt
mv /etc/apt/sources.list.d/* /mnt/apt/

# make the changes to /mnt/apt/prerequists-sources.list

umount /mnt/apt
mount -o ro /dev/loop1 /etc/apt/sources.list.d

do-release-upgrade

# Obviously, at the end of the process, put things back as they were:

umount /etc/apt/sources.list.d
mount /dev/loop1 /mnt/apt
mv /mnt/apt/* /etc/apt/sources.list.d/
umount /mnt/apt
losetup -d /dev/loop1
rm /tmp/sources.list.d



--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 02-28-2009, 10:29 PM
sean darcy
 
Default trouble updating 7.04 -> 7.10

TJ wrote:
> On Sat, 2009-02-28 at 17:06 -0500, sean darcy wrote:
>
>>> It'll overwrite whatever is there. And, of course,
>>> us.archive.ubuntu.com does have feisty.
>>>
>> And, of course, us.archive.ubuntu.com does _NOT_ have feisty
>
>
> Sean, how about using a read-only file system to prevent the unwanted
> change?
>
> *If* it doesn't cause do-release-upgrade to throw a wobbly this might
> work:
>
> sudo -i
>
> dd if=/dev/zero of=/tmp/sources.list.d bs=1024 count=2048
> losetup /dev/loop1 /tmp/sources.list.d
> mkfs.ext2 /dev/loop1
> mkdir /mnt/apt
> mount /dev/loop1 /mnt/apt
> mv /etc/apt/sources.list.d/* /mnt/apt/
>
> # make the changes to /mnt/apt/prerequists-sources.list
>
> umount /mnt/apt
> mount -o ro /dev/loop1 /etc/apt/sources.list.d
>
> do-release-upgrade
>
> # Obviously, at the end of the process, put things back as they were:
>
> umount /etc/apt/sources.list.d
> mount /dev/loop1 /mnt/apt
> mv /mnt/apt/* /etc/apt/sources.list.d/
> umount /mnt/apt
> losetup -d /dev/loop1
> rm /tmp/sources.list.d
>
>
>
Man - that is brilliant. And it shoulda worked, but it didn't

A fatal error occured
Please report this as a bug and include the files
/var/log/dist-upgrade/main.log and /var/log/dist-upgrade/apt.log in your
report. The upgrade aborts now.
Your original sources.list was saved in /etc/apt/sources.list.distUpgrade.
Traceback (most recent call last):

File "/tmp/tmpjg9FjS/gutsy", line 59, in <module>
app.run()

File "/tmp/tmpjg9FjS/DistUpgradeControler.py", line 1346, in run
self.fullUpgrade()

File "/tmp/tmpjg9FjS/DistUpgradeControler.py", line 1251, in fullUpgrade
if not self.getRequiredBackports():

File "/tmp/tmpjg9FjS/DistUpgradeControler.py", line 1140, in
getRequiredBackports
outfile =
open(os.path.join(apt_pkg.Config.FindDir("Dir::Etc ::sourceparts"),
sourceslistd), "w")

IOError: [Errno 30] Read-only file system:
'/etc/apt/sources.list.d/prerequists-sources.list'


But it does show where the problem is.

Thanks for the suggestion.

sean


--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 

Thread Tools




All times are GMT. The time now is 07:17 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org