FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Server Development

 
 
LinkBack Thread Tools
 
Old 12-05-2008, 02:41 PM
Zhu Sha Zang
 
Default openssh-server problem

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

I'm using Ubuntu Server 8.04 and yesterday i'm trying to update via
apt-get update && apt-get upgrade && apt-get dist-upgrade. Seens to be
normal, but openssh-server have a problem when try to create keys. The
problem are "segmentation fault".

Configuration and error:
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkk5S6sACgkQ35zeJy7JhCjzKACfUWJWd+54NI n+uW7hJTuYjEYd
CrYAn2I5loBnWmniZQaBg1fTX14OUPFn
=CE4O
-----END PGP SIGNATURE-----

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
stepping : 6
cpu MHz : 2397.655
cache size : 4096 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips : 4798.72
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
stepping : 6
cpu MHz : 2397.655
cache size : 4096 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips : 4795.53
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

Linux trolls 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

#deb http://br.archive.ubuntu.com/ubuntu/ feisty main restricted
#deb-src http://br.archive.ubuntu.com/ubuntu/ feisty main restricted

#deb http://us.archive.ubuntu.com/ubuntu/ feisty main restricted
#deb-src http://us.archive.com/ubuntu/ feisty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
#deb http://br.archive.ubuntu.com/ubuntu/ feisty-updates main restricted
#deb-src http://br.archive.ubuntu.com/ubuntu/ feisty-updates main restricted

deb http://us.archive.ubuntu.com/ubuntu/ feisty-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu feisty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
#deb http://br.archive.ubuntu.com/ubuntu/ feisty universe
#deb-src http://br.archive.ubuntu.com/ubuntu/ feisty universe

#deb http://us.archive.ubuntu.com/ubuntu/ feisty universe
#deb-src http://us.archive.ubuntu.com/ubuntu feisty universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
#deb http://br.archive.ubuntu.com/ubuntu/ feisty multiverse
#deb-src http://br.archive.ubuntu.com/ubuntu/ feisty multiverse

#deb http://us.archive.ubuntu.com/ubuntu/ feisty multiverse
#deb-src http://us.archive.ubuntu.com/ubuntu/ feisty multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://br.archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu feisty-security main restricted
deb-src http://security.ubuntu.com/ubuntu feisty-security main restricted
deb http://security.ubuntu.com/ubuntu feisty-security universe
deb-src http://security.ubuntu.com/ubuntu feisty-security universe
deb http://security.ubuntu.com/ubuntu feisty-security multiverse
deb-src http://security.ubuntu.com/ubuntu feisty-security multiverse
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
openssh-blacklist openssh-client openssh-server
Suggested packages:
ssh-askpass xbase-clients rssh molly-guard
The following NEW packages will be installed:
openssh-blacklist openssh-client openssh-server ssh
Preconfiguring packages ...
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/3121kB of archives.
After unpacking 6734kB of additional disk space will be used.
Selecting previously deselected package openssh-client.
(Reading database ... 26036 files and directories currently installed.)
Unpacking openssh-client (from .../openssh-client_1%3a4.3p2-8ubuntu1.5_amd64.deb) ...
Selecting previously deselected package openssh-blacklist.
Unpacking openssh-blacklist (from .../openssh-blacklist_0.1-1ubuntu0.7.04.1_all.deb) ...
Selecting previously deselected package openssh-server.
Unpacking openssh-server (from .../openssh-server_1%3a4.3p2-8ubuntu1.5_amd64.deb) ...
Selecting previously deselected package ssh.
Unpacking ssh (from .../ssh_1%3a4.3p2-8ubuntu1.5_all.deb) ...
Setting up openssh-client (1:4.3p2-8ubuntu1.5) ...

Setting up openssh-blacklist (0.1-1ubuntu0.7.04.1) ...
Setting up openssh-server (1:4.3p2-8ubuntu1.5) ...
Creating SSH2 RSA key; this may take some time ...Segmentation fault
dpkg: error processing openssh-server (--configure):
subprocess post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of ssh:
ssh depends on openssh-server; however:
Package openssh-server is not configured yet.
dpkg: error processing ssh (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
openssh-server
ssh
--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 12-05-2008, 03:09 PM
MJang
 
Default openssh-server problem

On Fri, 2008-12-05 at 13:41 -0200, Zhu Sha Zang wrote:

> I'm using Ubuntu Server 8.04 and yesterday i'm trying to update via
> apt-get update && apt-get upgrade && apt-get dist-upgrade. Seens to be
> normal, but openssh-server have a problem when try to create keys. The
> problem are "segmentation fault".
snip

> The following extra packages will be installed:
> openssh-blacklist openssh-client openssh-server

I see the openssh-blacklist in your update. Are you familiar with this
USN? http://www.ubuntu.com/usn/usn-612-2

It includes instructions for the new authorization keys.

Thanks,
Mike


--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 12-05-2008, 04:11 PM
Kees Cook
 
Default openssh-server problem

Hi,

On Fri, Dec 05, 2008 at 01:41:32PM -0200, Zhu Sha Zang wrote:
> I'm using Ubuntu Server 8.04 and yesterday i'm trying to update via
> apt-get update && apt-get upgrade && apt-get dist-upgrade. Seens to be
> normal, but openssh-server have a problem when try to create keys. The
> problem are "segmentation fault".
> [snip]
> deb http://us.archive.ubuntu.com/ubuntu/ feisty-updates main restricted
> deb-src http://us.archive.ubuntu.com/ubuntu feisty-updates main restricted
> deb http://security.ubuntu.com/ubuntu feisty-security main restricted
> deb-src http://security.ubuntu.com/ubuntu feisty-security main restricted
> deb http://security.ubuntu.com/ubuntu feisty-security universe
> deb-src http://security.ubuntu.com/ubuntu feisty-security universe
> deb http://security.ubuntu.com/ubuntu feisty-security multiverse
> deb-src http://security.ubuntu.com/ubuntu feisty-security multiverse

You aren't running 8.04 if the above are the contents of your sources.list.
Firstly, you seem to be missing the "feisty" suite, which would
certainly be confusing for apt when doing upgrades. Also, feisty is
end-of-life and no longer supported. If you want to run 8.04, you'll need
to first add "feisty" back:

deb http://us.archive.ubuntu.com/ubuntu/ feisty main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu feisty main restricted universe multiverse

Then get your system updated and sane (apt-get update, apt-get
dist-upgrade). From there, then fully upgrade to Gutsy[1], and then
fully upgrade to Hardy[2] (which is 8.04).

Good luck!

-Kees

[1] https://help.ubuntu.com/community/GutsyUpgrades
[2] https://help.ubuntu.com/community/HardyUpgrades

--
Kees Cook
Ubuntu Security Team

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 12-06-2008, 07:04 PM
"Azamat S. Kalimoulline"
 
Default openssh-server problem

On Friday 05 December 2008 18:41:32 Zhu Sha Zang wrote:

> I'm using Ubuntu Server 8.04 and yesterday i'm trying to update via
> apt-get update && apt-get upgrade && apt-get dist-upgrade. Seens to be
> normal, but openssh-server have a problem when try to create keys. The
> problem are "segmentation fault".

This is a described problem. And depends on kernel version. I can't find that
now, but idea is to boot with older kernel and do dist-upgrade.

--
WBR Turtle//BAZON Group
--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 

Thread Tools




All times are GMT. The time now is 11:43 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org