FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Server Development

 
 
LinkBack Thread Tools
 
Old 10-17-2008, 09:47 AM
"Andrew Hodgson"
 
Default Tripwire Enterprise on Ubuntu

Hi,

Has anyone installed Tripwire Enterprise 7.5 on Ubuntu Hardy? The Linux
.bin installer seems to be an RPM. We want to upgrade some of our
RedHat LAMP servers (which need to be PCI compliant) to Ubuntu to take
advantage of later PHP builds, but without this Tripwire we may have to
rethink.

I have contacted Tripwire about this also.

Thanks.
Andrew.

--
allpay.net Limited, Fortis et Fides, Whitestone Business Park, Whitestone, Hereford, HR1 3SE.
Registered in England No. 02933191. UK VAT Reg. No. 666 9148 88.

Telephone: 0870 243 3434, Fax: 0870 243 6041.
Website: www.allpay.net
Email: enquiries@allpay.net

This email, and any files transmitted with it, is confidential and intended solely for the use of the individual or entity to whom it is addressed. If you have received this email in error please notify the allpay.net Information Security Manager at the number above.

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 10-17-2008, 10:21 AM
"Andrew Hodgson"
 
Default Tripwire Enterprise on Ubuntu

MJang wrote:

>On Fri, 2008-10-17 at 10:47 +0100, Andrew Hodgson wrote:
>> Hi,
>>
>> Has anyone installed Tripwire Enterprise 7.5 on Ubuntu Hardy? The
Linux
>> .bin installer seems to be an RPM. We want to upgrade some of our
>> RedHat LAMP servers (which need to be PCI compliant) to Ubuntu to
take
>> advantage of later PHP builds, but without this Tripwire we may have
to
>> rethink.

>Have you tried converting to a .deb with the

I first tried installing using RPM after getting the RPM package. It
fails:

user@machine:~$ sudo rpm -i te_agent.rpm
error: Failed dependencies:
/bin/sh is needed by TWeagent-7.1-0.i386

Then I tried using alien:

user@machine:~$ sudo alien --to-deb --scripts te_agent.rpm
Package build failed. Here's the log:
dh_testdir
dh_testdir
dh_testroot
dh_clean -k -d
dh_installdirs
dh_installdocs
dh_installchangelogs
find . -maxdepth 1 -mindepth 1 -not -name debian -print0 |
xargs -0 -r -i cp -a {} debian/tweagent
dh_compress
dh_makeshlibs
dh_installdeb
dh_shlibdeps
sh: gcc: not found
dpkg-shlibdeps: warning: Couldn't determine gcc system type, falling
back to default (native compilation)
dpkg-shlibdeps: failure: couldn't find library libdl.so.2 needed by
debian/tweagent/usr/local/tripwire/te/agent/jre/lib/i386/client/libjsig.
so (its RPATH is ').
Note: libraries are not searched in other binary packages that do not
have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set
LD_LIBRARY_PATH.
dh_shlibdeps: command returned error code 512
make: [binary-arch] Error 1 (ignored)
dh_gencontrol
sh: gcc: not found
dpkg-gencontrol: warning: Couldn't determine gcc system type, falling
back to default (native compilation)
dpkg-gencontrol: error: current host architecture 'amd64' does not
appear in package's architecture list (i386)
dh_gencontrol: command returned error code 65280
make: *** [binary-arch] Error 1
find: TWeagent-7.1: No such file or directory

I could attempt to sort this out, but would probably end up with an
unsupported configuration. Added to this that the installer for TE is a
.bin file, which seems to run some other program for the initial
install, with specific parameters etc.

Thanks.
Andrew.


--
allpay.net Limited, Fortis et Fides, Whitestone Business Park, Whitestone, Hereford, HR1 3SE.
Registered in England No. 02933191. UK VAT Reg. No. 666 9148 88.

Telephone: 0870 243 3434, Fax: 0870 243 6041.
Website: www.allpay.net
Email: enquiries@allpay.net

This email, and any files transmitted with it, is confidential and intended solely for the use of the individual or entity to whom it is addressed. If you have received this email in error please notify the allpay.net Information Security Manager at the number above.

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 10-17-2008, 12:20 PM
"Ozgur Karatas"
 
Default Tripwire Enterprise on Ubuntu

Hello,
hmm your installed tripwire of source code?

http://sourceforge.net/project/showfiles.php?group_id=3130&package_id=3042

and

tripwire .deb package?

okaratas@ozgur-work:~$ apt-cache search tripwire
tripwire - file and directory integrity checker

perfect

apt-get install tripwire

Ozgur

http://www.ozgurkaratas.com


2008/10/17 Andrew Hodgson <Andrew.Hodgson@allpay.net>:
> MJang wrote:
>
>>On Fri, 2008-10-17 at 10:47 +0100, Andrew Hodgson wrote:
>>> Hi,
>>>
>>> Has anyone installed Tripwire Enterprise 7.5 on Ubuntu Hardy? The
> Linux
>>> .bin installer seems to be an RPM. We want to upgrade some of our
>>> RedHat LAMP servers (which need to be PCI compliant) to Ubuntu to
> take
>>> advantage of later PHP builds, but without this Tripwire we may have
> to
>>> rethink.
>
>>Have you tried converting to a .deb with the
>
> I first tried installing using RPM after getting the RPM package. It
> fails:
>
> user@machine:~$ sudo rpm -i te_agent.rpm
> error: Failed dependencies:
> /bin/sh is needed by TWeagent-7.1-0.i386
>
> Then I tried using alien:
>
> user@machine:~$ sudo alien --to-deb --scripts te_agent.rpm
> Package build failed. Here's the log:
> dh_testdir
> dh_testdir
> dh_testroot
> dh_clean -k -d
> dh_installdirs
> dh_installdocs
> dh_installchangelogs
> find . -maxdepth 1 -mindepth 1 -not -name debian -print0 |
> xargs -0 -r -i cp -a {} debian/tweagent
> dh_compress
> dh_makeshlibs
> dh_installdeb
> dh_shlibdeps
> sh: gcc: not found
> dpkg-shlibdeps: warning: Couldn't determine gcc system type, falling
> back to default (native compilation)
> dpkg-shlibdeps: failure: couldn't find library libdl.so.2 needed by
> debian/tweagent/usr/local/tripwire/te/agent/jre/lib/i386/client/libjsig.
> so (its RPATH is ').
> Note: libraries are not searched in other binary packages that do not
> have any shlibs or symbols file.
> To help dpkg-shlibdeps find private libraries, you might need to set
> LD_LIBRARY_PATH.
> dh_shlibdeps: command returned error code 512
> make: [binary-arch] Error 1 (ignored)
> dh_gencontrol
> sh: gcc: not found
> dpkg-gencontrol: warning: Couldn't determine gcc system type, falling
> back to default (native compilation)
> dpkg-gencontrol: error: current host architecture 'amd64' does not
> appear in package's architecture list (i386)
> dh_gencontrol: command returned error code 65280
> make: *** [binary-arch] Error 1
> find: TWeagent-7.1: No such file or directory
>
> I could attempt to sort this out, but would probably end up with an
> unsupported configuration. Added to this that the installer for TE is a
> .bin file, which seems to run some other program for the initial
> install, with specific parameters etc.
>
> Thanks.
> Andrew.

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 10-17-2008, 12:53 PM
"Andrew Hodgson"
 
Default Tripwire Enterprise on Ubuntu

Ozgur Karataswrote:

>Hello,

[...]

>okaratas@ozgur-work:~$ apt-cache search tripwire
>tripwire - file and directory integrity checker

I configured this at first, however, it cannot speak to our central
enterprise Tripwire server, and so the security team are not happy. I
am still trying to argue that if we use the OS version of Tripwire, and
get emailed reports sent to us, then that will meet the requirements.

Thanks.
Andrew.

--
allpay.net Limited, Fortis et Fides, Whitestone Business Park, Whitestone, Hereford, HR1 3SE.
Registered in England No. 02933191. UK VAT Reg. No. 666 9148 88.

Telephone: 0870 243 3434, Fax: 0870 243 6041.
Website: www.allpay.net
Email: enquiries@allpay.net

This email, and any files transmitted with it, is confidential and intended solely for the use of the individual or entity to whom it is addressed. If you have received this email in error please notify the allpay.net Information Security Manager at the number above.

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 10-18-2008, 01:55 AM
Onno Benschop
 
Default Tripwire Enterprise on Ubuntu

On 17/10/08 20:53, Andrew Hodgson wrote:
> I configured this at first, however, it cannot speak to our central
> enterprise Tripwire server, and so the security team are not happy. I
> am still trying to argue that if we use the OS version of Tripwire, and
> get emailed reports sent to us, then that will meet the requirements.
>
I'm not intimately familiar with tripwire, but your comment makes me ask
the following:

Do you know why "it cannot speak to our central enterprise Tripwire server"?

Is this a version issue, a bug, a licensing issue, or something else? Is
there a bug report?

If it is something that the server team can fix, I strongly suspect that
we'll add it to the to-do list.

--
Onno Benschop

Connected via Optus B3 at S3154'06" - E11550'39" (Yokine, WA)
--
()/)/)() ..ASCII for Onno..
|>>? ..EBCDIC for Onno..
--- -. -. --- ..Morse for Onno..

ITmaze - ABN: 56 178 057 063 - ph: 04 1219 8888 - onno@itmaze.com.au



--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 10-18-2008, 11:28 AM
"Andrew Hodgson"
 
Default Tripwire Enterprise on Ubuntu

Onno Benschop wrote:

>On 17/10/08 20:53, Andrew Hodgson wrote:
>> I configured this at first, however, it cannot speak to our central
>> enterprise Tripwire server, and so the security team are not happy.
I
>> am still trying to argue that if we use the OS version of Tripwire,
and
>> get emailed reports sent to us, then that will meet the requirements.
>
>I'm not intimately familiar with tripwire, but your comment makes me
ask
>the following:

>Do you know why "it cannot speak to our central enterprise Tripwire
server"?

Due to the fact that the version packaged with Ubuntu is the open source
version, and we are using Tripwire Enterprise <http://www.tripwire.com>.
I have now had it confirmed that Tripwire Enterprise will only work on
RedHat Enterprise and Suse, so we will have to see what our security
department thinks of using the open source version, as it pretty much
does what the enterprise version does, only without the pretty GUI in
front of it, and without the consolidated reports.

The only reason we are doing this is to provide PCI (payment card
industry) compliance to our servers, as the servers we wish to convert
to Ubuntu will be taking customers credit card details (although will
not store those details).

Thanks.
Andrew.

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 10-18-2008, 11:44 AM
Daniel Robitaille
 
Default Tripwire Enterprise on Ubuntu

Andrew Hodgson wrote:
>
> I first tried installing using RPM after getting the RPM package. It
> fails:
>
> user@machine:~$ sudo rpm -i te_agent.rpm
> error: Failed dependencies:
> /bin/sh is needed by TWeagent-7.1-0.i386
>


one wild guess, but could this error caused by the fact that in some versions
of Ubuntu /bin/sh is a symlink to the simpler /bin/dash instead of /bin/bash
and the rpm install process doesn't like it?

https://wiki.ubuntu.com/DashAsBinSh


--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 10-18-2008, 12:05 PM
John Pugh
 
Default Tripwire Enterprise on Ubuntu

Andrew Hodgson wrote:
> Due to the fact that the version packaged with Ubuntu is the open source
> version, and we are using Tripwire Enterprise <http://www.tripwire.com>.
> I have now had it confirmed that Tripwire Enterprise will only work on
> RedHat Enterprise and Suse, so we will have to see what our security
> department thinks of using the open source version, as it pretty much
> does what the enterprise version does, only without the pretty GUI in
> front of it, and without the consolidated reports.
>
> The only reason we are doing this is to provide PCI (payment card
> industry) compliance to our servers, as the servers we wish to convert
> to Ubuntu will be taking customers credit card details (although will
> not store those details).
>
> Thanks.
> Andrew.
>

Hi Andrew - we would like to change that and are working with Tripwire
to have them support Ubuntu Server. Your help is appreciated by stating
the need to support Ubuntu Server with Tripwire Enterprise directly to
the Tripwire folks.

Thanks.

--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 
Old 10-20-2008, 04:23 AM
Karl Goetz
 
Default Tripwire Enterprise on Ubuntu

On Fri, 2008-10-17 at 11:21 +0100, Andrew Hodgson wrote:
> MJang wrote:
>
> >On Fri, 2008-10-17 at 10:47 +0100, Andrew Hodgson wrote:
> >> Hi,
> >>
> >> Has anyone installed Tripwire Enterprise 7.5 on Ubuntu Hardy? The
> Linux
> >> .bin installer seems to be an RPM. We want to upgrade some of our
> >> RedHat LAMP servers (which need to be PCI compliant) to Ubuntu to
> take
> >> advantage of later PHP builds, but without this Tripwire we may have
> to
> >> rethink.
>
> >Have you tried converting to a .deb with the
>

> dh_compress
> dh_makeshlibs
> dh_installdeb
> dh_shlibdeps
> sh: gcc: not found

^^ This looks like the problem to me.
apt-get build-dep tripwire

> I could attempt to sort this out, but would probably end up with an
> unsupported configuration. Added to this that the installer for TE is a
> .bin file, which seems to run some other program for the initial
> install, with specific parameters etc.

I wont comment on the rest of the thread, as its looking pretty well
discussed already.
kk

>
> Thanks.
> Andrew.

--
Karl Goetz <karl@kgoetz.id.au>
--
ubuntu-server mailing list
ubuntu-server@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
More info: https://wiki.ubuntu.com/ServerTeam
 

Thread Tools




All times are GMT. The time now is 08:48 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org