FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Masters Of The Universe

 
 
LinkBack Thread Tools
 
Old 01-18-2012, 07:21 AM
Agustin Lobo
 
Default Problem updating libgeos-c1 and libgeos-dev

At running the automatic update under ubuntu 10.04, I get the following
error related to libgeos-c1:



Errors were encountered while processing:
/var/cache/apt/archives/libgeos++-dev_3.3.1-4lucid1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up libpq5 (8.4.10-0ubuntu0.10.04.1) ...

dpkg: dependency problems prevent configuration of libgeos-c1:
libgeos-c1 depends on libgeos++-dev (>= 3.3.1); however:
Package libgeos++-dev is not installed.
dpkg: error processing libgeos-c1 (--configure):
dependency problems - leaving unconfigured
Setting up wine1.3 (1.3.37-0ubuntu1~ppa1~lucid1) ...
procps stop/waiting

Setting up libgeos-3.3.1 (3.3.1-4lucid1) ...

Setting up libpq-dev (8.4.10-0ubuntu0.10.04.1) ...
dpkg: dependency problems prevent configuration of libgeos-dev:
libgeos-dev depends on libgeos-c1 (= 3.3.1-4lucid1); however:
Package libgeos-c1 is not configured yet.
dpkg: error processing libgeos-dev (--configure):
dependency problems - leaving unconfigured
Setting up r-cran-matrix (1.0-3-1lucid0) ...
Setting up mobile-broadband-provider-info (20111113-1ubuntu0.10.04) ...
Setting up ttf-symbol-replacement-wine1.3 (1.3.37-0ubuntu1~ppa1~lucid1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
libgeos-c1
libgeos-dev

E: /var/cache/apt/archives/libgeos++-dev_3.3.1-4lucid1_amd64.deb: trying
to overwrite '/usr/lib/libgeos_c.a', which is also in package libgeos-dev 0


Is this a problem with the libgeos-dev binary?


Thanks for your assistance,

Agus

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 01-18-2012, 01:16 PM
Micah Gersten
 
Default Problem updating libgeos-c1 and libgeos-dev

On 01/18/2012 02:21 AM, Agustin Lobo wrote:
> At running the automatic update under ubuntu 10.04, I get the
> following error related to libgeos-c1:
>
>
> Errors were encountered while processing:
> /var/cache/apt/archives/libgeos++-dev_3.3.1-4lucid1_amd64.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> A package failed to install. Trying to recover:
> Setting up libpq5 (8.4.10-0ubuntu0.10.04.1) ...
>
> dpkg: dependency problems prevent configuration of libgeos-c1:
> libgeos-c1 depends on libgeos++-dev (>= 3.3.1); however:
> Package libgeos++-dev is not installed.
> dpkg: error processing libgeos-c1 (--configure):
> dependency problems - leaving unconfigured
> Setting up wine1.3 (1.3.37-0ubuntu1~ppa1~lucid1) ...
> procps stop/waiting
>
> Setting up libgeos-3.3.1 (3.3.1-4lucid1) ...
>
> Setting up libpq-dev (8.4.10-0ubuntu0.10.04.1) ...
> dpkg: dependency problems prevent configuration of libgeos-dev:
> libgeos-dev depends on libgeos-c1 (= 3.3.1-4lucid1); however:
> Package libgeos-c1 is not configured yet.
> dpkg: error processing libgeos-dev (--configure):
> dependency problems - leaving unconfigured
> Setting up r-cran-matrix (1.0-3-1lucid0) ...
> Setting up mobile-broadband-provider-info (20111113-1ubuntu0.10.04) ...
> Setting up ttf-symbol-replacement-wine1.3
> (1.3.37-0ubuntu1~ppa1~lucid1) ...
> Processing triggers for libc-bin ...
> ldconfig deferred processing now taking place
> Errors were encountered while processing:
> libgeos-c1
> libgeos-dev
>
> E: /var/cache/apt/archives/libgeos++-dev_3.3.1-4lucid1_amd64.deb:
> trying to overwrite '/usr/lib/libgeos_c.a', which is also in package
> libgeos-dev 0
>
> Is this a problem with the libgeos-dev binary?
>
>
> Thanks for your assistance,
>
> Agus
>
Sorry, but these libgeos* packages are not from the Ubuntu archive. You
might want to try askubuntu.com, the ubuntu-users mailing list, or the
maintainer of the PPA with those packages in them.

Thanks,
Micah

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 

Thread Tools




All times are GMT. The time now is 04:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org