FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Masters Of The Universe

 
 
LinkBack Thread Tools
 
Old 05-29-2011, 07:33 PM
Micah Gersten
 
Default Ask help for updating the package "Ziproxy" on Ubuntu 9.10

On 05/29/2011 05:02 AM, Qian HE wrote:
> Hi MOTU,
>
> I'm a user of Ubuntu 9.10. Recently, I'm using Ziproxy. I found the version of Ziproxy in Ubuntu 9.10 is 2.5.2-2. However, the latest version of Ziproxy is 3.2.0. Could you please update it at your convenience? I will appreciate it. Thank you.
>
> Here is the website of Ziproxy: http://ziproxy.sourceforge.net/
>
>
> Sincerely,
>
> Qian HE
Hi. Karmic reached end of life on May 1, 2011 per
https://wiki.ubuntu.com/Releases. You should consider upgrading to a
supported Ubuntu release. Natty and Oneiric currently have 3.1.3.
3.2.0 should be uploaded to Debian unstable soon and then will be sync'd
over to Oneiric. We generally do not upgrade versions in a stable
release. You can however request a backport of a newer version to a
supported release of Ubuntu. The instructions for doing so are here:
https://help.ubuntu.com/community/UbuntuBackports

Thanks,
Micah

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 05-29-2011, 07:48 PM
Qian HE
 
Default Ask help for updating the package "Ziproxy" on Ubuntu 9.10

Thank you. I understand the situation now.

Upgrading OS is a nightmare to me. Especially it's running on VPS
with a lot of services... I will try to compile the latest Ziproxy.

Thank you for the reply.


Sent from my iPad

On 2011-5-30, at 上午3:35, Micah Gersten <micahg@ubuntu.com> wrote:

> Sorry, forgot to include you in the reply. Please reply to the mailing
> list.
>
> Thanks.
>
> -------- Original Message --------
> Subject: Re: Ask help for updating the package "Ziproxy" on Ubuntu 9.10
> Date: Sun, 29 May 2011 14:33:45 -0500
> From: Micah Gersten <micahg@ubuntu.com>
> To: ubuntu-motu@lists.ubuntu.com
>
> On 05/29/2011 05:02 AM, Qian HE wrote:
>> Hi MOTU,
>>
>> I'm a user of Ubuntu 9.10. Recently, I'm using Ziproxy. I found the version of Ziproxy in Ubuntu 9.10 is 2.5.2-2. However, the latest version of Ziproxy is 3.2.0. Could you please update it at your convenience? I will appreciate it. Thank you.
>>
>> Here is the website of Ziproxy: http://ziproxy.sourceforge.net/
>>
>>
>> Sincerely,
>>
>> Qian HE
> Hi. Karmic reached end of life on May 1, 2011 per
> https://wiki.ubuntu.com/Releases. You should consider upgrading to a
> supported Ubuntu release. Natty and Oneiric currently have 3.1.3.
> 3.2.0 should be uploaded to Debian unstable soon and then will be sync'd
> over to Oneiric. We generally do not upgrade versions in a stable
> release. You can however request a backport of a newer version to a
> supported release of Ubuntu. The instructions for doing so are here:
> https://help.ubuntu.com/community/UbuntuBackports
>
> Thanks,
> Micah

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 05-30-2011, 06:35 AM
Soren Hansen
 
Default Ask help for updating the package "Ziproxy" on Ubuntu 9.10

2011/5/29 Qian HE <me@heqian.name>:
> Upgrading OS is a nightmare to me.

I'm not trying to be dramatic or anything, but having the system be
compromised because a critical security vulnerability does not get
fixed (because, as Micah points out, Karmic is no longer supported
(and hence does not get security updates any longer)) sounds like a
much worse nightmare to me.

>*Especially it's running on VPS
> with a lot of services...

If by "services" you mean something that's exposed to a network, those
are reasons *for* upgrading (since they're easier to attack if there's
a security problem), not *against* upgrading.


--
Soren Hansen
Ubuntu Developer * *http://www.ubuntu.com/
OpenStack Developer http://www.openstack.org/

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 05-31-2011, 10:59 AM
Qian HE
 
Default Ask help for updating the package "Ziproxy" on Ubuntu 9.10

Thank you much for the advice. I spent the whole night to upgrade the OS, fix scripts, check package dependencies, and do a lot of dirty stuff...

Fortunately, all the services are running in good condition now.

Thanks~


On May 30, 2011, at 2:35 PM, Soren Hansen wrote:

> 2011/5/29 Qian HE <me@heqian.name>:
>> Upgrading OS is a nightmare to me.
>
> I'm not trying to be dramatic or anything, but having the system be
> compromised because a critical security vulnerability does not get
> fixed (because, as Micah points out, Karmic is no longer supported
> (and hence does not get security updates any longer)) sounds like a
> much worse nightmare to me.
>
>> Especially it's running on VPS
>> with a lot of services...
>
> If by "services" you mean something that's exposed to a network, those
> are reasons *for* upgrading (since they're easier to attack if there's
> a security problem), not *against* upgrading.
>
>
> --
> Soren Hansen
> Ubuntu Developer http://www.ubuntu.com/
> OpenStack Developer http://www.openstack.org/


--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 

Thread Tools




All times are GMT. The time now is 05:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org