FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Masters Of The Universe

 
 
LinkBack Thread Tools
 
Old 09-21-2010, 01:46 AM
Kevin McKinney
 
Default Dependency Errors while trying to create make file for package gnome-device-manager

Hi
While trying to create a make file for package gnome-device-manager
using ./configure, I am having a problem resolving dependencies. The
errors I receive are:

checking what language compliance flags to pass to the C compiler...
checking for GNOME_DEVICE_MANAGER... configure: error: Package
requirements (libgnome-2.0 >= 2.14.0
libgnomeui-2.0 >= 2.14.0
gtk+-2.0 >= 2.6.0
hal >= 0.5.10) were not met:

No package 'libgnome-2.0' found
No package 'libgnomeui-2.0' found
No package 'gtk+-2.0' found
No package 'hal' found

When I try command: sudo apt-get install libgnome-2.0; I receive the
error that the package does not exist. Can someone tell me what I am
doing wrong? I am not sure why apt-get can not find these packages. I
will also need to port this package from HAL to udev; any
documentation on this would be helpful. Thanks for your time.

Regards,
Kevin McKinney

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 09-27-2010, 04:48 AM
Aron Xu
 
Default Dependency Errors while trying to create make file for package gnome-device-manager

On Tue, Sep 21, 2010 at 09:46, Kevin McKinney <klmckinney1@gmail.com> wrote:
> Hi
> While trying to create a make file for package gnome-device-manager
> using ./configure, I am having a problem resolving dependencies. *The
> errors I receive are:
>
> checking what language compliance flags to pass to the C compiler...
> checking for GNOME_DEVICE_MANAGER... configure: error: Package
> requirements (libgnome-2.0 >= 2.14.0
> * libgnomeui-2.0 >= 2.14.0
> * gtk+-2.0 >= 2.6.0
> * hal >= 0.5.10) were not met:
>
> No package 'libgnome-2.0' found
> No package 'libgnomeui-2.0' found
> No package 'gtk+-2.0' found
> No package 'hal' found
>
> When I try command: sudo apt-get install libgnome-2.0; I receive the
> error that the package does not exist. *Can someone tell me what I am
> doing wrong? *I am not sure why apt-get can not find these packages. I
> will also need to port this package from HAL to udev; any
> documentation on this would be helpful. *Thanks for your time.
>
> Regards,
> Kevin McKinney
>
> --
> Ubuntu-motu mailing list
> Ubuntu-motu@lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
>

I think it should be libgnome2-dev in Ubuntu repository.


--
Regards,
Aron Xu

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 09-29-2010, 05:59 PM
Kevin McKinney
 
Default Dependency Errors while trying to create make file for package gnome-device-manager

Hi Aron,
On Mon, Sep 27, 2010 at 12:48 AM, Aron Xu <happyaron.xu@gmail.com> wrote:
>
> I think it should be libgnome2-dev in Ubuntu repository.
>
Thanks for the information!! Do you know if the other packages still
exist? Perhaps they have been deprecated? In addition, do you have
any how-to documentation on how to convert this package from Hal to
udev? Any help would be appreciated.

Thanks,
Kevin

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 09-30-2010, 09:50 AM
"Michael Bienia"
 
Default Dependency Errors while trying to create make file for package gnome-device-manager

On 2010-09-20 21:46:38 -0400, Kevin McKinney wrote:
> checking what language compliance flags to pass to the C compiler...
> checking for GNOME_DEVICE_MANAGER... configure: error: Package
> requirements (libgnome-2.0 >= 2.14.0
> libgnomeui-2.0 >= 2.14.0
> gtk+-2.0 >= 2.6.0
> hal >= 0.5.10) were not met:
>
> No package 'libgnome-2.0' found
> No package 'libgnomeui-2.0' found
> No package 'gtk+-2.0' found
> No package 'hal' found

This doesn't refer to package names as used by apt but to names as used
by pkg-config. It checks if a such named .pc file exists in
/usr/lib/pkg-config and if their dependencies (other .pc files) are also
there.

'libgnome-2.0':
/usr/lib/pkgconfig/libgnome-2.0.pc → libgnome2-dev

'libgnomeui-2.0':
/usr/lib/pkgconfig/libgnomeui-2.0.pc → libgnomeui-dev

'gtk+-2.0':
/usr/lib/pkgconfig/gtk+-2.0.pc → libgtk2.0-dev

'hal':
/usr/lib/pkgconfig/hal.pc → libhal-dev


Michael

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 

Thread Tools




All times are GMT. The time now is 02:33 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org