Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Ubuntu Masters Of The Universe (http://www.linux-archive.org/ubuntu-masters-universe/)
-   -   BIG problems with OpenJDK update for 8.04!! (http://www.linux-archive.org/ubuntu-masters-universe/414952-big-problems-openjdk-update-8-04-a.html)

Martijn Brinkers 08-18-2010 06:59 PM

BIG problems with OpenJDK update for 8.04!!
 
The update of OpenJDK for 8.04 installs an extra package
ca-certificates-java which results in the removal of the ANT package.
Because my application depends on ANT my application (and Tomcat 5.5)
will be removed!!!


This is a serious bug

Kind regards,

Martijn Brinkers

See below:

The following packages will be REMOVED:
ant ant-optional djigzo libtomcat5.5-java tomcat5.5
The following NEW packages will be installed:
ca-certificates-java
The following packages will be upgraded:
openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib


dpkg: openjdk-6-jre-headless: dependency problems, but removing anyway
as you request:
openjdk-6-jre depends on openjdk-6-jre-headless (>= 6b11-2ubuntu2.2).
djigzo-web depends on openjdk-6-jre-headless.
djigzo-appliance depends on openjdk-6-jre-headless.
Removing openjdk-6-jre-headless ...
dpkg: openjdk-6-jre: dependency problems, but removing anyway as you
request:
djigzo-web depends on openjdk-6-jre.
djigzo-appliance depends on openjdk-6-jre.
libcommons-pool-java depends on kaffe | java1-runtime | java2-runtime;
however:
Package kaffe is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-collections-java depends on java-gcj-compat | java1-runtime
| java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-beanutils-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-logging-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-modeler-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-dbcp-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-el-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-daemon-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-launcher-java depends on kaffe (>= 2:1.1.5-3) |
java1-runtime | java2-runtime; however:
Package kaffe is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-collections3-java depends on kaffe (>= 2:1.1.5-3) |
java-gcj-compat | java1-runtime | java2-runtime; however:
Package kaffe is not installed.
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libxerces2-java depends on gij | java-gcj-compat | java1-runtime |
java2-runtime; however:
Package gij is not installed.
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libservlet2.4-java depends on gij | java-gcj-compat | java1-runtime |
java2-runtime; however:
Package gij is not installed.
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libservlet2.3-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libregexp-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
rhino depends on java-gcj-compat-headless | java-gcj-compat |
java2-runtime-headless | java1-runtime | java2-runtime; however:
Package java-gcj-compat-headless is not installed.
Package java-gcj-compat is not installed.
Package java2-runtime-headless is not installed.
Package openjdk-6-jre-headless which provides java2-runtime-headless
is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libmx4j-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libcommons-digester-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
libjaxp1.3-java depends on gij | java-gcj-compat | java1-runtime |
java2-runtime; however:
Package gij is not installed.
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
liblog4j1.2-java depends on java-gcj-compat | java1-runtime |
java2-runtime; however:
Package java-gcj-compat is not installed.
Package java1-runtime is not installed.
Package java2-runtime is not installed.
Package openjdk-6-jre which provides java2-runtime is to be removed.
Removing openjdk-6-jre ...



--
Djigzo open source email encryption

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu


All times are GMT. The time now is 07:34 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.