FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 04-23-2010, 02:00 PM
Aleksey Mikhailov
 
Default curlftpfs

Hi all!
We are using Ubuntu Server 8.04 LTS
and we wanna use curlftpfs ... but can't... because this program
can't work. It has one small bug:
when we are trying to read file from curlftp mountpoint at first we
getting error : permition denied
subsequent reads - OK
In ftp server logs I'm seeing strange random user...

I guess our issue same with this bug report
https://bugs.launchpad.net/ubuntu/+source/curlftpfs/+bug/277488

Have you some workaround for this issue?

Thanks!


--
Best regards
Aleksey Mykhailov
http://kodingen.com

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 07-11-2011, 07:39 PM
"James B. Byrne"
 
Default curlftpfs

CentOS-5.6
fuse-2.7.4-8.el5
fuse-curlftpfs-0.9.1-1.el5.rf

I am trying to mount an ftp connection as a local file system using
fuse and curlftpfs. I can connect to the remote system (an HP3000
running MPEiX 7.5) and the directory seems to mount but I cannot use
it. What I get is an Input/output error:

$ curlftpfs -v hahp3k01.harte-lyne.ca tmp/hp3000
* About to connect() to hahp3k01.harte-lyne.ca port 21
* Trying 192.168.1.102... * connected
* Connected to hahp3k01.harte-lyne.ca (192.168.1.102) port 21
< 220 HP ARPA FTP Server [A0012H15] (C) Hewlett-Packard Co. 2000
[PASV SUPPORT]
> USER FTPUSER.HARTLYNE
< 331 Password required for FTPUSER.HARTLYNE. Syntax:
userpass,acctpass
> PASS xxxxxxxxxx
< 230 User logged on
> PWD
< 257 "/HARTLYNE/CADEXJOB" is the current directory.
* Entry path is '/HARTLYNE/CADEXJOB'
* Connection #0 to host hahp3k01.harte-lyne.ca left intact
$
$ ll tmp/hp3000
ls: reading directory tmp/hp3000: Input/output error
total 0

Is this a problem with fusermount, curlftpfs the ftp server on the
Hp3000 or something else?

Suggestions as to what is wrong and how I can get this to work are
most welcome.


--
*** E-Mail is NOT a SECURE channel ***
James B. Byrne mailto:ByrneJB@Harte-Lyne.ca
Harte & Lyne Limited http://www.harte-lyne.ca
9 Brockley Drive vox: +1 905 561 1241
Hamilton, Ontario fax: +1 905 561 0757
Canada L8E 3C3

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-12-2011, 10:31 AM
John Doe
 
Default curlftpfs

From: James B. Byrne <byrnejb@harte-lyne.ca>

> CentOS-5.6
> fuse-2.7.4-8.el5
> fuse-curlftpfs-0.9.1-1.el5.rf
> I am trying to mount an ftp connection as a local file system using
> fuse and curlftpfs.* I can connect to the remote system (an HP3000
> running MPEiX 7.5) and the directory seems to mount but I cannot use
> it.* What I get is an Input/output error:

I guess you tested a manual ftp and it works?
Random thought: tried disable_epsv in curlftpfs?
ftpfs_debug would tell more about the error maybe.
Or fuse options -d -o debug...

JD
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 12:48 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org