FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Masters Of The Universe

 
 
LinkBack Thread Tools
 
Old 07-21-2008, 10:18 PM
Ryan Niebur
 
Default Ubuntu (new upstream) rails 2.1.0-1ubuntu1

The real maintainer uploaded a new package today that fixes the same things as my attempted NMU.
You should use his.

On Mon, Jul 21, 2008 at 09:43:31PM -0000, Ubuntu Merge-o-Matic wrote:
> This e-mail has been sent due to an upload to Ubuntu of a new upstream
> version which still contains Ubuntu changes. It contains the difference
> between the Ubuntu version and the equivalent base version in Debian, note
> that this difference may include the upstream changes.
> Format: 1.7
> Date: Mon, 21 Jul 2008 12:49:03 -0400
> Source: rails
> Binary: rails
> Architecture: source
> Version: 2.1.0-1ubuntu1
> Distribution: intrepid
> Urgency: low
> Maintainer: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
> Changed-By: Scott Kitterman <scott@kitterman.com>
> Description:
> rails - MVC ruby based framework geared for web application development
> Closes: 475288 484351 490419 491125
> Launchpad-Bugs-Fixed: 236966
> Changes:
> rails (2.1.0-1ubuntu1) intrepid; urgency=low
> .
> [ Ryan Niebur ]
> * Non-maintainer upload.
> * NMU to fix RC bugs.
> * Build depend on rubygems (closes: #490419)
> * Depend on the rubygems package in sid or the one in lenny (closes: #491125)
> .
> [ Scott Kitterman ]
> * Update to rails 2.1 and grab proposed NMU for Ubuntu so it builds
> (LP: #236966)
> .
> rails (2.1.0-1) unstable; urgency=low
> .
> * New upstream release
> + No longer breaks with ruby 1.8.7 (closes: #484351)
> * Use libjs-prototype prototype library instead of upstream
> bundled (closes: #475288)
> * Added Vcs-* and Homepage data to debian/control
> * doc-base section changed to 'Programming'
> Files:
> ecbf24f293152cc67ab242c3e6edbb4b 873 web optional rails_2.1.0-1ubuntu1.dsc
> c5137842a6132c8c492379d3ec2410f5 11549 web optional rails_2.1.0-1ubuntu1.diff.gz
> Original-Maintainer: Adam Majer <adamm@zombino.com>

> diff -pruN 2.1.0-1/debian/changelog 2.1.0-1ubuntu1/debian/changelog
> --- 2.1.0-1/debian/changelog 2008-07-21 22:20:10.000000000 +0100
> +++ 2.1.0-1ubuntu1/debian/changelog 2008-07-21 22:17:30.000000000 +0100
> @@ -1,3 +1,17 @@
> +rails (2.1.0-1ubuntu1) intrepid; urgency=low
> +
> + [ Ryan Niebur ]
> + * Non-maintainer upload.
> + * NMU to fix RC bugs.
> + * Build depend on rubygems (closes: #490419)
> + * Depend on the rubygems package in sid or the one in lenny (closes: #491125)
> +
> + [ Scott Kitterman ]
> + * Update to rails 2.1 and grab proposed NMU for Ubuntu so it builds
> + (LP: #236966)
> +
> + -- Scott Kitterman <scott@kitterman.com> Mon, 21 Jul 2008 12:49:03 -0400
> +
> rails (2.1.0-1) unstable; urgency=low
>
> * New upstream release
> diff -pruN 2.1.0-1/debian/control 2.1.0-1ubuntu1/debian/control
> --- 2.1.0-1/debian/control 2008-07-21 22:20:10.000000000 +0100
> +++ 2.1.0-1ubuntu1/debian/control 2008-07-21 22:17:30.000000000 +0100
> @@ -1,8 +1,9 @@
> Source: rails
> Section: web
> Priority: optional
> -Maintainer: Adam Majer <adamm@zombino.com>
> -Build-Depends: debhelper (>= 4.0.0), rake (>>0.7.0), rdoc (>>1.8.2), liberb-ruby
> +Maintainer: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
> +XSBC-Original-Maintainer: Adam Majer <adamm@zombino.com>
> +Build-Depends: debhelper (>= 4.0.0), rake (>>0.7.0), rdoc (>>1.8.2), liberb-ruby, rubygems1.8 | rubygems
> Standards-Version: 3.8.0
> Vcs-Browser: http://git.debian.org/?p=collab-maint/rails.git;a=summary
> Vcs-Git: git://git.debian.org/git/collab-maint/rails.git
> @@ -11,7 +12,7 @@ Homepage: http://rubyonrails.com
> Package: rails
> Architecture: all
> Pre-Depends: dpkg (>= 1.10.24)
> -Depends: ${miscepends}, ruby, ruby1.8 (>=1.8.2-3), rake (>>0.7.0), rdoc (>>1.8.2), libsqlite3-ruby1.8 | libpgsql-ruby1.8 | libmysql-ruby1.8 | libdbi-ruby1.8, libredcloth-ruby1.8, liberb-ruby, libruby1.8-extras, rubygems, libjs-prototype
> +Depends: ${miscepends}, ruby, ruby1.8 (>=1.8.2-3), rake (>>0.7.0), rdoc (>>1.8.2), libsqlite3-ruby1.8 | libpgsql-ruby1.8 | libmysql-ruby1.8 | libdbi-ruby1.8, libredcloth-ruby1.8, liberb-ruby, libruby1.8-extras, rubygems1.8 | rubygems, libjs-prototype
> Recommends: irb (>>1.8), libmocha-ruby1.8
> Conflicts: libdevel-logger-ruby1.8
> Suggests: libapache2-mod-ruby | libapache-mod-ruby | libapache2-mod-fcgid, libfcgi-ruby1.8


--
_________________________
Ryan Niebur
RyanRyan52@gmail.com--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 

Thread Tools




All times are GMT. The time now is 12:55 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org