FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 07-09-2008, 08:38 AM
Mechler Matyas Illes
 
Default QtiPlot

Dear Developers,

I tried to compile the new version of QtiPlot (under Ubuntu 8.04);
however, I could not manage it. Could you please refresh the qtiplot
version in the package manager? I ask you this for two reasons: first, I
saw that at least the previous version of qtiplot was maintained by you
therefore surely you know every dependencies of the software. Secondly,
I tried to get an answer to my problem (with which I wasn't alone) from
the developers and I could not get a better answer than "buy the binaries".

Thank you in advance!

Best regards,
Matyas Mechler

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 11-23-2008, 02:01 PM
"brullo nulla"
 
Default qtiplot

Hi,

I have an x86 gentoo system, and I would like to install qtiplot.
Unfortunately:
- qtiplot 0.8.x requires qwt-4. I have both qwt-4 and qwt-5 installed,
and when compilng qtiplot seems to pick invariably the qwt-5. How do I
force qtiplot to build with qwt-4 ?

- qtiplot 0.9.x requires to unmask dependencies like split ebuilds for
qt-4.4.2 and boost-1.35. Is it safe to do so in a mostly x86 stable
system? What caveats could there be in migrating to the qt-4 unstable
split ebuilds?

Thanks,
m.
 
Old 11-24-2008, 05:59 PM
"b.n."
 
Default qtiplot

Hi,

I have an x86 gentoo system, and I would like to install qtiplot.
Unfortunately:
- qtiplot 0.8.x requires qwt-4. I have both qwt-4 and qwt-5 installed,
and when compilng qtiplot seems to pick invariably the qwt-5. How do I
force qtiplot to build with qwt-4 ?

- qtiplot 0.9.x requires to unmask dependencies like split ebuilds for
qt-4.4.2 and boost-1.35. Is it safe to do so in a mostly x86 stable
system? What caveats could there be in migrating to the qt-4 unstable
split ebuilds?

Thanks,
m.
 
Old 11-26-2008, 05:36 PM
"b.n."
 
Default qtiplot

b.n. ha scritto:
> Hi,
>
> I have an x86 gentoo system, and I would like to install qtiplot.
> Unfortunately:
> - qtiplot 0.8.x requires qwt-4. I have both qwt-4 and qwt-5 installed,
> and when compilng qtiplot seems to pick invariably the qwt-5. How do I
> force qtiplot to build with qwt-4 ?
>
> - qtiplot 0.9.x requires to unmask dependencies like split ebuilds for
> qt-4.4.2 and boost-1.35. Is it safe to do so in a mostly x86 stable
> system? What caveats could there be in migrating to the qt-4 unstable
> split ebuilds?
>

Bump...

m.
 
Old 11-27-2008, 04:33 PM
"Arttu V."
 
Default qtiplot

On 11/26/08, b.n. <brullonulla@gmail.com> wrote:
> b.n. ha scritto:
>> Hi,
>>
>> I have an x86 gentoo system, and I would like to install qtiplot.
>> Unfortunately:
>> - qtiplot 0.8.x requires qwt-4. I have both qwt-4 and qwt-5 installed,
>> and when compilng qtiplot seems to pick invariably the qwt-5. How do I
>> force qtiplot to build with qwt-4 ?

Wild guesses, semi-tested on amd64 only:

- in the current qtiplot-0.8.5-qmake.patch replace "-lqwt" with "-l:libqwt.so.4"
- check that you have qt:3 built with USE="opengl"
(- gcc-4.3 patching, which were a sort of a detour since I just didn't
want to downgrade gcc in the chroot in which I made my testing in)

After that I got qtiplot-0.8.5 emerged in a simplistic chrooted amd64
environment, which had little more than the basic qt stuff and
explicitly emerged qwt 4 and 5:

x11-libs/qwt
selected: 4.2.0-r3 5.0.2-r1

However, I don't know this piece of software and I don't think I'm
going to learn it right now, so that's as far as I planned on
"testing" it right now.

Maybe you would like to file a bug in b.g.o? I can dump my crude,
couple-line patches/changes there and whoever needs/maintains qtiplot
can then refine them or reject them as needed.

--
Arttu V.
 
Old 11-27-2008, 08:48 PM
"b.n."
 
Default qtiplot

Arttu V. ha scritto:
> On 11/26/08, b.n. <brullonulla@gmail.com> wrote:
>> b.n. ha scritto:
>>> Hi,
>>>
>>> I have an x86 gentoo system, and I would like to install qtiplot.
>>> Unfortunately:
>>> - qtiplot 0.8.x requires qwt-4. I have both qwt-4 and qwt-5 installed,
>>> and when compilng qtiplot seems to pick invariably the qwt-5. How do I
>>> force qtiplot to build with qwt-4 ?
>
> Wild guesses, semi-tested on amd64 only:
>
> - in the current qtiplot-0.8.5-qmake.patch replace "-lqwt" with "-l:libqwt.so.4"
> - check that you have qt:3 built with USE="opengl"
> (- gcc-4.3 patching, which were a sort of a detour since I just didn't
> want to downgrade gcc in the chroot in which I made my testing in)
>
> After that I got qtiplot-0.8.5 emerged in a simplistic chrooted amd64
> environment, which had little more than the basic qt stuff and
> explicitly emerged qwt 4 and 5:
>
> x11-libs/qwt
> selected: 4.2.0-r3 5.0.2-r1
>
> However, I don't know this piece of software and I don't think I'm
> going to learn it right now, so that's as far as I planned on
> "testing" it right now.
>
> Maybe you would like to file a bug in b.g.o? I can dump my crude,
> couple-line patches/changes there and whoever needs/maintains qtiplot
> can then refine them or reject them as needed.

Thanks for your wonderful reply! However it seems a bit of work. Nothing
fancy:but if I have to spend some time patching and testing, I'm rather
doing it for the latest version (0.9.x)

I keep your mail close, in the meaning that if 0.9.x refuses to work,
I'll fallback on 0.8.5 with your suggestions. But if anyone has
suggestions on the qt stuff, before b0rking my laptop, I'd be happy.

m.
 
Old 08-10-2012, 03:45 PM
Patrick Dupre
 
Default qtiplot

Hello,

Severql persons asked for qtiplot working with fedora 16.

I recompiled and installed (from src.fc16)
EmfEngine.spec liborigin2.spec QTeXEngine.spec

Unfortunately whenI try to compile qtiplot (rpmbuild -bb qtiplot.spec)
from (qtiplot-0.9.8.3-1.fc15.src.rpm), I get:

mv -f libqwt.a ../lib/
make[2]: Leaving directory
`/home/pdupre/rpmbuild/BUILD/qtiplot-0.9.8.3/3rdparty/qwt/src'
make[1]: Leaving directory
`/home/pdupre/rpmbuild/BUILD/qtiplot-0.9.8.3/3rdparty/qwt'

error: Bad exit status from /var/tmp/rpm-tmp.SgU2TC (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.SgU2TC (%build)


It means that the compilation seems OK, but just the build fails.

Any idea?

Thank.

--
================================================== ====================
Patrick DUPRÉ | | email: pdupre@kegtux.org
================================================== ====================
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 08-10-2012, 04:03 PM
Joe Zeff
 
Default qtiplot

On 08/10/2012 08:45 AM, Patrick Dupre wrote:

It means that the compilation seems OK, but just the build fails.

Any idea?


Just to be sure, have you checked and made sure you have all of the
dependencies?

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 08-10-2012, 04:09 PM
Patrick Dupre
 
Default qtiplot

On 2012-08-10 17:45, Patrick Dupre wrote:

Hello,

Severql persons asked for qtiplot working with fedora 16.

I recompiled and installed (from src.fc16)
EmfEngine.spec liborigin2.spec QTeXEngine.spec

Unfortunately whenI try to compile qtiplot (rpmbuild -bb
qtiplot.spec)

from (qtiplot-0.9.8.3-1.fc15.src.rpm), I get:

mv -f libqwt.a ../lib/
make[2]: Leaving directory
`/home/pdupre/rpmbuild/BUILD/qtiplot-0.9.8.3/3rdparty/qwt/src'
make[1]: Leaving directory
`/home/pdupre/rpmbuild/BUILD/qtiplot-0.9.8.3/3rdparty/qwt'
error: Bad exit status from /var/tmp/rpm-tmp.SgU2TC (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.SgU2TC (%build)


It means that the compilation seems OK, but just the build fails.

Any idea?



At least there is onne compilation error:

g++ -c -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -O2
-fPIC -D_REENTRANT -Wall -W -DQTIPLOT_PRO -DQT_NO_DEBUG -DQT_GUI_LIB
-DQT_CORE_LIB -DQT_SHARED -I/usr/lib64/qt4/mkspecs/linux-g++ -I.
-I/usr/include/QtCore -I/usr/include/QtGui -I/usr/include -Imoc -o
obj/qwt_interval_data.o qwt_interval_data.cpp

In file included from include/qwt3d_types.h:26:0,
from include/qwt3d_extglwidget.h:4,
from src/qwt3d_extglwidget.cpp:7:
include/qwt3d_openglhelper.h: In function 'const GLubyte*
Qwt3D::gl_error()':
include/qwt3d_openglhelper.h:67:31: error: 'gluErrorString' was not
declared in this scope

In file included from include/qwt3d_types.h:26:0,
from include/qwt3d_extglwidget.h:4,
from src/qwt3d_extglwidget.cpp:7:
include/qwt3d_openglhelper.h: In function 'bool
Qwt3D::ViewPort2World(double&, double&, double&, double, double,
double)':
include/qwt3d_openglhelper.h:104:97: error: 'gluUnProject' was not
declared in this scope
include/qwt3d_openglhelper.h: In function 'bool
Qwt3D::World2ViewPort(double&, double&, double&, double, double,
double)':
include/qwt3d_openglhelper.h:120:95: error: 'gluProject' was not
declared in this scope

make[1]: *** [lib/tmp/qwt3d_extglwidget.o] Error 1
make[1]: Leaving directory
`/home/pdupre/rpmbuild/BUILD/qtiplot-0.9.8.3/3rdparty/qwtplot3d'

make: *** [sub-3rdparty-qwtplot3d-make_default] Error 2
make: g++ -c -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -O2
-fPIC -D_REENTRANT -Wall -W -DQTIPLOT_PRO -DQT_NO_DEBUG -DQT_GUI_LIB
-DQT_CORE_LIB -DQT_SHARED -I/usr/lib64/qt4/mkspecs/linux-g++ -I.
-I/usr/include/QtCore -I/usr/include/QtGui -I/usr/include -Imoc -o
obj/qwt_legend.o qwt_legend.cpp





A dependency is probably missing, but which one?


--
================================================== ====================
Patrick DUPRÉ | | email: pdupre@kegtux.org
================================================== ====================
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 08-10-2012, 04:16 PM
Richard Shaw
 
Default qtiplot

On Fri, Aug 10, 2012 at 11:09 AM, Patrick Dupre <pdupre@kegtux.org> wrote:
> g++ -c -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector
> --param=ssp-buffer-size=4 -m64 -mtune=generic -O2 -fPIC -D_REENTRANT -Wall
> -W -DQTIPLOT_PRO -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED
> -I/usr/lib64/qt4/mkspecs/linux-g++ -I. -I/usr/include/QtCore
> -I/usr/include/QtGui -I/usr/include -Imoc -o obj/qwt_interval_data.o
> qwt_interval_data.cpp
> In file included from include/qwt3d_types.h:26:0,
> from include/qwt3d_extglwidget.h:4,
> from src/qwt3d_extglwidget.cpp:7:
> include/qwt3d_openglhelper.h: In function 'const GLubyte*
> Qwt3D::gl_error()':
> include/qwt3d_openglhelper.h:67:31: error: 'gluErrorString' was not declared
> in this scope
> In file included from include/qwt3d_types.h:26:0,
> from include/qwt3d_extglwidget.h:4,
> from src/qwt3d_extglwidget.cpp:7:
> include/qwt3d_openglhelper.h: In function 'bool
> Qwt3D::ViewPort2World(double&, double&, double&, double, double, double)':
> include/qwt3d_openglhelper.h:104:97: error: 'gluUnProject' was not declared
> in this scope
> include/qwt3d_openglhelper.h: In function 'bool
> Qwt3D::World2ViewPort(double&, double&, double&, double, double, double)':
> include/qwt3d_openglhelper.h:120:95: error: 'gluProject' was not declared in
> this scope
> make[1]: *** [lib/tmp/qwt3d_extglwidget.o] Error 1
> make[1]: Leaving directory
> `/home/pdupre/rpmbuild/BUILD/qtiplot-0.9.8.3/3rdparty/qwtplot3d'
> make: *** [sub-3rdparty-qwtplot3d-make_default] Error 2
> make: g++ -c -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
> -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -O2 -fPIC
> -D_REENTRANT -Wall -W -DQTIPLOT_PRO -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB
> -DQT_SHARED -I/usr/lib64/qt4/mkspecs/linux-g++ -I. -I/usr/include/QtCore
> -I/usr/include/QtGui -I/usr/include -Imoc -o obj/qwt_legend.o qwt_legend.cpp

If I wasn't fairly sure I had the package installed I would have
started with google, but since I was pretty sure:

# grep -r 'gluProject' /usr/include
/usr/include/GL/glu.h:GLAPI GLint GLAPIENTRY gluProject (GLdouble
objX, GLdouble objY, GLdouble objZ, const GLdouble *model, const
GLdouble *proj, const GLint *view, GLdouble* winX, GLdouble* winY,
GLdouble* winZ);

Then:
# repoquery --whatprovides /usr/include/GL/glu.h
mesa-libGLU-devel-0:7.11.2-3.fc16.x86_64
mesa-libGLU-devel-0:7.11.2-3.fc16.i686
mesa-libGLU-devel-0:7.11-8.fc16.x86_64
mesa-libGLU-devel-0:7.11-8.fc16.i686

I've run into this before and you may need an additional "#include
<GL/glu.h>" in the right source header but I can't remember for sure.

Richard
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 

Thread Tools




All times are GMT. The time now is 03:57 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org