FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Kernel Team

 
 
LinkBack Thread Tools
 
Old 10-12-2012, 09:58 AM
Colin Ian King
 
Default ALSA: hda - do not detect jack on internal speakers for Realtek

On 11/10/12 21:25, David Henningsson wrote:

A "pre-stable" [1] patch that we probably want to pick up ASAP:

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=commit;h=f7f4b2322bf7b8c5929b7eb5a6670 91f32592580


BugLink: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1064621

Except the two people affected by the bug above, I believe this is also
what Colin Ian King is seeing on his machine. Essentially, the machine's
internal speaker works on boot, but either silence for a while or an S3
cycle can cause it to stop functioning.


Just following this up to say I've tested this and it fixes the audio
issues on my Lenovo X230.


I figured that it'll be easier for you to just cherry-pick it from
Takashi, especially as I seem to always end up doing something wrong
when I try.




--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 10-12-2012, 10:48 AM
Colin Ian King
 
Default ALSA: hda - do not detect jack on internal speakers for Realtek

On 12/10/12 10:58, Colin Ian King wrote:

On 11/10/12 21:25, David Henningsson wrote:

A "pre-stable" [1] patch that we probably want to pick up ASAP:

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=commit;h=f7f4b2322bf7b8c5929b7eb5a6670 91f32592580



BugLink: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1064621

Except the two people affected by the bug above, I believe this is also
what Colin Ian King is seeing on his machine. Essentially, the machine's
internal speaker works on boot, but either silence for a while or an S3
cycle can cause it to stop functioning.


Just following this up to say I've tested this and it fixes the audio
issues on my Lenovo X230.


Just landed in 3.7, commit: f7f4b2322bf7b8c5929b7eb5a667091f32592580



I figured that it'll be easier for you to just cherry-pick it from
Takashi, especially as I seem to always end up doing something wrong
when I try.







--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 

Thread Tools




All times are GMT. The time now is 04:08 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org