FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Kernel Team

 
 
LinkBack Thread Tools
 
Old 03-14-2012, 09:18 PM
Stefan Bader
 
Default CVE-2012-0045

32bit guests will crash (and 64bit guests may behave in a
wrong way) for example by simply executing following
nasm-demo-application:
The reason seems a missing "invalid opcode"-trap (int6) for the
syscall opcode "0f05", which is not available on Intel CPUs
within non-longmodes, as also on some AMD CPUs within legacy-mode.
(depending on CPU vendor, MSR_EFER and cpuid)

Problem got introduced in 2.6.32 (so Hardy is not affected) and
recently fixed in a 3.3-rc.
For Precise a simple cherry-pick of the two patches works. Previous
releases require a increasing amount of tweaking. Following this
email are the patches for Lucid till Precise.
Since KVM virtualization is not an option for ARM and neither EC2,
only the master branches should require this. If I did not forget
something.

Changes tested on 32bit hosts/32bit guest for all releases and
additionally on a 64bit host/32bit+64bit guest for Lucid.

-Stefan

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 

Thread Tools




All times are GMT. The time now is 07:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org