FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Kernel Team

 
 
LinkBack Thread Tools
 
Old 04-07-2011, 09:15 PM
Herton Ronaldo Krzesinski
 
Default Regression on hibernate with x86_64 in 2.6.38.2

Hi,

I don't know if everyone is seeing this, but yesterday I hit a bug in
hibernate, and filled a bug for it (LP#752870). I would expect hibernate
not working on a lot of amd64 machines since 2.6.38.2 (may be all,
depending by luck of initialized value of mmu_cr4_features var).

Basically, with 2.6.38.2 it crashes consistently right after image is
restored in resume from hibernate on a test machine here with natty
amd64. After fighting a bit with grub2 to get a full picture of the oops,
I went to bisect, and results are on the ticket.

After getting the fault commit, I went to poke at the code and found the
issue, and right after I saw upstream getting a fix today afternoon. As
a response to this, attached goes the cherry picked fix for natty, the
only one currently affected. I confirmed the fix works on my machine.

Please consider applying it. The patch isn't with Cc stable, I'll try to
contact/send this later to stable ML. Also would be good more testers to
confirm the issue, I'm curious about how widespread is this problem.

--
[]'s
Herton

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 04-08-2011, 12:39 PM
Tim Gardner
 
Default Regression on hibernate with x86_64 in 2.6.38.2

On 04/07/2011 03:15 PM, Herton Ronaldo Krzesinski wrote:

Hi,

I don't know if everyone is seeing this, but yesterday I hit a bug in
hibernate, and filled a bug for it (LP#752870). I would expect hibernate
not working on a lot of amd64 machines since 2.6.38.2 (may be all,
depending by luck of initialized value of mmu_cr4_features var).

Basically, with 2.6.38.2 it crashes consistently right after image is
restored in resume from hibernate on a test machine here with natty
amd64. After fighting a bit with grub2 to get a full picture of the oops,
I went to bisect, and results are on the ticket.

After getting the fault commit, I went to poke at the code and found the
issue, and right after I saw upstream getting a fix today afternoon. As
a response to this, attached goes the cherry picked fix for natty, the
only one currently affected. I confirmed the fix works on my machine.

Please consider applying it. The patch isn't with Cc stable, I'll try to
contact/send this later to stable ML. Also would be good more testers to
confirm the issue, I'm curious about how widespread is this problem.



applied

--
Tim Gardner tim.gardner@canonical.com

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 

Thread Tools




All times are GMT. The time now is 06:24 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org