FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Kernel Team

 
 
LinkBack Thread Tools
 
Old 10-29-2010, 05:38 PM
Gursimran singh
 
Default Regarding Display wrong EDID information ..Blank display at bootup

hi,
* I'm Gursimran singh Mohar. I work for Ubuntu Bug control team. Someday I hope work for kernel triaging also. I have a display problem that I would like to share here.

My laptop Sonay vaio(VPC CW 16FG) has Nvidia 230M GPU. The laptop ends up in a blank display when booted directly into maverick. This is possibly caused because the driver (nouveau) is not able to read the EDID information of the display attached to laptop. These are some of the fourms that discus the issue ...


http://www.nvnews.net/vbulletin/showthread.php?t=140482&page=5
http://ubuntuforums.org/showthread.php?t=1470822


I start the computer by adding a 'nomodeset' in the boot parameters( http://lemoney92.blogspot.com/2010/09/linux-blank-screen-problem.html). But using mainline kernel linux-image-2.6.36-999-generic_2.6.36-999.201010271121_i386 however, I'm able to boot into directly. It works absolutely fine. Now I wanted to help somebody as a tester, if somebody could provide some ubuntu specific patch work and talk to upstream kernel team about this.


using this linux-image-2.6.36-999-generic_2.6.36-999.201010261121_i386 and all previous the problem perists. I'm attaching some videos that are made booting from the two kernels.


--

Warm Regards,
Gursimran singh Mohar


--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 10-29-2010, 07:53 PM
Eric Miao
 
Default Regarding Display wrong EDID information ..Blank display at bootup

On Sat, Oct 30, 2010 at 1:38 AM, Gursimran singh <simar.i3r@gmail.com> wrote:
> hi,
> * I'm Gursimran singh Mohar. I work for Ubuntu Bug control team. Someday I
> hope work for kernel triaging also. I have a display problem that I would
> like to share here.
>
> My laptop Sonay vaio(VPC CW 16FG) has Nvidia 230M GPU. The laptop ends up in
> a blank display when booted directly into maverick. This is possibly caused
> because the driver (nouveau) is not able to read the EDID information of the
> display attached to laptop. These are some of the fourms that discus the
> issue ...
>
> http://www.nvnews.net/vbulletin/showthread.php?t=140482&page=5
> http://ubuntuforums.org/showthread.php?t=1470822
>
> I start the computer by adding a 'nomodeset' in the boot parameters(
> ). But
> using mainline kernel
> linux-image-2.6.36-999-generic_2.6.36-999.201010271121_i386 however, I'm
> able to boot into directly. It works absolutely fine. Now I wanted to help
> somebody as a tester, if somebody could provide some ubuntu specific patch
> work and talk to upstream kernel team about this.
>
> using this linux-image-2.6.36-999-generic_2.6.36-999.201010261121_i386 and
> all previous the problem perists. I'm attaching some videos that are made
> booting from the two kernels.
>

I think the way to go is to identify which patch fixed this problem, and see if
that patch qualifies the SRU process.

What I suspect is the patch below fixed your problem, but it's more like
a feature-adding patch.

a6ed76d drm/nouveau: support fetching LVDS EDID from ACPI

Would be really good if you can get this backported and do some test.

Thanks
- eric

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 10-29-2010, 08:35 PM
Eric Miao
 
Default Regarding Display wrong EDID information ..Blank display at bootup

On Sat, Oct 30, 2010 at 4:33 AM, Eric Miao <eric.miao@canonical.com> wrote:
> On Sat, Oct 30, 2010 at 4:16 AM, Gursimran singh <simar.i3r@gmail.com> wrote:
>>
>>
>> On Sat, Oct 30, 2010 at 1:23 AM, Eric Miao <eric.miao@canonical.com> wrote:
>>>
>>> On Sat, Oct 30, 2010 at 1:38 AM, Gursimran singh <simar.i3r@gmail.com>
>>> wrote:
>>> > hi,
>>> > * I'm Gursimran singh Mohar. I work for Ubuntu Bug control team. Someday
>>> > I
>>> > hope work for kernel triaging also. I have a display problem that I
>>> > would
>>> > like to share here.
>>> >
>>> > My laptop Sonay vaio(VPC CW 16FG) has Nvidia 230M GPU. The laptop ends
>>> > up in
>>> > a blank display when booted directly into maverick. This is possibly
>>> > caused
>>> > because the driver (nouveau) is not able to read the EDID information of
>>> > the
>>> > display attached to laptop. These are some of the fourms that discus the
>>> > issue ...
>>> >
>>> > http://www.nvnews.net/vbulletin/showthread.php?t=140482&page=5
>>> > http://ubuntuforums.org/showthread.php?t=1470822
>>> >
>>> > I start the computer by adding a 'nomodeset' in the boot parameters(
>>> > ). But
>>> > using mainline kernel
>>> > linux-image-2.6.36-999-generic_2.6.36-999.201010271121_i386 however, I'm
>>> > able to boot into directly. It works absolutely fine. Now I wanted to
>>> > help
>>> > somebody as a tester, if somebody could provide some ubuntu specific
>>> > patch
>>> > work and talk to upstream kernel team about this.
>>> >
>>> > using this linux-image-2.6.36-999-generic_2.6.36-999.201010261121_i386
>>> > and
>>> > all previous the problem perists. I'm attaching some videos that are
>>> > made
>>> > booting from the two kernels.
>>> >
>>>
>>> I think the way to go is to identify which patch fixed this problem, and
>>> see if
>>> that patch qualifies the SRU process.
>>
>> From where you get the information about this patch. I mean, I see the
>> changelog but found no such thing.
>>>
>>> What I suspect is the patch below fixed your problem, but it's more like
>>> a feature-adding patch.
>>>
>>> a6ed76d drm/nouveau: support fetching LVDS EDID from ACPI
>>>
>>> Would be really good if you can get this backported and do some test.
>>
>> I'm just a beginner here. Not much knowledge both of kernel internals as
>> well as working process. But, I guess I can help testing if someone could
>> help me how to..
>>
>> This problem occurs in many Sony vaio laptops and many of then still uses
>> Karmic as it does not have nouveau in it.
>>
>
> Hi Gursimran,
>
> Would you please help file a bug on launchpad, or point the link if
> that's already opened? So that we can track all the details there?
>

Cc'ed the kernel-team, and you can reference the link below if you are new
to bug reporting.

https://help.ubuntu.com/community/ReportingBugs

> Thanks
> - eric
>

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 

Thread Tools




All times are GMT. The time now is 12:16 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org