FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Kernel Team

 
 
LinkBack Thread Tools
 
Old 05-28-2010, 05:48 PM
Chase Douglas
 
Default Please pull rt2870.bin reversion

Tim,

The 1.34.1 update pushed to -proposed modified rt2870.bin as part of an
upstream commit that added in rt3070.bin and rt3071.bin. No bug reports
have been filed to have the rt2870.bin firmware file updated, so, in the
interest of reducing regression potential, the file has been reverted to
the previous version. Please review and upload to -proposed again.

Thanks

The following changes since commit 5ae9e9597dcd1bd3c1f984695291bc4dd03bb110:
Chase Douglas (1):
Ubuntu-1.34.1

are available in the git repository at:

git://kernel.ubuntu.com/cndougla/linux-firmware.git lucid-updates

Chase Douglas (2):
UBUNTU: Revert modification to rt2870.bin
Ubuntu-1.34.2

debian/changelog | 6 ++++++
rt2870.bin | Bin 4096 -> 4096 bytes
2 files changed, 6 insertions(+), 0 deletions(-)

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 05-28-2010, 07:08 PM
Tim Gardner
 
Default Please pull rt2870.bin reversion

On 05/28/2010 11:48 AM, Chase Douglas wrote:
> Tim,
>
> The 1.34.1 update pushed to -proposed modified rt2870.bin as part of an
> upstream commit that added in rt3070.bin and rt3071.bin. No bug reports
> have been filed to have the rt2870.bin firmware file updated, so, in the
> interest of reducing regression potential, the file has been reverted to
> the previous version. Please review and upload to -proposed again.
>
> Thanks
>
> The following changes since commit 5ae9e9597dcd1bd3c1f984695291bc4dd03bb110:
> Chase Douglas (1):
> Ubuntu-1.34.1
>
> are available in the git repository at:
>
> git://kernel.ubuntu.com/cndougla/linux-firmware.git lucid-updates
>
> Chase Douglas (2):
> UBUNTU: Revert modification to rt2870.bin
> Ubuntu-1.34.2
>
> debian/changelog | 6 ++++++
> rt2870.bin | Bin 4096 -> 4096 bytes
> 2 files changed, 6 insertions(+), 0 deletions(-)

uploaded

--
Tim Gardner tim.gardner@canonical.com

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 05-31-2010, 01:34 AM
Ben Hutchings
 
Default Please pull rt2870.bin reversion

On Fri, 2010-05-28 at 13:48 -0400, Chase Douglas wrote:
> Tim,
>
> The 1.34.1 update pushed to -proposed modified rt2870.bin as part of an
> upstream commit that added in rt3070.bin and rt3071.bin. No bug reports
> have been filed to have the rt2870.bin firmware file updated, so, in the
> interest of reducing regression potential, the file has been reverted to
> the previous version. Please review and upload to -proposed again.
[...]

This is just wrong. No upstream version of Linux before 2.6.34 uses
rt2870.bin. The commit you're reverting updated it to match the version
previously embedded in the rt2870sta driver, which I removed from the
driver in 2.6.34.

Ben.

--
Ben Hutchings
Once a job is fouled up, anything done to improve it makes it worse.
--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 06-01-2010, 01:53 PM
Chase Douglas
 
Default Please pull rt2870.bin reversion

On Mon, 2010-05-31 at 02:34 +0100, Ben Hutchings wrote:
> On Fri, 2010-05-28 at 13:48 -0400, Chase Douglas wrote:
> > Tim,
> >
> > The 1.34.1 update pushed to -proposed modified rt2870.bin as part of an
> > upstream commit that added in rt3070.bin and rt3071.bin. No bug reports
> > have been filed to have the rt2870.bin firmware file updated, so, in the
> > interest of reducing regression potential, the file has been reverted to
> > the previous version. Please review and upload to -proposed again.
> [...]
>
> This is just wrong. No upstream version of Linux before 2.6.34 uses
> rt2870.bin. The commit you're reverting updated it to match the version
> previously embedded in the rt2870sta driver, which I removed from the
> driver in 2.6.34.

Ok, it does seem that the rt2870 driver we ship as part of 10.04 doesn't
use the rt2870.bin firmware file. However, it's possible that people are
using the firmware with a self-compiled driver or maybe through our
linux-backports-modules package, which has wireless drivers from 2.6.34.
If there's a chance people are using it without issue, then we should
consider not updating it until an issue arises. If 10.04 weren't already
released this would be a different issue, and in Maverick we have pulled
in the updated rt2870.bin firmware file.

-- Chase


--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 06-01-2010, 04:47 PM
Ben Hutchings
 
Default Please pull rt2870.bin reversion

On Tue, Jun 01, 2010 at 09:53:05AM -0400, Chase Douglas wrote:
> On Mon, 2010-05-31 at 02:34 +0100, Ben Hutchings wrote:
> > On Fri, 2010-05-28 at 13:48 -0400, Chase Douglas wrote:
> > > Tim,
> > >
> > > The 1.34.1 update pushed to -proposed modified rt2870.bin as part of an
> > > upstream commit that added in rt3070.bin and rt3071.bin. No bug reports
> > > have been filed to have the rt2870.bin firmware file updated, so, in the
> > > interest of reducing regression potential, the file has been reverted to
> > > the previous version. Please review and upload to -proposed again.
> > [...]
> >
> > This is just wrong. No upstream version of Linux before 2.6.34 uses
> > rt2870.bin. The commit you're reverting updated it to match the version
> > previously embedded in the rt2870sta driver, which I removed from the
> > driver in 2.6.34.
>
> Ok, it does seem that the rt2870 driver we ship as part of 10.04 doesn't
> use the rt2870.bin firmware file. However, it's possible that people are
> using the firmware with a self-compiled driver or maybe through our
> linux-backports-modules package, which has wireless drivers from 2.6.34.
> If there's a chance people are using it without issue, then we should
> consider not updating it until an issue arises. If 10.04 weren't already
> released this would be a different issue, and in Maverick we have pulled
> in the updated rt2870.bin firmware file.

The previous version of rt2870.bin, added to linux-firmware by me in commit
4618e53cccab720a8e74f9a3c9db362736fc8d01, is only useful with some versions
of the Debian kernel package which have an earlier version of the firmware
loading patch for rt2870sta.

All mainline kernel versions where rt2870sta loads external firmware have
a minimum version check for version 17, which is what was previously
embedded in it and which I copied into linux-firmware in commit
a1deff1f10974707739264269a4a16c73b4b2df9.

Given that you are including the updated rt2870sta in Lucid, you must
update the firmware there as well.

Ben.

--
Ben Hutchings
We get into the habit of living before acquiring the habit of thinking.
- Albert Camus

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 

Thread Tools




All times are GMT. The time now is 10:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org