On Mon, May 24, 2010 at 8:41 AM, Naresh Mehta <firstname.lastname@example.org> wrote:
> Hi All,
> I am trying to compile Ofono in Ubuntu 10.04. I have a problem with the
> glibc version number. Ofono needs a version >2.16 whereas 10.04 gives 2.10.
> Upstream of glibc is at 2.9. Why is ubuntu 10.04 stuck at 2.10? Is there a
> reason for that and/or are there any plans to upgrade the library later on?
Please don't confuse 2.10 and 2.1.0, or GLib and the GNU C Library
Since I am unsure whether you are referring to glibc (GNU C Library)
or GLib (GNOME's platform independent utility library), I will
describe both requirements as clearly as I can -- both how they are
implemented in Ubuntu, and what oFono requires.
Per the GNU C Library homepage, the latest version is 2.11.2:
The GNU C Library recently has a binary-compatible fork called eglibc.
Debian (and Ubuntu) have migrated to that; see
http://www.eglibc.org/home for their homepage.
I found out what package contains the GNU C Library in Ubuntu with this command:
$ apt-file search /lib/libc.so.6
So the libc6 package provides the GNU C Library. A bit more digging:
$ aptitude show libc6
Automatically installed: no
Maintainer: Ubuntu Core developers <email@example.com>
Uncompressed Size: 10.5M
Depends: libc-bin (= 2.11.1-0ubuntu7), debconf (>= 0.5) | debconf-2.0, libgcc1,
tzdata, findutils (>= 4.4.0-2ubuntu2)
Suggests: glibc-doc, locales
Conflicts: belocs-locales-bin, tzdata (< 2007k-1), tzdata-etch
Breaks: nscd (< 2.9)
Description: Embedded GNU C Library: Shared libraries
Contains the standard libraries that are used by nearly all programs on the
system. This package includes shared versions of the standard C library and
the standard math library, as well as many others.
So version 2.11.1 is provided in Ubuntu 10.04.
I'm not really sure where you're getting that oFono requires version
2.16, unless you mean GLib, which is completely different. GLib does
indeed have a version 2.16.
Looking in oFono's configure.ac, it seems that it does indeed require
GLib (from GNOME) version 2.16 or later. So the error you're actually
hitting is that your GLib development headers are not installed.
Here's the salient lines of configure.ac:
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.16, dummy=yes,
AC_MSG_ERROR(GLib >= 2.16 is required))
To install the GLib development headers on Ubuntu, install the package
After installing the required dependencies, I got ofono to build from
git on 10.04 with no problems.
> Previous versions of Ubuntu had glibc package available which is not
> available with 10.04. It would be great if somebody can throw some light
The two packages for glibc (note: not GLib) are libc6 and libc6-dev.
The latter is installed when you install build-essential. But the
actual problem you're hitting is with GLib, not glibc.
> Please do guide me to the appropriate mailing list if this is not the
> intended one.
> BR; Naresh
> visit me at:
> kernel-team mailing list
kernel-team mailing list