FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Kernel Team

 
 
LinkBack Thread Tools
 
Old 05-19-2010, 08:19 PM
Tim Gardner
 
Default Maverick: Further abstraction of the source package name

This is a multi-part message in MIME format.
This is kind of handy for the LTS backport work.

rtg
--
Tim Gardner tim.gardner@canonical.com
 
Old 05-20-2010, 07:37 AM
Andy Whitcroft
 
Default Maverick: Further abstraction of the source package name

On Wed, May 19, 2010 at 02:19:51PM -0600, Tim Gardner wrote:
> This is kind of handy for the LTS backport work.

This needs some thought as it is only sensible for the backports kernels.
If we apply this generally we will rename the linux-image- packages for
the arm and ec2 branches which was a big issue for the installer etc when
we introduced those initially. To fix it there we moved to a different
ABI number to introduce the version separation.

I also think this also introduces an issue that we have
/lib/modules/2.6.34-1-generic owned by linux-imaverick-image-* and also
in linux-image-* on upgrade.

In this context I think the only issue is the collision of versions in
the archive. For other packages the common case is to use a version
suffix on the older release. If I have understood things correctly
just adding a ~lucid1 suffix would be sufficient to differentiate them
to the archive and allow upgrades to succeed as the package would be the
same name and an updgradable version number.

Thoughts?

-apw

>
> rtg
> --
> Tim Gardner tim.gardner@canonical.com

> From d77772413c575c11cdb66f7806385a6d6a4e9064 Mon Sep 17 00:00:00 2001
> From: Tim Gardner <tim.gardner@canonical.com>
> Date: Wed, 19 May 2010 14:10:09 -0600
> Subject: [PATCH] UBUNTU: [Config] Further abstraction of source package name.
>
> Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
> ---
> debian.master/control.d/flavour-control.stub | 12 ++++++------
> debian.master/control.stub.in | 10 +++++-----
> 2 files changed, 11 insertions(+), 11 deletions(-)
>
> diff --git a/debian.master/control.d/flavour-control.stub b/debian.master/control.d/flavour-control.stub
> index a2d2a4d..3c41e61 100644
> --- a/debian.master/control.d/flavour-control.stub
> +++ b/debian.master/control.d/flavour-control.stub
> @@ -21,12 +21,12 @@
> #
> # XXX: Leave the blank line before the first package!!
>
> -Package: linux-image-PKGVER-ABINUM-FLAVOUR
> +Package: SRCPKGNAME-image-PKGVER-ABINUM-FLAVOUR
> Architecture: ARCH
> Section: admin
> Priority: optional
> Pre-Depends: dpkg (>= 1.10.24)
> -Provides: linux-image, linux-image-2.6, fuse-module, =PROVIDES=
> +Provides: SRCPKGNAME-image, SRCPKGNAME-image-2.6, fuse-module, =PROVIDES=
> Depends: ${miscepends}, ${shlibsepends}, initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3), wireless-crda
> Conflicts: hotplug (<< 0.0.20040105-1)
> Breaks: lvm2 (<< 2.02.54-1ubuntu3)
> @@ -45,10 +45,10 @@ Description: Linux kernel image for version PKGVER on DESC
> TARGET
> .
> You likely do not want to install this package directly. Instead, install
> - the linux-FLAVOUR meta-package, which will ensure that upgrades work
> + the SRCPKGNAME-FLAVOUR meta-package, which will ensure that upgrades work
> correctly, and that supporting packages are also installed.
>
> -Package: linux-headers-PKGVER-ABINUM-FLAVOUR
> +Package: SRCPKGNAME-headers-PKGVER-ABINUM-FLAVOUR
> Architecture: ARCH
> Section: devel
> Priority: optional
> @@ -61,12 +61,12 @@ Description: Linux kernel headers for version PKGVER on DESC
> This is for sites that want the latest kernel headers. Please read
> /usr/share/doc/SRCPKGNAME-headers-PKGVER-ABINUM/debian.README.gz for details.
>
> -Package: linux-image-PKGVER-ABINUM-FLAVOUR-dbgsym
> +Package: SRCPKGNAME-image-PKGVER-ABINUM-FLAVOUR-dbgsym
> Architecture: ARCH
> Section: devel
> Priority: optional
> Depends: ${miscepends}
> -Provides: linux-debug
> +Provides: SRCPKGNAME-debug
> Description: Linux kernel debug image for version PKGVER on DESC
> This package provides a kernel debug image for version PKGVER on
> DESC.
> diff --git a/debian.master/control.stub.in b/debian.master/control.stub.in
> index d51aaba..6512c37 100644
> --- a/debian.master/control.stub.in
> +++ b/debian.master/control.stub.in
> @@ -1,4 +1,4 @@
> -Source: linux
> +Source: SRCPKGNAME
> Section: devel
> Priority: optional
> Maintainer: Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
> @@ -28,7 +28,7 @@ Description: Linux kernel source for version PKGVER with Ubuntu patches
> been designed to ease the task of creating kernel image packages.
> .
> If you are simply trying to build third-party modules for your kernel,
> - you do not want this package. Install the appropriate linux-headers
> + you do not want this package. Install the appropriate SRCPKGNAME-headers
> package instead.
>
> Package: SRCPKGNAME-doc
> @@ -55,7 +55,7 @@ Description: Linux kernel specific tools for version PKGVER
> This package provides the architecture independent parts for kernel
> version locked tools in the PKGVER kernel source.
>
> -Package: linux-headers-PKGVER-ABINUM
> +Package: SRCPKGNAME-headers-PKGVER-ABINUM
> Architecture: all
> Section: devel
> Priority: optional
> @@ -78,11 +78,11 @@ Description: Linux Kernel Headers for development
> libraries. They are NOT meant to be used to build third-party modules for
> your kernel. Use SRCPKGNAME-headers-* packages for that.
>
> -Package: linux-tools-PKGVER-ABINUM
> +Package: SRCPKGNAME-tools-PKGVER-ABINUM
> Architecture: i386 amd64 ia64 powerpc sparc armel
> Section: devel
> Priority: optional
> -Depends: ${miscepends}, ${shlibsepends}, linux-tools-common
> +Depends: ${miscepends}, ${shlibsepends}, SRCPKGNAME-tools-common
> Description: Linux kernel tools for version PKGVER-ABINUM
> This package provides the architecture dependant parts for kernel
> version locked tools for version PKGVER-ABINUM on
> --
> 1.7.0.4
>

> --
> kernel-team mailing list
> kernel-team@lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/kernel-team


--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 05-20-2010, 12:51 PM
Tim Gardner
 
Default Maverick: Further abstraction of the source package name

On 05/20/2010 01:37 AM, Andy Whitcroft wrote:
> On Wed, May 19, 2010 at 02:19:51PM -0600, Tim Gardner wrote:
>> This is kind of handy for the LTS backport work.
>
> This needs some thought as it is only sensible for the backports kernels.
> If we apply this generally we will rename the linux-image- packages for
> the arm and ec2 branches which was a big issue for the installer etc when
> we introduced those initially. To fix it there we moved to a different
> ABI number to introduce the version separation.
>

Everything was so simple and elegant until you pointed that out.

Leann - consider this NAK'd. Andy has a good point, and I can't really
get the Lucid installer to change its ways.

> I also think this also introduces an issue that we have
> /lib/modules/2.6.34-1-generic owned by linux-imaverick-image-* and also
> in linux-image-* on upgrade.
>
> In this context I think the only issue is the collision of versions in
> the archive. For other packages the common case is to use a version
> suffix on the older release. If I have understood things correctly
> just adding a ~lucid1 suffix would be sufficient to differentiate them
> to the archive and allow upgrades to succeed as the package would be the
> same name and an updgradable version number.
>

Seems like that ought to fix the upgrade problem. Lemme take another
pass at it.

rtg

> Thoughts?
>
> -apw
>
>>
>> rtg
>> --
>> Tim Gardner tim.gardner@canonical.com
>
>> From d77772413c575c11cdb66f7806385a6d6a4e9064 Mon Sep 17 00:00:00 2001
>> From: Tim Gardner<tim.gardner@canonical.com>
>> Date: Wed, 19 May 2010 14:10:09 -0600
>> Subject: [PATCH] UBUNTU: [Config] Further abstraction of source package name.
>>
>> Signed-off-by: Tim Gardner<tim.gardner@canonical.com>
>> ---
>> debian.master/control.d/flavour-control.stub | 12 ++++++------
>> debian.master/control.stub.in | 10 +++++-----
>> 2 files changed, 11 insertions(+), 11 deletions(-)
>>
>> diff --git a/debian.master/control.d/flavour-control.stub b/debian.master/control.d/flavour-control.stub
>> index a2d2a4d..3c41e61 100644
>> --- a/debian.master/control.d/flavour-control.stub
>> +++ b/debian.master/control.d/flavour-control.stub
>> @@ -21,12 +21,12 @@
>> #
>> # XXX: Leave the blank line before the first package!!
>>
>> -Package: linux-image-PKGVER-ABINUM-FLAVOUR
>> +Package: SRCPKGNAME-image-PKGVER-ABINUM-FLAVOUR
>> Architecture: ARCH
>> Section: admin
>> Priority: optional
>> Pre-Depends: dpkg (>= 1.10.24)
>> -Provides: linux-image, linux-image-2.6, fuse-module, =PROVIDES=
>> +Provides: SRCPKGNAME-image, SRCPKGNAME-image-2.6, fuse-module, =PROVIDES=
>> Depends: ${miscepends}, ${shlibsepends}, initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3), wireless-crda
>> Conflicts: hotplug (<< 0.0.20040105-1)
>> Breaks: lvm2 (<< 2.02.54-1ubuntu3)
>> @@ -45,10 +45,10 @@ Description: Linux kernel image for version PKGVER on DESC
>> TARGET
>> .
>> You likely do not want to install this package directly. Instead, install
>> - the linux-FLAVOUR meta-package, which will ensure that upgrades work
>> + the SRCPKGNAME-FLAVOUR meta-package, which will ensure that upgrades work
>> correctly, and that supporting packages are also installed.
>>
>> -Package: linux-headers-PKGVER-ABINUM-FLAVOUR
>> +Package: SRCPKGNAME-headers-PKGVER-ABINUM-FLAVOUR
>> Architecture: ARCH
>> Section: devel
>> Priority: optional
>> @@ -61,12 +61,12 @@ Description: Linux kernel headers for version PKGVER on DESC
>> This is for sites that want the latest kernel headers. Please read
>> /usr/share/doc/SRCPKGNAME-headers-PKGVER-ABINUM/debian.README.gz for details.
>>
>> -Package: linux-image-PKGVER-ABINUM-FLAVOUR-dbgsym
>> +Package: SRCPKGNAME-image-PKGVER-ABINUM-FLAVOUR-dbgsym
>> Architecture: ARCH
>> Section: devel
>> Priority: optional
>> Depends: ${miscepends}
>> -Provides: linux-debug
>> +Provides: SRCPKGNAME-debug
>> Description: Linux kernel debug image for version PKGVER on DESC
>> This package provides a kernel debug image for version PKGVER on
>> DESC.
>> diff --git a/debian.master/control.stub.in b/debian.master/control.stub.in
>> index d51aaba..6512c37 100644
>> --- a/debian.master/control.stub.in
>> +++ b/debian.master/control.stub.in
>> @@ -1,4 +1,4 @@
>> -Source: linux
>> +Source: SRCPKGNAME
>> Section: devel
>> Priority: optional
>> Maintainer: Ubuntu Kernel Team<kernel-team@lists.ubuntu.com>
>> @@ -28,7 +28,7 @@ Description: Linux kernel source for version PKGVER with Ubuntu patches
>> been designed to ease the task of creating kernel image packages.
>> .
>> If you are simply trying to build third-party modules for your kernel,
>> - you do not want this package. Install the appropriate linux-headers
>> + you do not want this package. Install the appropriate SRCPKGNAME-headers
>> package instead.
>>
>> Package: SRCPKGNAME-doc
>> @@ -55,7 +55,7 @@ Description: Linux kernel specific tools for version PKGVER
>> This package provides the architecture independent parts for kernel
>> version locked tools in the PKGVER kernel source.
>>
>> -Package: linux-headers-PKGVER-ABINUM
>> +Package: SRCPKGNAME-headers-PKGVER-ABINUM
>> Architecture: all
>> Section: devel
>> Priority: optional
>> @@ -78,11 +78,11 @@ Description: Linux Kernel Headers for development
>> libraries. They are NOT meant to be used to build third-party modules for
>> your kernel. Use SRCPKGNAME-headers-* packages for that.
>>
>> -Package: linux-tools-PKGVER-ABINUM
>> +Package: SRCPKGNAME-tools-PKGVER-ABINUM
>> Architecture: i386 amd64 ia64 powerpc sparc armel
>> Section: devel
>> Priority: optional
>> -Depends: ${miscepends}, ${shlibsepends}, linux-tools-common
>> +Depends: ${miscepends}, ${shlibsepends}, SRCPKGNAME-tools-common
>> Description: Linux kernel tools for version PKGVER-ABINUM
>> This package provides the architecture dependant parts for kernel
>> version locked tools for version PKGVER-ABINUM on
>> --
>> 1.7.0.4
>>
>
>> --
>> kernel-team mailing list
>> kernel-team@lists.ubuntu.com
>> https://lists.ubuntu.com/mailman/listinfo/kernel-team
>


--
Tim Gardner tim.gardner@canonical.com

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 

Thread Tools




All times are GMT. The time now is 05:14 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org