FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Kernel Team

 
 
LinkBack Thread Tools
 
Old 03-11-2010, 12:14 PM
"Sebastian Spaeth"
 
Default Add support for Marvell 8431 to 2.6.31 series

Sorry, looking at the mail archive, it seems my mailer screwed up. I am
going to resend this mail with those 4 patches being sent by
git-send-email.

On Thu, 11 Mar 2010, Sebastian Spaeth <Sebastian@SSpaeth.de> wrote:
> New netbooks (eg. the Hewlett Packard 5102) have a Marvell ethernet card
> (0x11AB:0x8431). Support for this card went into 2.6.33 (in the sky2
> driver), but not yet in 2.6.31. The upstreamed patches to support it has
> been taken into the Suse 2.6.31 kernel and work fine there.
>
> Given that the 2.6.31 kernel is going to be used for quite some time, it
> would be great to also support this device and take the Suse patch
> (which is really just 4 kernel upstream patches).
>
> The patches are here:
> http://gitorious.org/opensuse/kernel-source/commit/68c33163d0e1e7bf44cf0bb4c6b8497e944d7886
>
> I filed a bug
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/537168
>
> and attached the patches there as well. I also attach the upstream git
> patches to this email. WOuld adding that be difficult/controversial? It
> is in upstream, I can use it in my Suse Enterprise 11, and opensuse, but
> not in Ubuntu.... (yet)
>
> Thanks for consideration,
> Sebastian

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 03-11-2010, 12:42 PM
Stefan Bader
 
Default Add support for Marvell 8431 to 2.6.31 series

Sebastian Spaeth wrote:
> New netbooks (eg. the Hewlett Packard 5102) have a Marvell ethernet card
> (0x11AB:0x8431). Support for this card went into 2.6.33 (in the sky2
> driver), but not yet in 2.6.31. The upstreamed patches to support it has
> been taken into the Suse 2.6.31 kernel and work fine there.
>
> Given that the 2.6.31 kernel is going to be used for quite some time, it
> would be great to also support this device and take the Suse patch
> (which is really just 4 kernel upstream patches).
>
> The patches are here:
> http://gitorious.org/opensuse/kernel-source/commit/68c33163d0e1e7bf44cf0bb4c6b8497e944d7886
>
> I filed a bug
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/537168
>
> and attached the patches there as well. I also attach the upstream git
> patches to this email. WOuld adding that be difficult/controversial? It
> is in upstream, I can use it in my Suse Enterprise 11, and opensuse, but
> not in Ubuntu.... (yet)
>
> Thanks for consideration,
> Sebastian
>
>
The 2.6.31 kernel is no LTS support and in fact will only be maintained now for
critical problems. Our next LTS release is based on 2.6.32. But this also now is
in feature freeze.
Looking at the changes required for this request alone looks more than would be
acceptable for normal stable release updates. At least not the normal kernel. At
most as a backports module.
Or you try to can try to convince upstream stable (stable@kernel.org) to accept
these. But normally there is also some reservations against taking big
enablement patches.

Stefan

--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 

Thread Tools




All times are GMT. The time now is 10:14 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org