FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Kernel Team

 
 
LinkBack Thread Tools
 
Old 01-07-2009, 12:51 PM
Andy Whitcroft
 
Default UBUNTU: update kernel bootloader recommends: to prefer grub

Bug: #314004

The kernel packages recommend either lilo or grub. The order of these
indicates a preference. Currently we recommend lilo over grub which is
contrary to the default in debian-installer. From Intrepid recommendations
are automatically installed which causes the default desktop installs to
install both grub and lilo. Not a good thing when later they are updated.

Signed-off-by: Andy Whitcroft <apw@canonical.com>
---
debian/control | 6 +++---
debian/control.d/vars.generic | 2 +-
debian/control.d/vars.server | 2 +-
debian/control.stub | 6 +++---
debian/sub-flavours/virtual.vars | 2 +-
5 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/debian/control b/debian/control
index 0bf5c23..cd2f9e2 100644
--- a/debian/control
+++ b/debian/control
@@ -77,7 +77,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, kvm-api-4, redhat-cluster-modules, ivtv-modules, ndiswrapper-modules-1.9
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1)
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
@@ -293,7 +293,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, redhat-cluster-modules, kvm-api-4, ivtv-modules, ndiswrapper-modules-1.9
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1)
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
@@ -401,7 +401,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, redhat-cluster-modules
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1), linux-image-2.6.28-4-server
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
diff --git a/debian/control.d/vars.generic b/debian/control.d/vars.generic
index 60ed340..a2bc149 100644
--- a/debian/control.d/vars.generic
+++ b/debian/control.d/vars.generic
@@ -2,5 +2,5 @@ arch="i386 amd64"
supported="Generic"
target="Geared toward desktop systems."
desc="x86/x86_64"
-bootloader="lilo (>= 19.1) | grub"
+bootloader="grub | lilo (>= 19.1)"
provides="kvm-api-4, redhat-cluster-modules, ivtv-modules, ndiswrapper-modules-1.9"
diff --git a/debian/control.d/vars.server b/debian/control.d/vars.server
index 5885323..1a5024e 100644
--- a/debian/control.d/vars.server
+++ b/debian/control.d/vars.server
@@ -2,5 +2,5 @@ arch="i386 amd64"
supported="Server"
target="Geared toward server systems."
desc="x86/x86_64"
-bootloader="lilo (>= 19.1) | grub"
+bootloader="grub | lilo (>= 19.1)"
provides="redhat-cluster-modules, kvm-api-4, ivtv-modules, ndiswrapper-modules-1.9"
diff --git a/debian/control.stub b/debian/control.stub
index 0bf5c23..cd2f9e2 100644
--- a/debian/control.stub
+++ b/debian/control.stub
@@ -77,7 +77,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, kvm-api-4, redhat-cluster-modules, ivtv-modules, ndiswrapper-modules-1.9
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1)
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
@@ -293,7 +293,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, redhat-cluster-modules, kvm-api-4, ivtv-modules, ndiswrapper-modules-1.9
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1)
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
@@ -401,7 +401,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, redhat-cluster-modules
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1), linux-image-2.6.28-4-server
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
diff --git a/debian/sub-flavours/virtual.vars b/debian/sub-flavours/virtual.vars
index 1f09133..fbe5dac 100644
--- a/debian/sub-flavours/virtual.vars
+++ b/debian/sub-flavours/virtual.vars
@@ -3,7 +3,7 @@ arch="i386 amd64"
supported="Virtual"
target="Geared toward virtual machine guests."
desc="x86/x86_64"
-bootloader="lilo (>= 19.1) | grub"
+bootloader="grub | lilo (>= 19.1)"
is_sub="true"
based_on="server"
# The provides and conflicts are REQUIRED
--
1.6.0.4.911.gc990


--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 
Old 01-07-2009, 12:59 PM
Andy Whitcroft
 
Default UBUNTU: update kernel bootloader recommends: to prefer grub

Bug: #314004

The kernel packages recommend either lilo or grub. The order of these
indicates a preference. Currently we recommend lilo over grub which is
contrary to the default in debian-installer. From Intrepid recommendations
are automatically installed which causes the default desktop installs to
install both grub and lilo. Not a good thing when later they are updated.

Signed-off-by: Andy Whitcroft <apw@canonical.com>
---
debian/control | 6 +++---
debian/control.d/vars.generic | 2 +-
debian/control.d/vars.server | 2 +-
debian/control.stub | 6 +++---
debian/sub-flavours/virtual.vars | 2 +-
5 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/debian/control b/debian/control
index 0bf5c23..cd2f9e2 100644
--- a/debian/control
+++ b/debian/control
@@ -77,7 +77,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, kvm-api-4, redhat-cluster-modules, ivtv-modules, ndiswrapper-modules-1.9
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1)
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
@@ -293,7 +293,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, redhat-cluster-modules, kvm-api-4, ivtv-modules, ndiswrapper-modules-1.9
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1)
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
@@ -401,7 +401,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, redhat-cluster-modules
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1), linux-image-2.6.28-4-server
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
diff --git a/debian/control.d/vars.generic b/debian/control.d/vars.generic
index 60ed340..a2bc149 100644
--- a/debian/control.d/vars.generic
+++ b/debian/control.d/vars.generic
@@ -2,5 +2,5 @@ arch="i386 amd64"
supported="Generic"
target="Geared toward desktop systems."
desc="x86/x86_64"
-bootloader="lilo (>= 19.1) | grub"
+bootloader="grub | lilo (>= 19.1)"
provides="kvm-api-4, redhat-cluster-modules, ivtv-modules, ndiswrapper-modules-1.9"
diff --git a/debian/control.d/vars.server b/debian/control.d/vars.server
index 5885323..1a5024e 100644
--- a/debian/control.d/vars.server
+++ b/debian/control.d/vars.server
@@ -2,5 +2,5 @@ arch="i386 amd64"
supported="Server"
target="Geared toward server systems."
desc="x86/x86_64"
-bootloader="lilo (>= 19.1) | grub"
+bootloader="grub | lilo (>= 19.1)"
provides="redhat-cluster-modules, kvm-api-4, ivtv-modules, ndiswrapper-modules-1.9"
diff --git a/debian/control.stub b/debian/control.stub
index 0bf5c23..cd2f9e2 100644
--- a/debian/control.stub
+++ b/debian/control.stub
@@ -77,7 +77,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, kvm-api-4, redhat-cluster-modules, ivtv-modules, ndiswrapper-modules-1.9
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1)
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
@@ -293,7 +293,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, redhat-cluster-modules, kvm-api-4, ivtv-modules, ndiswrapper-modules-1.9
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1)
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
@@ -401,7 +401,7 @@ Pre-Depends: dpkg (>= 1.10.24)
Provides: linux-image, linux-image-2.6, fuse-module, redhat-cluster-modules
Depends: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools (>= 3.3-pre11-4ubuntu3)
Conflicts: hotplug (<< 0.0.20040105-1), linux-image-2.6.28-4-server
-Recommends: lilo (>= 19.1) | grub
+Recommends: grub | lilo (>= 19.1)
Suggests: fdutils, linux-doc-2.6.28 | linux-source-2.6.28
Description: Linux kernel image for version 2.6.28 on x86/x86_64
This package contains the Linux kernel image for version 2.6.28 on
diff --git a/debian/sub-flavours/virtual.vars b/debian/sub-flavours/virtual.vars
index 1f09133..fbe5dac 100644
--- a/debian/sub-flavours/virtual.vars
+++ b/debian/sub-flavours/virtual.vars
@@ -3,7 +3,7 @@ arch="i386 amd64"
supported="Virtual"
target="Geared toward virtual machine guests."
desc="x86/x86_64"
-bootloader="lilo (>= 19.1) | grub"
+bootloader="grub | lilo (>= 19.1)"
is_sub="true"
based_on="server"
# The provides and conflicts are REQUIRED
--
1.6.0.4.911.gc990


--
kernel-team mailing list
kernel-team@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kernel-team
 

Thread Tools




All times are GMT. The time now is 04:47 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org