FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Development

 
 
LinkBack Thread Tools
 
Old 03-18-2009, 01:09 PM
Colin Watson
 
Default missing dependencies (shlibs:Depends) on lpia from 2009-03-11 - 2009-03-16

On Mon, Mar 16, 2009 at 08:14:52PM +0100, Matthias Klose wrote:
> Packages built on lpia for jaunty between 2009-03-11 - 2009-03-16 don't have
> ${shlibsepends} substituted, and are not correctly stripped, resulting in
> unstripped binary packages for lpia.
>
> This did start with the 2009-03-11 upload of file (unrelated change), and did
> stop on 2009-03-16 with a no-change rebuild of file. The error messages in the
> logs are of the form:
>
> dh_shlibdeps -plibsoup-gnome2.4-1
> /etc/magic, 4: Warning: using regular magic file
> `/build/buildd/file-4.26/debian/tmp/usr/share/file/magic'
> /etc/magic, 4: Warning: using regular magic file
> `/build/buildd/file-4.26/debian/tmp/usr/share/file/magic'
> /etc/magic, 4: Warning: using regular magic file
> `/build/buildd/file-4.26/debian/tmp/usr/share/file/magic'
>
> Best thing would be to rebuild all packages during this time for lpia to correct
> the dependencies.

These will all need manual uploads. Do you have a list? It would be best
to get this out of the way before beta freeze.

--
Colin Watson [cjwatson@ubuntu.com]

--
ubuntu-devel mailing list
ubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
 
Old 03-18-2009, 11:26 PM
Colin Watson
 
Default missing dependencies (shlibs:Depends) on lpia from 2009-03-11 - 2009-03-16

On Wed, Mar 18, 2009 at 02:09:44PM +0000, Colin Watson wrote:
> On Mon, Mar 16, 2009 at 08:14:52PM +0100, Matthias Klose wrote:
> > Best thing would be to rebuild all packages during this time for lpia to correct
> > the dependencies.
>
> These will all need manual uploads. Do you have a list? It would be best
> to get this out of the way before beta freeze.

Here's a manually-filtered list, starting with one generated by Celso
from the Launchpad database and then comparing 'dpkg -I' output against
i386 for everything:

http://people.ubuntu.com/~cjwatson/lpia-rebuilds-20090319

I'm working my way through this now.

--
Colin Watson [cjwatson@ubuntu.com]

--
ubuntu-devel mailing list
ubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
 
Old 03-18-2009, 11:50 PM
Colin Watson
 
Default missing dependencies (shlibs:Depends) on lpia from 2009-03-11 - 2009-03-16

On Thu, Mar 19, 2009 at 12:26:13AM +0000, Colin Watson wrote:
> On Wed, Mar 18, 2009 at 02:09:44PM +0000, Colin Watson wrote:
> > On Mon, Mar 16, 2009 at 08:14:52PM +0100, Matthias Klose wrote:
> > > Best thing would be to rebuild all packages during this time for lpia to correct
> > > the dependencies.
> >
> > These will all need manual uploads. Do you have a list? It would be best
> > to get this out of the way before beta freeze.
>
> Here's a manually-filtered list, starting with one generated by Celso
> from the Launchpad database and then comparing 'dpkg -I' output against
> i386 for everything:
>
> http://people.ubuntu.com/~cjwatson/lpia-rebuilds-20090319
>
> I'm working my way through this now.

By the way, for the moment I would prefer it if people did *not* take
packages off this list and help out by uploading them. I'm taking a bit
of care about the order. Feel free to investigate any marked "FTBFS",
though.

Thanks,

--
Colin Watson [cjwatson@ubuntu.com]

--
ubuntu-devel mailing list
ubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
 

Thread Tools




All times are GMT. The time now is 04:17 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org