FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Development

 
 
LinkBack Thread Tools
 
Old 12-03-2007, 08:55 AM
Matt Zimmerman
 
Default Hardy Alpha 1 released

(This message was mistakenly approved by an ubuntu-devel-announce moderator.
That list is for announcements only, and discussion should take place here)

Ubuntu has included the madwifi stack for years. If it doesn't support your
particular device properly, please file a bug in Launchpad with specific
details.

On Sun, Dec 02, 2007 at 06:16:35PM +0100, bruyere.ronald wrote:
> Dear Sir,
>
> I am a fan of this Linux distribution since years ago but since the version 7.04, I am disappointed because the wifi module in my mobile computer isn't recognised !!!! I hoped with the Hardy Alpha, my Atheros Wifi module be recognised but once again, it isn't !
>
> Could you help me ? Will you think to integrate the madwifi module in the Hardy Ubuntu 8.04 ? As soon as there will be a version which will find ma Atheros wifi network, I'll use you distribution again !!! Just one distribution recognise my version, it is a Mandrake Linux but I would prefer largely your distribution !!!
>
>
>
> Good Luck
>
>
> Yours Faithfully
>
>
>
> Ronald Bruyère
> A belgian Microsoft Windows and Linux OS's user
>
>
> J'utilise BullGuard afin de maintenir propre mon ordinateur.
> Essayez gratuitement BullGuard: www.bullguard.com

> --
> ubuntu-devel-announce mailing list
> ubuntu-devel-announce@lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-announce


--
- mdz

--
Ubuntu-devel-discuss mailing list
Ubuntu-devel-discuss@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss
 
Old 12-03-2007, 10:14 AM
"João Gomes"
 
Default Hardy Alpha 1 released

cher ronald, tu peux voir ta reponse chez http://www.marlow.dk/site.php/tech/madwifi, au revoir

2007/12/2, bruyere.ronald <
bruyere.ronald@skynet.be>:






Dear Sir,
*
I am a fan of this Linux distribution since years
ago but since the version 7.04, I am disappointed because the wifi module in my
mobile computer isn't recognised !!!! I hoped with the Hardy Alpha, my Atheros
Wifi module be recognised but once again, it isn't !
*
Could you help me ? Will you think to integrate the
madwifi module in the Hardy Ubuntu 8.04 ? As soon as there will be a version
which will find ma Atheros wifi network, I'll use you distribution again !!!
Just one distribution recognise my version, it is a Mandrake Linux but I would
prefer largely your distribution !!!
*
*
*
Good Luck
*
*
Yours Faithfully
*
*
*
Ronald Bruyère
A belgian Microsoft Windows and Linux OS's
user



*
J'utilise BullGuard afin de maintenir propre mon ordinateur.
Essayez gratuitement BullGuard:
www.bullguard.com

--
ubuntu-devel-announce mailing list
ubuntu-devel-announce@lists.ubuntu.com

https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-announce



--
Ubuntu-devel-discuss mailing list
Ubuntu-devel-discuss@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss
 
Old 12-03-2007, 12:34 PM
Ped
 
Default Hardy Alpha 1 released

Hello all,

> I am a fan of this Linux distribution since years ago but since the
> version 7.04, I am disappointed because the wifi module in my mobile
> computer isn't recognised !!!! I hoped with the Hardy Alpha, my Atheros
> Wifi module be recognised but once again, it isn't !

I'm using kubuntu only for a year and something (since 6.10), but I'm using
it on a bit obsolete/obscure hardware, one of the devices is USB ADSL modem
SAGEM F@ST 800, second is linksys RT61 WiFi card (I'm not sure about type
and can't check it right now).
From forum post I learned the sagem modem *did* work in 5.xx ubuntu
(probably 2.4 kernel with eagle-usb driver) right after install, but when I
did install 6.10 first time on my PC, it took me 5 days to connect to
internet finally. The reason is probably 2.6 kernel no more working with old
eagle-usb (so far perfectly understandable), and while the 6.10 (7.04 and
7.10 too) does contain newer ueagle-usb driver, it's not functional!
So to make it work I had not only to compile working version of the driver,
I had also to hunt the wrong files in kernel modules, and I have to
delete/rename them every time the kernel is updated. Very very unconvenient
and probably so much confusing for ordinary user that he will not get trough
it. (I'm personally programmer, so I *can* do these things by myself
eventually, if I invest *enough* of my *time* into it)

After some time my friend lend me WiFi RT61 card so he can connect to my
computer and I can share my internet connection with him. Guess what?! Yes,
the driver is included in 6.10, but again it's not working correctly
(although it may look so on first sight, as it reports itself as working,
but the connection works only occasionally and only for short time).
Enlightened from my USB modem experience I did firstly check how-tos on
internet, so I was well prepared for this behavior, downloaded source,
compiled fresh working driver, and now it works.

Couple of days ago I tried to install 7.10. The modem is still dead after
install, so I took the learned route of driver compilation. Guess what?!
In the /etc/ppp/options the "auth" option has been changed to "noauth", so
the 6.10 way of doing things with old configuration files didn't work at
first. (somehow I got the idea to do diff on "options" file as a first step
in troubleshooting, so this little change of Ubuntu team took me only couple
additional minutes to discover) Now it works almost as good as in 6.10
(well, not as good, but that's due to some "improvements" in the driver
source itself, I didn't have time to fight with those yet and it's not
[k]ubuntu related anyway).
I didn't even try the WiFi card yet, but from some boot-up messages I think
it's not working properly again, so another driver compilation is ahead of
me very likely.

The story with 7.04 was pretty much the same, except the bonus of my mic
not working in Skype. As I was lazy to pay more time to troubleshoot it, I
have no idea what/where went wrong. I hope when I will try it in 7.10 it
will work ok, otherwise I will have to finally nail it down.

The moral of my story?
If you don't have skills to compile drivers for yourself on daily basis and
resolve all potentional unexpected problems, don't use distribution where
everything doesn't work right from the start.
Even ordinary user can successfuly compile the drivers thanks to great
Ubuntu community and forums/wikis, but in the end it may backfire on him in
ugly way, if he's not aware for example that the installation of kernel
update may brake the already working things. So I would not recommend any
ordinary user to bother with it.
It also means that upgrading your distribution every 6months can be quite
dangerous without trying it out firstly from liveCD. (Imagine ordinary user
with working usb modem upgrading to fresh ubuntu, leaving him without
internet connection after restart, and with no sane "undo" option ...
connect this with the default ubuntu install putting /home on the same
partition with system, i.e. no easy reinstall of system without losing user
data)
And finally I feel the newer versions of Ubuntu do have worser
(obsolete/old) HW support than the previous ones. I see there's been lot of
work done on accelerated desktop, notebooks support, etc.. and the
Ubuntu8.04 will work probably great on almost-new HW which is in focus of
developers. But from my experience it feels like those who don't want to
upgrade HW so often are left behind on their own, with such regressions.
I especially dislike the inclusion of non-working drivers. I would love to
see the Ubuntu team to cruise a bit trough forums/wikis to discover such
pieces and either completely remove it from kernel or fix it, so it will not
confuse people.

So while I feel sorry with the original mail author, I suggest firstly to
search trough launchpad and to report it as bug, secondly if it is not
fixed, either you will have to fix it up by yourself every time you install
OS, or change distro. Or to fix it for everyone.

And final word. I admit I bear some responsibility for current situation
too, as instead of writing this email I probably should have reported all
the problems much earlier into the launchpad. But some of them are well
known in forums/wikis (sagem modem for sure), so I didn't even bother to
search launchpad if they are already filed.
I'm trying to migrate to 7.10 right now, so I promise I will fill up bug
reports more often with everything what I have to fix by hand.

Regards, Peter.

--

PED - Peter Helcmanovsky - wishing to have 48h days
Braniskova 7 Kosice 04001 Slovakia / phone +420 721308701
(_ -- actually in Prag, so don't look after me --
"~/~" -=- deRATized RAT -=- Being beyond Yer imagination -=-
,_oo_, 7 GODS demo group WWW pages: http://7gods.org
`'

--
Ubuntu-devel-discuss mailing list
Ubuntu-devel-discuss@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss
 
Old 12-03-2007, 01:03 PM
Tomas -
 
Default Hardy Alpha 1 released

Once the new linux kernel (2.6.24) is included, I think your problems will be solved




----- Original Message ----
From: bruyere.ronald <bruyere.ronald@skynet.be>
To: ubuntu-devel-announce@lists.ubuntu.com
Cc: bruyere.ronald@skynet.be
Sent: Sunday, December 2, 2007 6:16:35 PM
Subject: Hardy Alpha 1 released








Dear Sir,
*
I am a fan of this Linux distribution since years
ago but since the version 7.04, I am disappointed because the wifi module in my
mobile computer isn't recognised !!!! I hoped with the Hardy Alpha, my Atheros
Wifi module be recognised but once again, it isn't !
*
Could you help me ? Will you think to integrate the
madwifi module in the Hardy Ubuntu 8.04 ? As soon as there will be a version
which will find ma Atheros wifi network, I'll use you distribution again !!!
Just one distribution recognise my version, it is a Mandrake Linux but I would
prefer largely your distribution !!!
*
*
*
Good Luck
*
*
Yours Faithfully
*
*
*
Ronald Bruyère
A belgian Microsoft Windows and Linux OS's
user*
J'utilise BullGuard afin de maintenir propre mon ordinateur.
Essayez gratuitement BullGuard: www.bullguard.com



Get easy, one-click access to your favorites.
Make Yahoo! your homepage.

--
Ubuntu-devel-discuss mailing list
Ubuntu-devel-discuss@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss
 
Old 12-04-2007, 05:11 AM
"Aaron Whitehouse"
 
Default Hardy Alpha 1 released

> The moral of my story?
> If you don't have skills to compile drivers for yourself on daily basis and
> resolve all potentional unexpected problems, don't use distribution where
> everything doesn't work right from the start.

Given that I went to the trouble of reading this lengthy email, I
thought I would reply.

The reason that Alpha releases are made is so that the more competent
computer users can test that things work. If you report bugs, these
things get fixed.

I do not ever compile kernel modules. There have been occasions where
hardware that used to work correctly stops working. I report these
early in the release cycle (often marked [Regression]) and the
problems are nearly always fixed by release time.

Aaron

--
FSF Associate Member: 5632
http://www.fsf.org

--
Ubuntu-devel-discuss mailing list
Ubuntu-devel-discuss@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss
 
Old 12-04-2007, 04:25 PM
"Conrad Knauer"
 
Default Hardy Alpha 1 released

On Dec 3, 2007 7:34 AM, Ped <ped@7gods.org> wrote:

> From forum post I learned the sagem modem *did* work in 5.xx ubuntu
> (probably 2.4 kernel with eagle-usb driver) right after install, but when I
> did install 6.10 first time on my PC, it took me 5 days to connect to
> internet finally. The reason is probably 2.6 kernel no more working with old
> eagle-usb (so far perfectly understandable), and while the 6.10 (7.04 and
> 7.10 too) does contain newer ueagle-usb driver, it's not functional!

FYI, Ubuntu has always used a 2.6 kernel; note
http://distrowatch.com/table.php?distribution=ubuntu

CK

--
Ubuntu-devel-discuss mailing list
Ubuntu-devel-discuss@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss
 
Old 12-06-2007, 12:24 PM
Colin Watson
 
Default Hardy Alpha 1 released

On Tue, Dec 04, 2007 at 11:25:35AM -0600, Conrad Knauer wrote:
> On Dec 3, 2007 7:34 AM, Ped <ped@7gods.org> wrote:
> > From forum post I learned the sagem modem *did* work in 5.xx ubuntu
> > (probably 2.4 kernel with eagle-usb driver) right after install, but when I
> > did install 6.10 first time on my PC, it took me 5 days to connect to
> > internet finally. The reason is probably 2.6 kernel no more working with old
> > eagle-usb (so far perfectly understandable), and while the 6.10 (7.04 and
> > 7.10 too) does contain newer ueagle-usb driver, it's not functional!
>
> FYI, Ubuntu has always used a 2.6 kernel; note
> http://distrowatch.com/table.php?distribution=ubuntu

For the historians: we actually originally planned to offer 2.4 as an
extra for heavy-duty server users, and Ubuntu 4.10 had 2.4 kernels in
universe. (At some point before release - possibly before we went
public, I'm not certain - they were even in main.) See e.g.:

https://lists.ubuntu.com/archives/ubuntu-devel/2004-October/000419.html

We never supported installation with 2.4, though, and we dropped it
entirely in Ubuntu 5.04.

Cheers,

--
Colin Watson [cjwatson@ubuntu.com]

--
Ubuntu-devel-discuss mailing list
Ubuntu-devel-discuss@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss
 

Thread Tools




All times are GMT. The time now is 03:20 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org