FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > RPM Package Manager

 
 
LinkBack Thread Tools
 
Old 01-03-2008, 07:09 PM
Josh Miller
 
Default SOLVED: rpmbuild -ba builds source but not binary RPM

Josh Miller wrote:

I have an issue where I build an RPM using 'rpmbuild -ba <spec file>'
and it builds the packages and writes a source RPM, but there are no
binaries written out and no errors. Any idea what would cause this? I
also tried with rpmbuild -bb with no luck.

It turns out that the problem with my SPEC file was that I had an errant
% that was not doing anything constructive.


ie:
install -d %(buildroot}/usr/share/%{pkg_name}

which should have been:

install -d %{buildroot}/usr/share/%{pkg_name}

Note that in the first line, there is a '(' just after the '%'. This
caused the build to bail on the install portion of the build. I caught
this after reviewing the Fedora RPM guide and seeing a note about errant
percent signs.


Regards,

--
Joshua M. Miller - RHCE,VCP

_______________________________________________
Rpm-list mailing list
Rpm-list@redhat.com
https://www.redhat.com/mailman/listinfo/rpm-list
 

Thread Tools




All times are GMT. The time now is 02:41 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org