Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   RPM Package Manager (http://www.linux-archive.org/rpm-package-manager/)
-   -   Installing MySQL via RPM on RHEL4 glibc errors (http://www.linux-archive.org/rpm-package-manager/146496-installing-mysql-via-rpm-rhel4-glibc-errors.html)

Josh 08-21-2008 04:29 PM

Installing MySQL via RPM on RHEL4 glibc errors
 
When I try to install mysql on rhel4 I get errors saying glibc needs
updated but when I do rpm -qa | grep glibc it tells me I have
glibc2.3.4 which is newer than the version the mysql rpm tells me I
need? *I'm just trying to get MySQL installed. *Can someone help me
out? *Exact errors are below...


[root@localhost ~]# rpm -i MySQL-server-standard-5.0.22-0.rhel4.ia64.rpm
warning: MySQL-server-standard-5.0.22-0.rhel4.ia64.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:

* * * * libc.so.6.1()(64bit) is needed by MySQL-server-standard-5.0.22-0.rhel4.ia64
* * * * libc.so.6.1(GLIBC_2.2)(64bit) is needed by MySQL-server-standard-5.0.22-0.rhel4.ia64
* * * * libc.so.6.1(GLIBC_2.2.4)(64bit) is needed by MySQL-server-standard-5.0.22-0.rhel4.ia64

* * * * libc.so.6.1(GLIBC_2.3)(64bit) is needed by MySQL-server-standard-5.0.22-0.rhel4.ia64
* * * * libcrypt.so.1(GLIBC_2.0)(64bit) is needed by MySQL-server-standard-5.0.22-0.rhel4.ia64
* * * * libdl.so.2(GLIBC_2.0)(64bit) is needed by MySQL-server-standard-5.0.22-0.rhel4.ia64

* * * * libdl.so.2(GLIBC_2.1)(64bit) is needed by MySQL-server-standard-5.0.22-0.rhel4.ia64
* * * * libm.so.6.1()(64bit) is needed by MySQL-server-standard-5.0.22-0.rhel4.ia64
* * * * libpthread.so.0(GLIBC_2.2)(64bit) is needed by MySQL-server-standard-5.0.22-0.rhel4.ia64

[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# rpm -qa | grep glibc
glibc-2.3.4-2.41
glibc-2.3.4-2.41
glibc-common-2.3.4-2.41
[root@localhost ~]#
_______________________________________________
Rpm-list mailing list
Rpm-list@redhat.com
https://www.redhat.com/mailman/listinfo/rpm-list

Josh 08-21-2008 04:32 PM

Installing MySQL via RPM on RHEL4 glibc errors
 
When I try to install mysql5 on rhel4 I get errors saying glibc needs
updated but when I do rpm -qa | grep glibc it tells me I have glibc2.3.4
which is newer than the version the mysql rpm tells me I need? I'm just
trying to get MySQL installed. Can someone help me out? Exact errors are
below...


[root@localhost ~]# rpm -i MySQL-server-standard-5.0.22-0.rhel4.ia64.rpm
warning: MySQL-server-standard-5.0.22-0.rhel4.ia64.rpm: V3 DSA signature:
NOKEY, key ID 5072e1f5
error: Failed dependencies:
libc.so.6.1()(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libc.so.6.1(GLIBC_2.2)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libc.so.6.1(GLIBC_2.2.4)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libc.so.6.1(GLIBC_2.3)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libcrypt.so.1(GLIBC_2.0)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libdl.so.2(GLIBC_2.0)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libdl.so.2(GLIBC_2.1)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libm.so.6.1()(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libpthread.so.0(GLIBC_2.2)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# rpm -qa | grep glibc
glibc-2.3.4-2.41
glibc-2.3.4-2.41
glibc-common-2.3.4-2.41
[root@localhost ~]#
--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list

Jos Vos 08-21-2008 04:36 PM

Installing MySQL via RPM on RHEL4 glibc errors
 
On Thu, Aug 21, 2008 at 12:29:52PM -0400, Josh wrote:

> [root@localhost ~]# rpm -i MySQL-server-standard-5.0.22-0.rhel4.ia64.rpm
^^^^

Are you really trying to install this on an Itanium (ia64) system?

Otherwise you're using the wrong rpm, you should have the x86_64 version.

--
-- Jos Vos <jos@xos.nl>
-- X/OS Experts in Open Systems BV | Phone: +31 20 6938364
-- Amsterdam, The Netherlands | Fax: +31 20 6948204

_______________________________________________
Rpm-list mailing list
Rpm-list@redhat.com
https://www.redhat.com/mailman/listinfo/rpm-list

Josh 08-21-2008 05:06 PM

Installing MySQL via RPM on RHEL4 glibc errors
 
You were right, doh!, thanks

On Thu, Aug 21, 2008 at 12:36 PM, Jos Vos <jos@xos.nl> wrote:

On Thu, Aug 21, 2008 at 12:29:52PM -0400, Josh wrote:



> [root@localhost ~]# rpm -i MySQL-server-standard-5.0.22-0.rhel4.ia64.rpm

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *^^^^



Are you really trying to install this on an Itanium (ia64) system?



Otherwise you're using the wrong rpm, you should have the x86_64 version.



--

-- * *Jos Vos <jos@xos.nl>

-- * *X/OS Experts in Open Systems BV * | * Phone: +31 20 6938364

-- * *Amsterdam, The Netherlands * * * *| * * Fax: +31 20 6948204



_______________________________________________

Rpm-list mailing list

Rpm-list@redhat.com

https://www.redhat.com/mailman/listinfo/rpm-list



_______________________________________________
Rpm-list mailing list
Rpm-list@redhat.com
https://www.redhat.com/mailman/listinfo/rpm-list

"Knabe, Troy" 08-21-2008 08:55 PM

Installing MySQL via RPM on RHEL4 glibc errors
 
You need both the 64 bit and 32 bit gcc libraries.

-Troy


On 8/21/08 9:32 AM, "Josh" <serjosh@gmail.com> wrote:

When I try to install mysql5 on rhel4 I get errors saying glibc needs
updated but when I do rpm -qa | grep glibc it tells me I have glibc2.3.4
which is newer than the version the mysql rpm tells me I need? I'm just
trying to get MySQL installed. Can someone help me out? Exact errors are
below...


[root@localhost ~]# rpm -i MySQL-server-standard-5.0.22-0.rhel4.ia64.rpm
warning: MySQL-server-standard-5.0.22-0.rhel4.ia64.rpm: V3 DSA signature:
NOKEY, key ID 5072e1f5
error: Failed dependencies:
libc.so.6.1()(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libc.so.6.1(GLIBC_2.2)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libc.so.6.1(GLIBC_2.2.4)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libc.so.6.1(GLIBC_2.3)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libcrypt.so.1(GLIBC_2.0)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libdl.so.2(GLIBC_2.0)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libdl.so.2(GLIBC_2.1)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libm.so.6.1()(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
libpthread.so.0(GLIBC_2.2)(64bit) is needed by
MySQL-server-standard-5.0.22-0.rhel4.ia64
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# rpm -qa | grep glibc
glibc-2.3.4-2.41
glibc-2.3.4-2.41
glibc-common-2.3.4-2.41
[root@localhost ~]#
--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list

Fri Aug 22 00:30:01 2008
Return-path: <gentoo-hardened+bounces-2127-tom=linux-archive.org@lists.gentoo.org>
Envelope-to: tom@linux-archive.org
Delivery-date: Thu, 21 Aug 2008 23:56:34 +0300
Received: from pigeon.gentoo.org ([69.77.167.62] helo=lists.gentoo.org)
by s2.java-tips.org with esmtps (TLSv1:AES256-SHA:256)
(Exim 4.69)
(envelope-from <gentoo-hardened+bounces-2127-tom=linux-archive.org@lists.gentoo.org>)
id 1KWHCs-0000gq-3X
for tom@linux-archive.org; Thu, 21 Aug 2008 23:56:34 +0300
Received: from pigeon.gentoo.org (localhost [127.0.0.1])
by pigeon.gentoo.org (Postfix) with SMTP id 81D75E0338;
Thu, 21 Aug 2008 20:56:25 +0000 (UTC)
X-Original-To: gentoo-hardened@lists.gentoo.org
Delivered-To: gentoo-hardened@lists.gentoo.org
Received: from agave.telenet-ops.be (agave.telenet-ops.be [195.130.137.77])
by pigeon.gentoo.org (Postfix) with ESMTP id 59212E0338
for <gentoo-hardened@lists.gentoo.org>; Thu, 21 Aug 2008 20:56:25 +0000 (UTC)
Received: from localhost (localhost.localdomain [127.0.0.1])
by agave.telenet-ops.be (Postfix) with SMTP id 12F5D67D27
for <gentoo-hardened@lists.gentoo.org>; Thu, 21 Aug 2008 22:56:24 +0200 (CEST)
Received: from [192.168.1.2] (user-85-201-69-178.tvcablenet.be [85.201.69.178])
by agave.telenet-ops.be (Postfix) with ESMTP id EA55967D20
for <gentoo-hardened@lists.gentoo.org>; Thu, 21 Aug 2008 22:56:23 +0200 (CEST)
Message-ID: <48ADD677.5070605@tvcablenet.be>
Date: Thu, 21 Aug 2008 22:56:23 +0200
From: =?ISO-8859-1?Q?François_Valenduc? <francois.valenduc@tvcablenet.be>
User-Agent: Thunderbird 2.0.0.16 (X11/20080806)
Precedence: bulk
List-Post: <mailto:gentoo-hardened@lists.gentoo.org>
List-Help: <mailto:gentoo-hardened+help@lists.gentoo.org>
List-Unsubscribe: <mailto:gentoo-hardened+unsubscribe@lists.gentoo.org>
List-Subscribe: <mailto:gentoo-hardened+subscribe@lists.gentoo.org>
List-Id: Gentoo Linux mail <gentoo-hardened.gentoo.org>
X-BeenThere: gentoo-hardened@lists.gentoo.org
Reply-to: gentoo-hardened@lists.gentoo.org
MIME-Version: 1.0
To: gentoo-hardened@lists.gentoo.org
Subject: [gentoo-hardened] problem installing a cross glibc with SELinux
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable

Hello everybody,
I am trying to install a i686 cross compiler on an x86_64 host. I use
crossdev to install it but when it want to install glibc, it fails with
the following error:

checking for is_selinux_enabled in -lselinux... no
configure: error: SELinux explicitly required, but sufficiently recent
SELinux library not found

Does anybody know how to solve this problem ?
Furthermore, if I ever manage to install it, will it be OK to cross
compile programs for another computer (through distcc) if SELinux is not
installed on this other computer ?

Thanks in advance for your help,
François Valenduc


All times are GMT. The time now is 12:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.