Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   RPM Package Manager (http://www.linux-archive.org/rpm-package-manager/)
-   -   How to 'Require' a version on a certain branch (http://www.linux-archive.org/rpm-package-manager/122055-how-require-version-certain-branch.html)

Julian Cowley 07-09-2008 10:06 PM

How to 'Require' a version on a certain branch
 
Hello,

I have a question about how to get Require to require a package in a
certain branch rather than a specific version.


Can I require that a package start with a certain version, but be any
version within that branch? For instance, I want to require version 1.1
and let 1.1, 1.1.0, 1.1.1 satisfy the requirement (but not 1.2, say).


Is this possible?

I know that you can specify a version number in a Require header using '='
(e.g., "Require: package = 1.1"), but this specifies an *exact* version
number. I also know you can use any version at or after a certain version
using '>=', but that means 1.2 from the previous example also works, and I
don't want that.


_______________________________________________
Rpm-list mailing list
Rpm-list@redhat.com
https://www.redhat.com/mailman/listinfo/rpm-list

Rex Dieter 07-10-2008 01:52 PM

How to 'Require' a version on a certain branch
 
Julian Cowley wrote:

> I have a question about how to get Require to require a package in a
> certain branch rather than a specific version.
>
> Can I require that a package start with a certain version, but be any
> version within that branch? For instance, I want to require version 1.1
> and let 1.1, 1.1.0, 1.1.1 satisfy the requirement (but not 1.2, say).
>
> Is this possible?

Not really (afaik).

One way to do accomplish something cloes to what you're asking... is to make
Package foo include (something like)
Provides: foo11

and for Package bar
Requires: foo11

-- Rex

_______________________________________________
Rpm-list mailing list
Rpm-list@redhat.com
https://www.redhat.com/mailman/listinfo/rpm-list

Julian Cowley 07-11-2008 06:18 PM

How to 'Require' a version on a certain branch
 
On Thu, 10 Jul 2008, Rex Dieter wrote:

Julian Cowley wrote:


I have a question about how to get Require to require a package in a
certain branch rather than a specific version.

Can I require that a package start with a certain version, but be any
version within that branch? For instance, I want to require version 1.1
and let 1.1, 1.1.0, 1.1.1 satisfy the requirement (but not 1.2, say).

Is this possible?


Not really (afaik).


That's what I thought.


One way to do accomplish something cloes to what you're asking... is to make
Package foo include (something like)
Provides: foo11

and for Package bar
Requires: foo11


Well, since I'm building all of the packages in question and not mixing
any RPM archive packages with my own, I suppose I can do this. Thanks for
the idea.


The other way to go is to bite the bullet and make the dependent package
specify the exact version it depends on. More work for the packager (me)
since it requires making a package for each new version of the main
package, but at least it prevents any installer from creating an
inconsistent system.


-=- julian

_______________________________________________
Rpm-list mailing list
Rpm-list@redhat.com
https://www.redhat.com/mailman/listinfo/rpm-list


All times are GMT. The time now is 04:03 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.