Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Red Hat Linux (http://www.linux-archive.org/red-hat-linux/)
-   -   device-mapper-1.02.63-4.el5.x86_64 conflicts with file from package device-mapper-1.02.55-2.el5.i386 (http://www.linux-archive.org/red-hat-linux/589821-device-mapper-1-02-63-4-el5-x86_64-conflicts-file-package-device-mapper-1-02-55-2-el5-i386.html)

unix syzadmin 10-21-2011 03:42 PM

device-mapper-1.02.63-4.el5.x86_64 conflicts with file from package device-mapper-1.02.55-2.el5.i386
 
Could not skip the device-mapper; because lvm2 depended on it.
So had to use "yum -x device-mapper --skip-broken update" to successfully
upgrade remaining packages from the channel and also install the latest
kernel.

# yum -x device-mapper update
.
.
.
lvm2-2.02.84-6.el5.x86_64 from rhel-5.6_x86_64 has depsolving problems
--> Missing Dependency: device-mapper >= 1.02.63-2 is needed by package
lvm2-2.02.84-6.el5.x86_64 (rhel-5.6_x86_64)
Error: Missing Dependency: device-mapper >= 1.02.63-2 is needed by package
lvm2-2.02.84-6.el5.x86_64 (rhel-5.6_x86_64)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.


Thanks,



On Thu, Oct 20, 2011 at 12:14 PM, unix syzadmin <unixsyzadmin@gmail.com>wrote:

> Hi,
>
> I just installed redhat linux 5.6.
> Though our satellite server has the latest kernel version
> (2.6.18-238.19.1.el5) in the 5.6 channel; for some reason an older kernel
> gets installed.
>
> # uname -r
> 2.6.18-238.el5
>
>
> yum -y update in the post install script does not work for some reason.
>
> So I manually run "yum -y update" after the initial setup to install the
> latest kernel version for 5.6 and update all other packages. This is
> throwing an error.
>
>
>
> Transaction Check Error:
> file /usr/include/libdevmapper.h from install of
> device-mapper-1.02.63-4.el5.x86_64 conflicts with file from package
> device-mapper-1.02.55-2.el5.i386
> file /usr/share/man/man8/dmeventd.8.gz from install of
> device-mapper-1.02.63-4.el5.x86_64 conflicts with file from package
> device-mapper-1.02.55-2.el5.i386
> file /usr/share/man/man8/dmsetup.8.gz from install of
> device-mapper-1.02.63-4.el5.x86_64 conflicts with file from package
> device-mapper-1.02.55-2.el5.i386
>
> Error Summary
> -------------
>
> #yum list device-mapper
> Loadedplugins:rhnplugin,security
> InstalledPackages
> device-mapper.i386 1.02.55-2.el5 installed
> device-mapper.x86_64 1.02.55-2.el5 installed
> AvailablePackages
> device-mapper.x86_64 1.02.63-4.el5 rhel-5.6_x86_64
>
> Please suggest or point me in the right direction.
>
--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list

Ivan Pozdeev 10-21-2011 05:16 PM

device-mapper-1.02.63-4.el5.x86_64 conflicts with file from package device-mapper-1.02.55-2.el5.i386
 
Remove device-mapper-1.02.55-2.el5.i386 .

As for the kernel, check "rpm -q kernel" to see if the latest kernel
is in fact installed.
If it is, check/fix /boot/grub/grub.conf to make sure it is the
default one (do not ask how), then reboot (I hope you didn't forget you need to
reboot to change the active kernel?).
If it isn't, install it manually "yum install kernel-2.6.18-238.19.1.el5",
if there's an error message from "grubby",
you'll have to adjust grub.conf before rebooting.

> Hi,

> I just installed redhat linux 5.6.
> Though our satellite server has the latest kernel version
> (2.6.18-238.19.1.el5) in the 5.6 channel; for some reason an older kernel
> gets installed.

> # uname -r
> 2.6.18-238.el5


> yum -y update in the post install script does not work for some reason.

> So I manually run "yum -y update" after the initial setup to install the
> latest kernel version for 5.6 and update all other packages. This is
> throwing an error.



> Transaction Check Error:
> file /usr/include/libdevmapper.h from install of
> device-mapper-1.02.63-4.el5.x86_64 conflicts with file from package
> device-mapper-1.02.55-2.el5.i386
> file /usr/share/man/man8/dmeventd.8.gz from install of
> device-mapper-1.02.63-4.el5.x86_64 conflicts with file from package
> device-mapper-1.02.55-2.el5.i386
> file /usr/share/man/man8/dmsetup.8.gz from install of
> device-mapper-1.02.63-4.el5.x86_64 conflicts with file from package
> device-mapper-1.02.55-2.el5.i386

> Error Summary
> -------------

> #yum list device-mapper
> Loadedplugins:rhnplugin,security
> InstalledPackages
> device-mapper.i386 1.02.55-2.el5 installed
> device-mapper.x86_64 1.02.55-2.el5 installed
> AvailablePackages
> device-mapper.x86_64 1.02.63-4.el5 rhel-5.6_x86_64

> Please suggest or point me in the right direction.

--
Regards,
Ivan mailto:vano@mail.mipt.ru

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list


All times are GMT. The time now is 07:42 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.