FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Red Hat Linux

 
 
LinkBack Thread Tools
 
Old 09-12-2011, 04:27 PM
Matty Sarro
 
Default Explanation of weird yum behavior

Greetings everyone.
We had two systems in our lab where we had multipathd installed. In
order to verify our documentation, I am trying to uninstall the
packages.

When I type:
yum erase multipath-tools device-mapper-multipath device-mapper

Instead of being allowed to uninstall only those packages, I get the following:

*****START SNIP*****
---> Package poppler-utils.x86_64 0:0.5.4-4.4.el5_5.14 set to be erased
---> Package ppp.x86_64 0:2.4.4-2.el5 set to be erased
---> Package pygobject2.x86_64 0:2.12.1-5.el5 set to be erased
---> Package python-dmidecode.x86_64 0:3.10.13-1.el5_5.1 set to be erased
---> Package python-elementtree.x86_64 0:1.2.6-5 set to be erased
---> Package python-iniparse.noarch 0:0.2.3-4.el5 set to be erased
---> Package python-sqlite.x86_64 0:1.1.7-1.2.1 set to be erased
---> Package python-urlgrabber.noarch 0:3.1.0-5.el5 set to be erased
---> Package rhel-instnum.noarch 0:1.0.9-1.el5 set to be erased
---> Package rhn-check.noarch 0:0.4.20-33.el5_5.4 set to be erased
--> Processing Dependency: rhn-check >= 0.0.8 for package: rhnsd
---> Package rhn-setup.noarch 0:0.4.20-33.el5_5.4 set to be erased
---> Package rhnlib.noarch 0:2.5.22-3.el5_5.1 set to be erased
---> Package rhpl.x86_64 0:0.194.1-1 set to be erased
---> Package rpm-python.x86_64 0:4.4.2.3-20.el5_5.1 set to be erased
---> Package setuptool.x86_64 0:1.19.2-1 set to be erased
---> Package sos.noarch 0:1.7-9.49.el5 set to be erased
---> Package sudo.x86_64 0:1.7.2p1-9.el5_5 set to be erased
---> Package ypbind.x86_64 3:1.19-12.el5 set to be erased
--> Processing Dependency: ypbind for package: yp-tools
---> Package yum.noarch 0:3.2.22-26.el5_5.1 set to be erased
--> Processing Dependency: yum >= 3.2.18 for package: yum-security
---> Package yum-metadata-parser.x86_64 0:1.1.2-3.el5 set to be erased
---> Package yum-rhn-plugin.noarch 0:0.5.4-15.el5 set to be erased
---> Package yum-updatesd.noarch 1:0.9-2.el5 set to be erased
--> Running transaction check
---> Package avahi-compat-libdns_sd.i386 0:0.6.16-9.el5_5 set to be erased
---> Package avahi-compat-libdns_sd.x86_64 0:0.6.16-9.el5_5 set to be erased
---> Package ntsysv.x86_64 0:1.3.30.2-2.el5 set to be erased
---> Package pam.i386 0:0.99.6.2-6.el5_5.2 set to be erased
--> Processing Dependency: libpam.so.0 for package: pam_pkcs11
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: pam_pkcs11
--> Processing Dependency: libpam.so.0(LIBPAM_EXTENSION_1.0) for
package: pam_pkcs11
--> Processing Dependency: pam for package: udev
--> Processing Dependency: pam >= 0.77-66.8 for package: vixie-cron
--> Processing Dependency: pam >= 0.66-5 for package: SysVinit
--> Processing Dependency: pam >= 0.66-12 for package: coreutils
---> Package pam.x86_64 0:0.99.6.2-6.el5_5.2 set to be erased
--> Processing Dependency: libpam.so.0()(64bit) for package: pam_pkcs11
--> Processing Dependency: libpam.so.0()(64bit) for package: at
--> Processing Dependency: libpam.so.0(LIBPAM_1.0)(64bit) for package:
pam_pkcs11
--> Processing Dependency: libpam.so.0(LIBPAM_1.0)(64bit) for package: at
--> Processing Dependency: libpam.so.0(LIBPAM_EXTENSION_1.0)(64bit)
for package: pam_pkcs11
--> Processing Dependency: libpam_misc.so.0()(64bit) for package: at
---> Package passwd.x86_64 0:0.73-1 set to be erased
---> Package rhnsd.x86_64 0:4.7.0-5.el5 set to be erased
---> Package selinux-policy.noarch 0:2.4.6-279.el5_5.2 set to be erased
---> Package selinux-policy-targeted.noarch 0:2.4.6-279.el5_5.2 set to be erased
---> Package setools.x86_64 0:3.0-3.el5 set to be erased
---> Package system-config-securitylevel-tui.x86_64 0:1.6.29.1-5.el5
set to be erased
---> Package yp-tools.x86_64 0:2.9-1.el5 set to be erased
---> Package yum-security.noarch 0:1.1.16-13.el5_4.1 set to be erased
--> Running transaction check
---> Package SysVinit.x86_64 0:2.86-15.el5 set to be erased
---> Package at.x86_64 0:3.1.8-84.el5 set to be erased
---> Package coreutils.x86_64 0:5.97-23.el5_4.2 set to be erased
--> Processing Dependency: fileutils for package: sysklogd
--> Processing Dependency: fileutils for package: sysstat
--> Processing Dependency: fileutils for package: tcsh
--> Processing Dependency: fileutils for package: smartmontools
--> Processing Dependency: sh-utils for package: sysstat
--> Processing Dependency: sh-utils for package: module-init-tools
--> Processing Dependency: sh-utils for package: logwatch
--> Processing Dependency: sh-utils for package: nscd
--> Processing Dependency: textutils for package: sysstat
--> Processing Dependency: textutils for package: logwatch
--> Processing Dependency: textutils for package: autoconf
--> Processing Dependency: coreutils for package: ksh
--> Processing Dependency: coreutils for package: hicolor-icon-theme
--> Processing Dependency: coreutils for package: hicolor-icon-theme
--> Processing Dependency: coreutils for package: man
--> Processing Dependency: coreutils for package: microcode_ctl
--> Processing Dependency: coreutils for package: fontconfig
--> Processing Dependency: coreutils for package: fontconfig
---> Package pam_pkcs11.i386 0:0.5.3-23 set to be erased
---> Package pam_pkcs11.x86_64 0:0.5.3-23 set to be erased
---> Package udev.x86_64 0:095-14.21.el5_5.1 set to be erased
--> Processing Dependency: dev for package: which
---> Package vixie-cron.x86_64 4:4.1-77.el5_4.1 set to be erased
--> Running transaction check
---> Package autoconf.noarch 0:2.59-12 set to be erased
--> Processing Dependency: autoconf >= 2.54 for package: automake17
---> Package fontconfig.i386 0:2.4.1-7.el5 set to be erased
--> Processing Dependency: libfontconfig.so.1 for package: libXft
--> Processing Dependency: libfontconfig.so.1 for package: pango
--> Processing Dependency: libfontconfig.so.1 for package: cairo
--> Processing Dependency: fontconfig >= 2.2-1 for package: libXft
--> Processing Dependency: fontconfig >= 2.2-1 for package: libXft
---> Package fontconfig.x86_64 0:2.4.1-7.el5 set to be erased
--> Processing Dependency: libfontconfig.so.1()(64bit) for package: cairo
--> Processing Dependency: libfontconfig.so.1()(64bit) for package: pango
---> Package hicolor-icon-theme.noarch 0:0.9-2.1 set to be erased
---> Package ksh.x86_64 0:20100202-1.el5_5.1 set to be erased
---> Package logwatch.noarch 0:7.3-8.el5 set to be erased
---> Package man.x86_64 0:1.6d-1.1 set to be erased
---> Package microcode_ctl.x86_64 1:1.17-1.50.el5 set to be erased
---> Package module-init-tools.x86_64 0:3.3-0.pre3.1.60.el5_5.1 set to be erased
--> Processing Dependency: modutils >= 2.3.21-4 for package: irda-utils
--> Processing Dependency: module-init-tools >= 3.2 for package: hwdata
---> Package nscd.x86_64 0:2.5-49.el5_5.7 set to be erased
---> Package smartmontools.x86_64 1:5.38-2.el5 set to be erased
---> Package sysklogd.x86_64 0:1.4.1-46.el5 set to be erased
---> Package sysstat.x86_64 0:7.0.2-3.el5_5.1 set to be erased
---> Package tcsh.x86_64 0:6.14-17.el5_5.2 set to be erased
---> Package which.x86_64 0:2.16-7 set to be erased
--> Processing Dependency: which for package: htmlview
--> Running transaction check
---> Package automake17.noarch 0:1.7.9-7.el5.2 set to be erased
---> Package cairo.i386 0:1.2.4-5.el5 set to be erased
---> Package cairo.x86_64 0:1.2.4-5.el5 set to be erased
---> Package htmlview.noarch 0:4.0.0-2.el5 set to be erased
--> Processing Dependency: htmlview for package: Deployment_Guide-en-US
--> Processing Dependency: htmlview for package: pinfo
---> Package hwdata.noarch 0:0.213.18-1.el5.1 set to be erased
--> Processing Dependency: hwdata for package: usbutils
--> Processing Dependency: hwdata for package: pciutils
---> Package irda-utils.x86_64 0:0.9.17-2.fc6 set to be erased
---> Package libXft.i386 0:2.1.10-1.1 set to be erased
---> Package libXft.x86_64 0:2.1.10-1.1 set to be erased
---> Package pango.i386 0:1.14.9-8.el5 set to be erased
---> Package pango.x86_64 0:1.14.9-8.el5 set to be erased
--> Running transaction check
---> Package Deployment_Guide-en-US.noarch 0:5.2-11 set to be erased
---> Package pciutils.x86_64 0:2.2.3-8.el5 set to be erased
--> Processing Dependency: pciutils for package: hp-health
---> Package pinfo.x86_64 0:0.6.9-1.fc6 set to be erased
---> Package usbutils.x86_64 0:0.71-2.1 set to be erased
--> Running transaction check
---> Package hp-health.x86_64 0:8.5.0.23-23 set to be erased
--> Processing Dependency: /usr/bin/env for package: conman
--> Processing Dependency: /usr/bin/python for package: libhugetlbfs
--> Processing Dependency: /usr/bin/python for package: gettext
--> Processing Dependency: /usr/bin/python for package: libhugetlbfs
--> Processing Dependency: /usr/bin/fipscheck for package: fipscheck-lib
--> Processing Dependency: /sbin/service for package: dnsmasq
--> Processing Dependency: /sbin/service for package: dnsmasq
--> Processing Dependency: /sbin/service for package: rng-utils
--> Processing Dependency: /sbin/service for package: cpuspeed
--> Processing Dependency: /sbin/service for package: irqbalance
--> Processing Dependency: /sbin/service for package: mcstrans
--> Processing Dependency: /sbin/service for package: mcstrans
--> Processing Dependency: /sbin/service for package: conman
--> Processing Dependency: /sbin/service for package: conman
--> Processing Dependency: /sbin/service for package: acpid
--> Processing Dependency: /bin/touch for package: psacct
--> Processing Dependency: /bin/csh for package: mtools
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package acpid.x86_64 0:1.0.4-9.el5_4.2 set to be erased
---> Package conman.x86_64 0:0.1.9.2-8.el5 set to be erased
---> Package cpuspeed.x86_64 1:1.2.1-9.el5 set to be erased
---> Package dnsmasq.x86_64 0:2.45-1.1.el5_3 set to be erased
---> Package fipscheck-lib.x86_64 0:1.2.0-1.el5 set to be erased
---> Package gettext.x86_64 0:0.14.6-4.el5 set to be erased
---> Package irqbalance.x86_64 2:0.55-15.el5 set to be erased
---> Package libhugetlbfs.i386 0:1.3-7.el5 set to be erased
---> Package libhugetlbfs.x86_64 0:1.3-7.el5 set to be erased
---> Package mcstrans.x86_64 0:0.2.11-3.el5 set to be erased
--> Processing Dependency: setransd for package: libselinux
--> Processing Dependency: setransd for package: libselinux
---> Package mtools.x86_64 0:3.9.10-2.fc6 set to be erased
--> Processing Dependency: mtools for package: syslinux
---> Package psacct.x86_64 0:6.3.2-44.el5 set to be erased
---> Package rng-utils.x86_64 1:2.0-1.14.1.fc6 set to be erased
--> Running transaction check
---> Package libselinux.i386 0:1.33.4-5.7.el5 set to be erased
--> Processing Dependency: libselinux.so.1 for package: nss_db
--> Processing Dependency: libselinux.so.1 for package: dbus
--> Processing Dependency: libselinux.so.1 for package: rpm-devel
--> Processing Dependency: libselinux.so.1 for package: rpm-libs
--> Processing Dependency: libselinux.so.1 for package: mesa-libGL
--> Processing Dependency: libselinux = 1.33.4-5.7.el5 for package:
libselinux-utils
--> Processing Dependency: libselinux = 1.33.4-5.7.el5 for package:
libselinux-devel
--> Processing Dependency: libselinux >= 1.15.2 for package: dbus
--> Processing Dependency: libselinux >= 1.15.2 for package: dbus
--> Processing Dependency: libselinux >= 1.25.2-1 for package: shadow-utils
---> Package libselinux.x86_64 0:1.33.4-5.7.el5 set to be erased
--> Processing Dependency: libselinux.so.1()(64bit) for package: MAKEDEV
--> Processing Dependency: libselinux.so.1()(64bit) for package: rpm-libs
--> Processing Dependency: libselinux.so.1()(64bit) for package: net-tools
--> Processing Dependency: libselinux.so.1()(64bit) for package: findutils
--> Processing Dependency: libselinux.so.1()(64bit) for package: mesa-libGL
--> Processing Dependency: libselinux.so.1()(64bit) for package: psmisc
--> Processing Dependency: libselinux.so.1()(64bit) for package: vim-minimal
--> Processing Dependency: libselinux.so.1()(64bit) for package: logrotate
--> Processing Dependency: libselinux.so.1()(64bit) for package: tar
--> Processing Dependency: libselinux.so.1()(64bit) for package: nss_db
--> Processing Dependency: libselinux.so.1()(64bit) for package: rpm
--> Processing Dependency: libselinux.so.1()(64bit) for package: lsof
--> Processing Dependency: libselinux.so.1()(64bit) for package: rpm-devel
---> Package syslinux.x86_64 0:3.11-4 set to be erased
--> Running transaction check
---> Package MAKEDEV.x86_64 0:3.23-1.2 set to be erased
---> Package dbus.i386 0:1.1.2-14.el5 set to be erased
--> Processing Dependency: dbus = 1.1.2-14.el5 for package: dbus-libs
--> Processing Dependency: dbus = 1.1.2-14.el5 for package: dbus-libs
---> Package dbus.x86_64 0:1.1.2-14.el5 set to be erased
---> Package findutils.x86_64 1:4.2.27-6.el5 set to be erased
---> Package libselinux-devel.x86_64 0:1.33.4-5.7.el5 set to be erased
---> Package libselinux-utils.x86_64 0:1.33.4-5.7.el5 set to be erased
---> Package logrotate.x86_64 0:3.7.4-9.el5_5.2 set to be erased
---> Package lsof.x86_64 0:4.78-3 set to be erased
---> Package mesa-libGL.i386 0:6.5.1-7.8.el5 set to be erased
---> Package mesa-libGL.x86_64 0:6.5.1-7.8.el5 set to be erased
---> Package net-tools.x86_64 0:1.60-81.el5 set to be erased
---> Package nss_db.i386 0:2.2-35.4.el5_5 set to be erased
---> Package nss_db.x86_64 0:2.2-35.4.el5_5 set to be erased
---> Package psmisc.x86_64 0:22.2-7 set to be erased
--> Processing Dependency: psmisc for package: tmpwatch
---> Package rpm.x86_64 0:4.4.2.3-20.el5_5.1 set to be erased
---> Package rpm-devel.i386 0:4.4.2.3-20.el5_5.1 set to be erased
---> Package rpm-devel.x86_64 0:4.4.2.3-20.el5_5.1 set to be erased
---> Package rpm-libs.i386 0:4.4.2.3-20.el5_5.1 set to be erased
---> Package rpm-libs.x86_64 0:4.4.2.3-20.el5_5.1 set to be erased
---> Package shadow-utils.x86_64 2:4.0.17-15.el5 set to be erased
---> Package tar.x86_64 2:1.15.1-30.el5 set to be erased
---> Package vim-minimal.x86_64 2:7.0.109-6.el5 set to be erased
--> Running transaction check
---> Package dbus-libs.i386 0:1.1.2-14.el5 set to be erased
--> Processing Dependency: libdbus-1.so.3 for package: dbus-glib
---> Package dbus-libs.x86_64 0:1.1.2-14.el5 set to be erased
--> Processing Dependency: libdbus-1.so.3()(64bit) for package: dbus-glib
---> Package tmpwatch.x86_64 0:2.9.7-1.1.el5.2 set to be erased
--> Running transaction check
---> Package dbus-glib.i386 0:0.73-10.el5_5 set to be erased
---> Package dbus-glib.x86_64 0:0.73-10.el5_5 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Removing:
device-mapper i386 1.02.55-2.el5 installed 1.7 M
device-mapper x86_64 1.02.55-2.el5 installed 2.0 M
device-mapper-multipath x86_64 0.4.7-42.el5_6.2 installed 7.0 M
Removing for dependencies:
Deployment_Guide-en-US noarch 5.2-11 installed 6.8 M
GConf2 x86_64 2.14.0-9.el5 installed 4.7 M
MAKEDEV x86_64 3.23-1.2 installed 645 k
NetworkManager i386 1:0.7.0-10.el5_5.2 installed 3.3 M
NetworkManager x86_64 1:0.7.0-10.el5_5.2 installed 3.4 M
NetworkManager-glib i386 1:0.7.0-10.el5_5.2 installed 154 k
NetworkManager-glib x86_64 1:0.7.0-10.el5_5.2 installed 161 k
OpenIPMI x86_64 2.0.16-7.el5 installed 307 k
OpenIPMI-libs i386 2.0.16-7.el5 installed 1.4 M
OpenIPMI-libs x86_64 2.0.16-7.el5 installed 1.6 M
SysVinit x86_64 2.86-15.el5 installed 220 k
acpid x86_64 1.0.4-9.el5_4.2 installed 38 k
at x86_64 3.1.8-84.el5 installed 86 k
audit-libs-python x86_64 1.7.17-3.el5 installed 266 k
authconfig x86_64 5.3.21-6.el5 installed 1.7 M
autoconf noarch 2.59-12 installed 1.7 M
autofs x86_64 1:5.0.1-0.rc2.143.el5_5.6 installed 2.0 M
automake17 noarch 1.7.9-7.el5.2 installed 922 k
avahi i386 0.6.16-9.el5_5 installed 706 k
avahi x86_64 0.6.16-9.el5_5 installed 717 k
avahi-compat-libdns_sd i386 0.6.16-9.el5_5 installed 31 k
avahi-compat-libdns_sd x86_64 0.6.16-9.el5_5 installed 32 k
bind-libs i386 30:9.3.6-4.P1.el5_5.3 installed 2.0 M
bind-libs x86_64 30:9.3.6-4.P1.el5_5.3 installed 1.9 M
bind-utils x86_64 30:9.3.6-4.P1.el5_5.3 installed 294 k
bluez-gnome x86_64 0.5-5.fc6 installed 47 k
bluez-utils x86_64 3.7-2.2 installed 848 k
cairo i386 1.2.4-5.el5 installed 1.1 M
cairo x86_64 1.2.4-5.el5 installed 1.1 M
ccid x86_64 1.3.8-1.el5 installed 375 k
conman x86_64 0.1.9.2-8.el5 installed 294 k
coolkey i386 1.1.0-14.el5 installed 203 k
coolkey x86_64 1.1.0-14.el5 installed 211 k
coreutils x86_64 5.97-23.el5_4.2 installed 8.6 M
cpuspeed x86_64 1:1.2.1-9.el5 installed 56 k
cracklib i386 2.8.9-3.3 installed 140 k
cracklib x86_64 2.8.9-3.3 installed 172 k
cryptsetup-luks i386 1.0.3-5.el5 installed 1.3 M
cryptsetup-luks x86_64 1.0.3-5.el5 installed 1.3 M
cups x86_64 1:1.3.7-18.el5_5.8 installed 9.1 M
cups-libs i386 1:1.3.7-18.el5_5.8 installed 317 k
cups-libs x86_64 1:1.3.7-18.el5_5.8 installed 315 k
curl i386 7.15.5-9.el5 installed 463 k
curl x86_64 7.15.5-9.el5 installed 471 k
cyrus-sasl i386 2.1.22-5.el5_4.3 installed 2.6 M
cyrus-sasl x86_64 2.1.22-5.el5_4.3 installed 2.5 M
dbus i386 1.1.2-14.el5 installed 495 k
dbus x86_64 1.1.2-14.el5 installed 486 k
dbus-glib i386 0.73-10.el5_5 installed 467 k
dbus-glib x86_64 0.73-10.el5_5 installed 475 k
dbus-libs i386 1.1.2-14.el5 installed 246 k
dbus-libs x86_64 1.1.2-14.el5 installed 235 k
dbus-python x86_64 0.70-9.el5_4 installed 628 k
device-mapper-event x86_64 1.02.55-2.el5 installed 28 k
dhclient x86_64 12:3.0.5-23.el5_5.2 installed 561 k
dhcpv6-client x86_64 1.0.10-18.el5 installed 259 k
dmraid x86_64 1.0.0.rc13-63.el5 installed 1.6 M
dmraid-events x86_64 1.0.0.rc13-63.el5 installed 8.6 k
dnsmasq x86_64 2.45-1.1.el5_3 installed 350 k
e2fsprogs x86_64 1.39-23.el5_5.1 installed 2.2 M
e2fsprogs-libs i386 1.39-23.el5_5.1 installed 206 k
e2fsprogs-libs x86_64 1.39-23.el5_5.1 installed 228 k
findutils x86_64 1:4.2.27-6.el5 installed 671 k
fipscheck x86_64 1.2.0-1.el5 installed 26 k
fipscheck-lib x86_64 1.2.0-1.el5 installed 6.6 k
firstboot-tui x86_64 1.4.27.8-1.el5 installed 665 k
fontconfig i386 2.4.1-7.el5 installed 361 k
fontconfig x86_64 2.4.1-7.el5 installed 387 k
gamin-python x86_64 0.1.7-8.el5 installed 194 k
gettext x86_64 0.14.6-4.el5 installed 3.9 M
gnupg x86_64 1.4.5-14.el5_5.1 installed 4.4 M
gtk2 i386 2.10.4-21.el5_5.6 installed 19 M
gtk2 x86_64 2.10.4-21.el5_5.6 installed 19 M
hal i386 0.5.8.1-59.el5 installed 1.1 M
hal x86_64 0.5.8.1-59.el5 installed 1.1 M
hicolor-icon-theme noarch 0.9-2.1 installed 17 k
hp-health x86_64 8.5.0.23-23 installed 1.6 M
hp-snmp-agents x86_64 8.5.0.17-19 installed 5.6 M
htmlview noarch 4.0.0-2.el5 installed 5.4 k
hwdata noarch 0.213.18-1.el5.1 installed 1.3 M
ifd-egate x86_64 0.05-15 installed 44 k
initscripts x86_64 8.45.30-3.el5_5.1 installed 5.2 M
ipsec-tools x86_64 0.6.5-14.el5_5.5 installed 854 k
irda-utils x86_64 0.9.17-2.fc6 installed 136 k
irqbalance x86_64 2:0.55-15.el5 installed 31 k
kbd x86_64 1.12-21.el5 installed 2.7 M
kernel x86_64 2.6.18-164.el5 installed 87 M
kernel x86_64 2.6.18-194.26.1.el5 installed 92 M
kpartx x86_64 0.4.7-42.el5_6.2 installed 960 k
krb5-libs i386 1.6.1-36.el5_5.6 installed 1.4 M
krb5-libs x86_64 1.6.1-36.el5_5.6 installed 1.4 M
krb5-workstation x86_64 1.6.1-36.el5_5.6 installed 1.7 M
ksh x86_64 20100202-1.el5_5.1 installed 3.1 M
kudzu x86_64 1.2.57.1.24-1 installed 417 k
libXft i386 2.1.10-1.1 installed 78 k
libXft x86_64 2.1.10-1.1 installed 81 k
libgssapi x86_64 0.10-2 installed 40 k
libhugetlbfs i386 1.3-7.el5 installed 105 k
libhugetlbfs x86_64 1.3-7.el5 installed 108 k
libnotify x86_64 0.4.2-6.el5 installed 95 k
libpcap i386 14:0.9.4-15.el5 installed 192 k
libpcap x86_64 14:0.9.4-15.el5 installed 195 k
libselinux i386 1.33.4-5.7.el5 installed 90 k
libselinux x86_64 1.33.4-5.7.el5 installed 91 k
libselinux-devel x86_64 1.33.4-5.7.el5 installed 345 k
libselinux-python x86_64 1.33.4-5.7.el5 installed 146 k
libselinux-utils x86_64 1.33.4-5.7.el5 installed 51 k
libsemanage x86_64 1.9.1-4.4.el5 installed 411 k
libuser i386 0.54.7-2.1.el5_4.1 installed 1.5 M
libuser x86_64 0.54.7-2.1.el5_4.1 installed 1.6 M
libwnck x86_64 2.16.0-4.fc6 installed 523 k
libxml2-python x86_64 2.6.26-2.1.2.8.el5_5.1 installed 2.5 M
logrotate x86_64 3.7.4-9.el5_5.2 installed 58 k
logwatch noarch 7.3-8.el5 installed 0.0
lsof x86_64 4.78-3 installed 829 k
lvm2 x86_64 2.02.56-8.el5_5.6 installed 7.4 M
m2crypto x86_64 0.16-6.1.el5_5.1 installed 1.7 M
man x86_64 1.6d-1.1 installed 354 k
mcstrans x86_64 0.2.11-3.el5 installed 23 k
mdadm x86_64 2.6.9-3.el5 installed 1.9 M
mesa-libGL i386 6.5.1-7.8.el5 installed 26 M
mesa-libGL x86_64 6.5.1-7.8.el5 installed 23 M
microcode_ctl x86_64 1:1.17-1.50.el5 installed 1.4 M
mkbootdisk x86_64 1.5.3-2.1 installed 7.2 k
mkinitrd i386 5.1.19.6-61.el5_5.2 installed 946 k
mkinitrd x86_64 5.1.19.6-61.el5_5.2 installed 904 k
module-init-tools x86_64 3.3-0.pre3.1.60.el5_5.1 installed 881 k
mtools x86_64 3.9.10-2.fc6 installed 321 k
net-snmp x86_64 1:5.3.2.2-9.el5_5.1 installed 2.8 M
net-snmp-devel i386 1:5.3.2.2-9.el5_5.1 installed 5.8 M
net-snmp-devel x86_64 1:5.3.2.2-9.el5_5.1 installed 7.9 M
net-snmp-libs i386 1:5.3.2.2-9.el5_5.1 installed 3.2 M
net-snmp-libs x86_64 1:5.3.2.2-9.el5_5.1 installed 3.0 M
net-snmp-perl x86_64 1:5.3.2.2-9.el5_5.1 installed 430 k
net-snmp-utils x86_64 1:5.3.2.2-9.el5_5.1 installed 381 k
net-tools x86_64 1.60-81.el5 installed 780 k
newt i386 0.52.2-15.el5 installed 240 k
newt x86_64 0.52.2-15.el5 installed 253 k
nfs-utils x86_64 1:1.0.9-42.el5 installed 793 k
nfs-utils x86_64 1:1.0.9-47.el5_5 installed 793 k
nfs-utils-lib x86_64 1.0.8-7.6.el5 installed 112 k
notification-daemon x86_64 0.3.5-9.el5 installed 111 k
nscd x86_64 2.5-49.el5_5.7 installed 120 k
nss_db i386 2.2-35.4.el5_5 installed 1.6 M
nss_db x86_64 2.2-35.4.el5_5 installed 1.6 M
nss_ldap i386 253-25.el5_5.3 installed 3.3 M
nss_ldap x86_64 253-25.el5_5.3 installed 3.3 M
ntsysv x86_64 1.3.30.2-2.el5 installed 24 k
openldap i386 2.3.43-12.el5_5.3 installed 592 k
openldap x86_64 2.3.43-12.el5_5.3 installed 598 k
openssh x86_64 4.3p2-41.el5_5.1 installed 728 k
openssh-clients x86_64 4.3p2-41.el5_5.1 installed 840 k
openssh-server x86_64 4.3p2-41.el5_5.1 installed 475 k
openssl i686 0.9.8e-12.el5_5.7 installed 3.3 M
openssl x86_64 0.9.8e-12.el5_5.7 installed 3.4 M
pam i386 0.99.6.2-6.el5_5.2 installed 2.4 M
pam x86_64 0.99.6.2-6.el5_5.2 installed 2.5 M
pam_ccreds i386 3-5 installed 32 k
pam_ccreds x86_64 3-5 installed 39 k
pam_krb5 i386 2.2.14-15 installed 266 k
pam_krb5 x86_64 2.2.14-15 installed 266 k
pam_pkcs11 i386 0.5.3-23 installed 758 k
pam_pkcs11 x86_64 0.5.3-23 installed 824 k
pango i386 1.14.9-8.el5 installed 783 k
pango x86_64 1.14.9-8.el5 installed 845 k
paps x86_64 0.6.6-19.el5 installed 62 k
parted i386 1.8.1-27.el5 installed 1.3 M
parted x86_64 1.8.1-27.el5 installed 1.3 M
passwd x86_64 0.73-1 installed 27 k
pciutils x86_64 2.2.3-8.el5 installed 159 k
pcmciautils x86_64 014-5 installed 67 k
pcsc-lite x86_64 1.4.4-4.el5_5 installed 341 k
pinfo x86_64 0.6.9-1.fc6 installed 290 k
pkinit-nss x86_64 0.7.6-1.el5 installed 604 k
pm-utils x86_64 0.99.3-10.el5 installed 278 k
policycoreutils x86_64 1.33.12-14.8.el5 installed 2.1 M
poppler i386 0.5.4-4.4.el5_5.14 installed 8.4 M
poppler x86_64 0.5.4-4.4.el5_5.14 installed 8.6 M
poppler-utils x86_64 0.5.4-4.4.el5_5.14 installed 163 k
portmap x86_64 4.0-65.2.2.1 installed 63 k
ppp x86_64 2.4.4-2.el5 installed 857 k
prelink x86_64 0.4.0-2.el5 installed 1.6 M
psacct x86_64 6.3.2-44.el5 installed 107 k
psmisc x86_64 22.2-7 installed 159 k
pyOpenSSL x86_64 0.6-1.p24.7.2.2 installed 498 k
pygobject2 x86_64 2.12.1-5.el5 installed 292 k
python x86_64 2.4.3-27.el5_5.3 installed 21 M
python-dmidecode x86_64 3.10.13-1.el5_5.1 installed 256 k
python-elementtree x86_64 1.2.6-5 installed 308 k
python-iniparse noarch 0.2.3-4.el5 installed 131 k
python-sqlite x86_64 1.1.7-1.2.1 installed 118 k
python-urlgrabber noarch 3.1.0-5.el5 installed 467 k
quota x86_64 1:3.13-1.2.5.el5 installed 753 k
readahead x86_64 1:1.3-8.el5 installed 260 k
redhat-lsb i386 3.1-12.3.EL installed 22 k
redhat-lsb x86_64 3.1-12.3.EL installed 22 k
rhel-instnum noarch 1.0.9-1.el5 installed 101 k
rhn-check noarch 0.4.20-33.el5_5.4 installed 0.0
rhn-client-tools noarch 0.4.20-33.el5_5.4 installed 0.0
rhn-setup noarch 0.4.20-33.el5_5.4 installed 0.0
rhnlib noarch 2.5.22-3.el5_5.1 installed 0.0
rhnsd x86_64 4.7.0-5.el5 installed 69 k
rhpl x86_64 0.194.1-1 installed 922 k
rng-utils x86_64 1:2.0-1.14.1.fc6 installed 26 k
rp-pppoe x86_64 3.5-32.1 installed 249 k
rpm x86_64 4.4.2.3-20.el5_5.1 installed 3.6 M
rpm-devel i386 4.4.2.3-20.el5_5.1 installed 3.5 M
rpm-devel x86_64 4.4.2.3-20.el5_5.1 installed 4.1 M
rpm-libs i386 4.4.2.3-20.el5_5.1 installed 2.0 M
rpm-libs x86_64 4.4.2.3-20.el5_5.1 installed 2.0 M
rpm-python x86_64 4.4.2.3-20.el5_5.1 installed 131 k
selinux-policy noarch 2.4.6-279.el5_5.2 installed 0.0
selinux-policy-targeted noarch 2.4.6-279.el5_5.2 installed 0.0
sendmail x86_64 8.13.8-8.el5 installed 1.3 M
setools x86_64 3.0-3.el5 installed 3.3 M
setuptool x86_64 1.19.2-1 installed 125 k
shadow-utils x86_64 2:4.0.17-15.el5 installed 2.6 M
smartmontools x86_64 1:5.38-2.el5 installed 2.8 M
sos noarch 1.7-9.49.el5 installed 0.0
stunnel x86_64 4.15-2.el5.1 installed 223 k
sudo x86_64 1.7.2p1-9.el5_5 installed 487 k
sysklogd x86_64 1.4.1-46.el5 installed 125 k
syslinux x86_64 3.11-4 installed 1.3 M
sysstat x86_64 7.0.2-3.el5_5.1 installed 393 k
system-config-network-tui noarch 1.3.99.18-1.el5 installed 4.7 M
system-config-securitylevel-tui
x86_64 1.6.29.1-5.el5 installed 1.0 M
tar x86_64 2:1.15.1-30.el5 installed 1.6 M
tcpdump x86_64 14:3.9.4-15.el5 installed 978 k
tcsh x86_64 6.14-17.el5_5.2 installed 1.1 M
tmpwatch x86_64 2.9.7-1.1.el5.2 installed 18 k
udev x86_64 095-14.21.el5_5.1 installed 5.3 M
usbutils x86_64 0.71-2.1 installed 90 k
usermode x86_64 1.88-3.el5.2 installed 539 k
util-linux x86_64 2.13-0.52.el5_4.1 installed 4.6 M
vim-minimal x86_64 2:7.0.109-6.el5 installed 616 k
vixie-cron x86_64 4:4.1-77.el5_4.1 installed 624 k
wget x86_64 1.11.4-2.el5_4.1 installed 1.4 M
which x86_64 2.16-7 installed 34 k
wpa_supplicant x86_64 1:0.5.10-9.el5 installed 601 k
xinetd x86_64 2:2.3.14-10.el5 installed 255 k
yp-tools x86_64 2.9-1.el5 installed 167 k
ypbind x86_64 3:1.19-12.el5 installed 55 k
yum noarch 3.2.22-26.el5_5.1 installed 0.0
yum-metadata-parser x86_64 1.1.2-3.el5 installed 55 k
yum-rhn-plugin noarch 0.5.4-15.el5 installed 173 k
yum-security noarch 1.1.16-13.el5_4.1 installed 60 k
yum-updatesd noarch 1:0.9-2.el5 installed 55 k

Transaction Summary
================================================== ==============================
Remove 250 Package(s)
Reinstall 0 Package(s)
Downgrade 0 Package(s)

Is this ok [y/N]:

*****END SNIP*****




Ok, this doesn't make sense. It seems like it wants to remove pretty
much every package in the system. Can anyone shed any light on why its
doing this?
When i try to run it using rpm -e it says that the packages are
required by mkinitrd?
-Matt

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list
 
Old 09-12-2011, 04:50 PM
Jonathan S Billings
 
Default Explanation of weird yum behavior

On 09/12/2011 12:27 PM, Matty Sarro wrote:

yum erase multipath-tools device-mapper-multipath device-mapper

Instead of being allowed to uninstall only those packages, I get the following:


It's probably device-mapper's fault. device-mapper is required by a
variety of packages (notably e2fsprogs-libs) which then brings in a huge
number of dependencies because e2fsprogs-libs provides libcom_err.so and
a lot of things link against that library or other libraries that use it.


Removing device-mapper-multipath will get rid of mkinitrd, something you
probably want to avoid as well.


--
Jonathan Billings <jsbillin@umich.edu>
College of Engineering - CAEN - Unix and Linux Support

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list
 
Old 09-12-2011, 04:55 PM
Matty Sarro
 
Default Explanation of weird yum behavior

I suppose what doesn't make sense to me - these aren't packages that
are installed by default (running RHEL 5.5). I had to manually install
them on this build - I only have core packages installed. So why can I
add them with no fuss, but not remove them without everything being
impacted? The system ran perfectly happy without them, so why are they
suddenly dependencies for everything after they're installed?

On Mon, Sep 12, 2011 at 12:50 PM, Jonathan S Billings
<jsbillin@umich.edu> wrote:
> On 09/12/2011 12:27 PM, Matty Sarro wrote:
>>
>> yum erase multipath-tools device-mapper-multipath device-mapper
>>
>> Instead of being allowed to uninstall only those packages, I get the
>> following:
>
> It's probably device-mapper's fault. *device-mapper is required by a variety
> of packages (notably e2fsprogs-libs) which then brings in a huge number of
> dependencies because e2fsprogs-libs provides libcom_err.so and a lot of
> things link against that library or other libraries that use it.
>
> Removing device-mapper-multipath will get rid of mkinitrd, something you
> probably want to avoid as well.
>
> --
> Jonathan Billings <jsbillin@umich.edu>
> College of Engineering - CAEN - Unix and Linux Support
>
> --
> redhat-list mailing list
> unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
> https://www.redhat.com/mailman/listinfo/redhat-list
>

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list
 
Old 09-12-2011, 05:31 PM
Jonathan S Billings
 
Default Explanation of weird yum behavior

On 09/12/2011 12:55 PM, Matty Sarro wrote:

I suppose what doesn't make sense to me - these aren't packages that
are installed by default (running RHEL 5.5). I had to manually install
them on this build - I only have core packages installed. So why can I
add them with no fuss, but not remove them without everything being
impacted? The system ran perfectly happy without them, so why are they
suddenly dependencies for everything after they're installed?


I believe device-mapper and device-mapper-multipath are part of the base
install.


--
Jonathan Billings <jsbillin@umich.edu>
College of Engineering - CAEN - Unix and Linux Support

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list
 
Old 09-13-2011, 02:25 AM
Ricardo David Carrillo Sanchez
 
Default Explanation of weird yum behavior

Greetings to all,


In my organization required to implement a solution for file sharing,
they would
be discharged by different servers automatically and in turn can be
administered through different accounts assigned, I researched that there
are different applications with different methods to perform some of these
tasks:


Using different technology to download / distrubution of files:

- Emule (decentralized, some customers: mldonkey)
- Bittorrent (decentralized, some customers: TorrentFlux, Vuze, uTorrent,
etc.)
- FTP virtual users (centralized, some customers: filezilla)
- Samba / ldap (centralized Some clients: windows - Windows Explorer)



As technology is based on the operational needs of the organization, but seek
to find a balance between efficiency / robustness / support / functionality,
(hehe, it seems difficult not?).


Based on the above and based on his experience, my questions are:

- What other known technologies that could carry out any of the tasks
described in the first paragraph?
- Have implemented any service where an aim of distributing files to
different computers within a network?


Already, thanks in advance for your guidance

regards
-

Ricardo David Carrillo Sanchez
Systems Administrator
Information Security Analyst
PGP / GPG key fingerprint: 4EDE BEF9 2FAE C88B AC73 52CB 0655 B749 8D5A F2A0
PGP / GPG public key: http://openinsecureit.mx/keys/dominus.ceo.asc
--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list
 

Thread Tools




All times are GMT. The time now is 12:11 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org