FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Red Hat Install

 
 
LinkBack Thread Tools
 
Old 05-13-2010, 09:21 AM
Zha Hou Dun
 
Default How to configure PXE for Red Hat Enterprise Virtualization Hypervisor install

Hi All,

*** I have setup an PXE environment for network installation of* RHEV. My pxe server is Red Hat Enterprise Linux Server release 5. I encountered some problems that needs your help, thanks in advance!
1. Currently I can install RHEV from the pxe server,* but after the installation, it can not be accessed because I don't know the password for root, during the installation process, I have no chance to set the password, after I select PXE boot from BIOS, the installation start automatically. How can I set password for automatically install? I know that Kickstart config file can be this for* Red Hat Linux,* is there way for Red Hat Enterprise Virtualization Hypervisor?

2. Before installed the Client, I changed the boot order of the Client to PXE -> Hard Disk in the BIOS, is there any way to automatically change or disable network booting after the RHEV Hypervisor is installed? Or is there some methods can be used on the pxe server side to fail the pxe boot of Client after RHEV is installed? I know that we can just remove the configuration file under /tftpboot/pxelinux.cfg if we know the installation of OS has started, but I just don't know how to know if the installation of OS has started by some automatic methods.


3. After the installation of RHEV in my client machine, I found that I can not ssh to the client, do you know how to configure it as enabled on the pxe server side?

This is the configure file under /tftpboot/pxelinux.cfg/:


TIMEOUT 20
PROMPT 0
LABEL pxeboot
******* KERNEL vmlinuz0
******* APPEND* rootflags=loop initrd=initrd0.img root=/director_appliance-rhevhb-hypervisor-0.94.1.iso rootfstype=auto ro liveimg** check crashkernel=128M@16M elevator=deadline processor.max_cstate=1 linux storage_init=/dev/sda firstboot storage_vol=50:1000:512:20:1000:40000 BOOTIF=eth0 ip=dhcp hostname=directorapp local_boot standalone ovirt_early=director_appliance vga=791 da_hostnet=1

ONERROR LOCALBOOT 0

I once tried add ks=nfs:9.123.99.177:/rhev/ks/ks.cfg to APPEND line, and enable nfs, in the ks.cfg, I set rootpw, but still did not set the client's password after the installation.

Did some one once do this before? Can you share your configuration file?



_______________________________________________
Redhat-install-list mailing list
Redhat-install-list@redhat.com
https://www.redhat.com/mailman/listinfo/redhat-install-list
To Unsubscribe Go To ABOVE URL or send a message to:
redhat-install-list-request@redhat.com
Subject: unsubscribe
 

Thread Tools




All times are GMT. The time now is 06:15 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org