Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Launchpad User (http://www.linux-archive.org/launchpad-user/)
-   -   Vim fails to build (actually: Special characters and escape sequences) (http://www.linux-archive.org/launchpad-user/168866-vim-fails-build-actually-special-characters-escape-sequences.html)

"Martin Pool" 10-01-2008 02:26 AM

Vim fails to build (actually: Special characters and escape sequences)
 
On Tue, Sep 30, 2008 at 11:54 PM, Pau Garcia i Quiles
<pgquiles@elpauer.org> wrote:
> Hello,
>
> Vim 7.2.022 builds fine here in a pbuilder but it fails in my PPA.
>
> I think the failure is due to the tests Vim runs, which include
> special characters and escape sequences which confuse the PPA.
>
> How can I fix that (not running the tests is not an option)?

So it looks like vim is running during the tests and trying to run
interactively - displaying itself in your terminal if you run it
directly. It is certainly pretty hard to read in the output.

You could look into whether vim actually needs a real terminal of some
kind to run its tests. If it does, maybe you could run it under
screen? You could speak to the Ubuntu or Debian maintainer of vim who
may have some experience with it, or be able to help you work out if
it really is just specific to PPAs. (For instance can you rebuild the
Ubuntu source package unchanged in a PPA?)

At the end, where it's killed by sigterm, it seems to have been
opening test.out which is already open. Is this the intended
behaviour of this test or is something going wrong?


--
Martin <http://launchpad.net/~mbp/>

--
launchpad-users mailing list
launchpad-users@lists.canonical.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/launchpad-users


All times are GMT. The time now is 10:14 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.