FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Kubuntu User

 
 
LinkBack Thread Tools
 
Old 02-15-2012, 12:41 AM
gene heskett
 
Default apt-get install problem

Greetings people;

I have a deb (openscam, a graphics preview that converts rs-274D gcode into
a preview of what the milling machine would carve when that code is
executed by this openscam program) package sitting in
/var/cache/apt/archives that I would like to install. However apt-get
insists on telling me that this file does not exist even when I give apt-
get the full pathlist/name.deb.

I don't use apt enough to be well versed in its cli nuances, doing the
maintenance with synaptic 99% of the time, so what option do I give it to
make it use this already downloaded package?

Thanks.

Cheers, Gene
--
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
My web page: <http://coyoteden.dyndns-free.com:85/gene>
I can't decide whether to commit suicide or go bowling.
-- Florence Henderson

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 02-15-2012, 12:53 AM
Jan Johansson
 
Default apt-get install problem

>I don't use apt enough to be well versed in its cli nuances, doing the maintenance with synaptic 99% of the time, so >what option do I give it to make it use this already downloaded package?

If I read you correctly dpkg -i /path/to/file.deb should be what you are looking for.

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 02-15-2012, 03:10 AM
gene heskett
 
Default apt-get install problem

On Tuesday, February 14, 2012 09:36:29 PM Jan Johansson did opine:

> >I don't use apt enough to be well versed in its cli nuances, doing the
> >maintenance with synaptic 99% of the time, so >what option do I give
> >it to make it use this already downloaded package?
>
> If I read you correctly dpkg -i /path/to/file.deb should be what you are
> looking for.

Thanks Jan, but then it throws a dependency I can't fix from the repos for
10.04 LTS. I need libglew.so.1.6, but only 1.5 seems to be available for
10.04 lTS.

So, I've now pulled in the tarball, installed the deps according to their
build instructs, and cbang is being digested by scons, whatever the heck
that is. And at the rate its going, I wonder if a 250Gb drive is big
enough! I had a distaste for C++ before because of its sizes, and it is
being reinforced.

Humm, on the web page, scons is the last command listed. Does this, when
its done, do a 'make install' or something?

Apparently not.

I've run it in place, but apparently it doesn't like the dialect of gcode
we have, says its throwing an exception because of a null pointer in line
1. Its a (style) comment.

From the cli I ran it:
gene@shop:~/src/openscam_0.0.5$ ./openscam

(openscam:11706): Gtk-WARNING **: Could not find signal handler
'on_render_resolution_changed'
03:54:31:INFO(1):Bounds: ((-inf,-inf,-inf), (inf,inf,inf))
03:54:31:INFO(1)imensions: (inf,inf,inf)
03:54:59:INFO(1):Opening project /home/gene/linuxcnc/nc_files/genes-
encoder.ngc
03:54:59:ERROR:Exception: Parse failed: 2: syntax error
03:54:59:ERROR: At: /home/gene/linuxcnc/nc_files/genes-
encoder.ngc:1:0

Looks like its alpha code. Stable, but can't do anything. Sigh. And the
propaganda reads so nice. The tarball contains exactly zero docs too.
Grroooouuuuuuhphphphp! <-my tony the tiger roar ;-)

In spite of all that:

Cheers, Gene
--
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
My web page: <http://coyoteden.dyndns-free.com:85/gene>
Seize the day, put no trust in the morrow!
-- Quintus Horatius Flaccus (Horace)

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 

Thread Tools




All times are GMT. The time now is 09:40 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org