FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Kubuntu User

 
 
LinkBack Thread Tools
 
Old 12-19-2011, 12:52 PM
Sid Boyce
 
Default kde 4.7.4 upgrade problems

How do I get kde4 to 4.7.4, do I need a repository change or added?
# apt-cache policy libqt4-core
libqt4-core:
Installed: (none)
Candidate: 4:4.7.4-0ubuntu8
Version table:
4:4.7.4-0ubuntu8 0
500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64
Packages

# apt-cache policy libqt4-core
libqt4-core:
Installed: (none)
Candidate: 4:4.7.4-0ubuntu8
Version table:
4:4.7.4-0ubuntu8 0
500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64
Packages

root@sdrbox1:~# apt-cache policy kde-workspace
kde-workspace:
Installed: 4:4.7.3a-0ubuntu0.1
Candidate: 4:4.7.3a-0ubuntu0.1
Version table:
*** 4:4.7.3a-0ubuntu0.1 0
500 http://gb.archive.ubuntu.com/ubuntu/ oneiric-proposed/main
amd64 Packages

100 /var/lib/dpkg/status
4:4.7.2-0ubuntu2 0
500 http://gb.archive.ubuntu.com/ubuntu/ oneiric-updates/main
amd64 Packages

4:4.7.1-0ubuntu5 0
500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64
Packages

# aptitude install libqt4-core
The following NEW packages will be installed:
libqt4-core{b}
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 6,296 B of archives. After unpacking 131 kB will be used.
The following packages have unmet dependencies:
libqt4-core: Conflicts: libqt4-core but 4:4.7.4-0ubuntu8 is installed.
libqt4-core: Conflicts: libqt4-core but 4:4.7.4-0ubuntu8 is to be
installed.

The following actions will resolve these dependencies:

Remove the following packages:
1) flashplugin-downloader
2) flashplugin-installer
3) libasound2
4) libasound2-plugins
5) libasyncns0
6) libatk1.0-0
7) libaudio2
8) libavahi-client3
9) libavahi-common3
10) libc6
11) libcairo2
12) libcomerr2
13) libcups2
14) libcurl3
15) libdatrie1
16) libdb5.1
17) libdbus-1-3
18) libdrm-intel1
19) libdrm-nouveau1a
20) libdrm-radeon1
21) libdrm2
22) libexpat1
23) libffi6
24) libflac8
25) libfontconfig1
26) libfreetype6
27) libgcc1
28) libgcrypt11
29) libgdk-pixbuf2.0-0
30) libgl1-mesa-dri
31) libgl1-mesa-glx
32) libglapi-mesa
33) libglib2.0-0
34) libgnutls26
35) libgpg-error0
36) libgssapi-krb5-2
37) libgtk2.0-0
38) libice6
39) libidn11
40) libjack-jackd2-0
41) libjasper1
42) libjpeg62
43) libjson0
44) libk5crypto3
45) libkeyutils1
46) libkrb5-3
47) libkrb5support0
48) liblcms1
49) libldap-2.4-2
50) libllvm2.9
51) libmng1
52) libnspr4
53) libnspr4-0d
54) libnss3
55) libnss3-1d
56) libogg0
57) libpango1.0-0
58) libpciaccess0
59) libpcre3
60) libpixman-1-0
61) libpng12-0
62) libpulse0
63) libqt4-core
64) libqt4-dbus
65) libqt4-declarative
66) libqt4-designer
67) libqt4-gui
68) libqt4-network
69) libqt4-opengl
70) libqt4-script
71) libqt4-sql
72) libqt4-svg
73) libqt4-test
74) libqt4-xml
75) libqt4-xmlpatterns
76) libqtcore4
77) libqtgui4
78) librtmp0
79) libsamplerate0
80) libsasl2-2
81) libsasl2-modules
82) libselinux1
83) libsm6
84) libsndfile1
85) libspeexdsp1
86) libsqlite3-0
87) libssl1.0.0
88) libstdc++6
89) libtasn1-3
90) libthai0
91) libtiff4
92) libuuid1
93) libvorbis0a
94) libvorbisenc2
95) libwrap0
96) libx11-6
97) libxau6
98) libxcb-render0
99) libxcb-shm0
100) libxcb1
101) libxcomposite1
102) libxcursor1
103) libxdamage1
104) libxdmcp6
105) libxext6
106) libxfixes3
107) libxft2
108) libxi6
109) libxinerama1
110) libxrandr2
111) libxrender1
112) libxss1
113) libxt6
114) libxxf86vm1
115) nspluginviewer
116) nspluginwrapper
117) zlib1g

Leave the following dependencies unresolved:
118) ubuntu-restricted-addons recommends flashplugin-installer
119) flashplugin-downloader recommends libasound2-plugins (>= 1.0.16)


Accept this solution? [Y/n/q/?]

root@sdrbox1:~# aptitude install kde-workspace
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

root@sdrbox1:~# dpkg -l kde-workspace
Desired=Unknown/Install/Remove/Purge/Hold
|
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend

|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name
Version Description

+++-================================================== ===-================================================== ===-================================================== ================================================== ======================
ii kde-workspace
4:4.7.3a-0ubuntu0.1 KDE Plasma
Workspace components


Regards
Sid.

--
Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot,
Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
Senior Staff Specialist, Cricket Coach
Microsoft Windows Free Zone - Linux used for all Computing Tasks


--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 12-21-2011, 10:45 AM
Sid Boyce
 
Default kde 4.7.4 upgrade problems

In the end I copied across /etc/apt from another 11.10 box running KDE
4.7.4 and was able to upgrade using it.

Regards
Sid.

--
Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot,
Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
Senior Staff Specialist, Cricket Coach
Microsoft Windows Free Zone - Linux used for all Computing Tasks


--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 

Thread Tools




All times are GMT. The time now is 10:34 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org