Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Kubuntu User (http://www.linux-archive.org/kubuntu-user/)
-   -   xpdf gives segmentation fault under kubuntu 11.04 (http://www.linux-archive.org/kubuntu-user/577705-xpdf-gives-segmentation-fault-under-kubuntu-11-04-a.html)

Waleed Hamra 09-19-2011 09:03 PM

xpdf gives segmentation fault under kubuntu 11.04
 
On 09/19/2011 10:55 PM, Hugo Coolens wrote:
> I installed xpdf using sudo apt-get install xpdf but it crashes as you
> can see below:
> coolens@tuxedo:~$ xpdf cable.pdf
> Warning: Cannot convert string
> "-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1" to type FontStruct
> Warning: Cannot convert string
> "-*-courier-medium-r-normal--12-*-*-*-*-*-iso8859-1" to type FontStruct
> Warning: Cannot convert string
> "-*-times-bold-i-normal--20-*-*-*-*-*-iso8859-1" to type FontStruct
> Warning: Cannot convert string
> "-*-times-medium-r-normal--16-*-*-*-*-*-iso8859-1" to type FontStruct
> Segmentation fault
>
> Any idea how to solve this (of course not by using another pdf-viewer)
>
> regards,
> hugo
>

Hello Hugo
first off, please, start a new thread when you want to start a subject
in this list, instead of replying to an unrelated email. many of us use
threading views, and this sorts your email into a completely unrelated
topic.

but to the matter at hand. a little googling suggests this is a somewhat
popular topic from this year. it seems to be a bug in libpoppler, which
is a dependency of xpdf, and hence, can not be removed.
but according to both, debian and ubuntu bug control, a fix has been
released somewhere around late july.
i am assuming you are using either Natty or an earlier release, since
Oneiric is still in beta stage, in which case, you won't be able to get
the fix from the regular repository.
you can either wait for the oneiric upgrade, which should be in October,
and use another pdf viewer meanwhile, or you can install xpdf along with
libpoppler from some alternate repository (or maybe oneiric's). i'm
afraid i don't know of any such repository at the moment, or how safe it
is to pick just the few debian packages needed from oneiric's repository
and installing them on an older system.

PS: in https://bugs.launchpad.net/debian/+source/xpdf/+bug/788343
there's a mention of a way to install from the source package, you can
try that as well.

--
Waleed K. Hamra
Manager of Hamra Information Systems

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users


All times are GMT. The time now is 09:20 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.