FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Kubuntu User

 
 
LinkBack Thread Tools
 
Old 07-30-2010, 07:49 PM
"giovanni_re"
 
Default firefox-bin:26987): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64 ; jor kubuntu

Firefox from direct download from mozilla. - Not the KUbuntu packaged
Firefox.
On KUbuntu 10.4 on 64 bit os.

I'm using the mozilla direct version, not the KU version, because i was
told the direct version had debug output, but the KU version doesn't
have debug output - useful if there is a crash, or other problems.


=
I'm getting this message.
(firefox-bin:26987): Gtk-WARNING **:
/usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class:
ELFCLASS64

when I start FF.

I'm running this from the console command line:
"./firefox -no-remote"


I'm using no-remote because that starts a separate instance of firefox.
That is done in case there is a crash, then only the windows in that
instance of ff crash, not the windows in the other instance.

Since FF from mozilla seems to use the gtk stuff, but the KUbuntu FF
version maybe uses QT stuff, what would seem to be the best way to
resolve this error?


Thanks



=================
# dpkg -l | grep gtk
ii firestarter 1.0.3-7ubuntu5
gtk program for managing and observing your
ii gtk2-engines-qtcurve 1.0.2-1ubuntu1
This is a set of widget styles for Gtk2 base
ii kcm-gtk 0.5.3-0ubuntu2
Configuration module for GTK+ appearance in
ii libcanberra-gtk-module 0.22-1ubuntu2
translates Gtk+ widgets signals to event sou
ii libcanberra-gtk0 0.22-1ubuntu2
Gtk+ helper for playing widget event sounds
ii libdbusmenu-gtk1 0.2.9-0ubuntu3
Menus over DBus shared library for GTK
ii libgtk2-perl 1:1.221-4ubuntu2
Perl interface to the 2.x series of the Gimp
ii libgtk2.0-0 2.20.1-0ubuntu2
The GTK+ graphical user interface library
ii libgtk2.0-bin 2.20.1-0ubuntu2
The programs for the GTK+ graphical user int
ii libgtk2.0-cil 2.12.9-4
CLI binding for the GTK+ toolkit 2.12
ii libgtk2.0-common 2.20.1-0ubuntu2
Common files for the GTK+ graphical user int
ii libgtk2.0-dev 2.20.1-0ubuntu2
Development files for the GTK+ library
ii libgtkhtml3.14-19 1:3.29.6.is.3.28.3-0ubuntu2
HTML rendering/editing library - runtime fil
ii libgtkmm-2.4-1c2a 1:2.20.3-0ubuntu1
C++ wrappers for GTK+ (shared libraries)
ii libgtksourceview2.0-0 2.10.4-0ubuntu1
shared libraries for the GTK+ syntax highlig
ii libgtksourceview2.0-common 2.10.4-0ubuntu1
common files for the GTK+ syntax highlightin
ii libwxgtk2.8-0 2.8.10.1-0ubuntu1
wxWidgets Cross-platform C++ GUI toolkit (GT
ii python-gtk2 2.17.0-0ubuntu2
Python bindings for the GTK+ widget set
ii python-gtksourceview2 2.10.1-0ubuntu1
Python bindings for the GtkSourceView widget
ii software-properties-gtk 0.75.10
manage the repositories that you install sof
ii wicd-gtk 1.7.0+ds1-2
wired and wireless network manager - GTK+ cl


# dpkg -l | grep libqtcurve


# dpkg -l | grep libqt
ii libqt3-mt 3:3.3.8-b-6ubuntu2
Qt GUI Library (Threaded runtime version), V
ii libqt4-assistant 4:4.6.2-0ubuntu5
Qt 4 assistant module
ii libqt4-dbg 4:4.6.2-0ubuntu5
Qt 4 library debugging symbols
ii libqt4-dbus 4:4.6.2-0ubuntu5
Qt 4 D-Bus module
ii libqt4-designer 4:4.6.2-0ubuntu5
Qt 4 designer module
ii libqt4-help 4:4.6.2-0ubuntu5
Qt 4 help module
ii libqt4-network 4:4.6.2-0ubuntu5
Qt 4 network module
ii libqt4-opengl 4:4.6.2-0ubuntu5
Qt 4 OpenGL module
ii libqt4-qt3support 4:4.6.2-0ubuntu5
Qt 3 compatibility library for Qt 4
ii libqt4-script 4:4.6.2-0ubuntu5
Qt 4 script module
ii libqt4-scripttools 4:4.6.2-0ubuntu5
Qt 4 script tools module
ii libqt4-sql 4:4.6.2-0ubuntu5
Qt 4 SQL module
ii libqt4-sql-mysql 4:4.6.2-0ubuntu5
Qt 4 MySQL database driver
ii libqt4-sql-sqlite 4:4.6.2-0ubuntu5
Qt 4 SQLite 3 database driver
ii libqt4-svg 4:4.6.2-0ubuntu5
Qt 4 SVG module
ii libqt4-test 4:4.6.2-0ubuntu5
Qt 4 test module
ii libqt4-webkit 4:4.6.2-0ubuntu5
Qt 4 WebKit module
ii libqt4-xml 4:4.6.2-0ubuntu5
Qt 4 XML module
ii libqt4-xmlpatterns 4:4.6.2-0ubuntu5
Qt 4 XML patterns module
ii libqtcore4 4:4.6.2-0ubuntu5
Qt 4 core module
ii libqtgui4 4:4.6.2-0ubuntu5
Qt 4 GUI module
ii libqtscript4-core 0.1.0-3build1
Qt Script bindings for the Qt 4 Core library
ii libqtscript4-gui 0.1.0-3build1
Qt Script bindings for the Qt 4 Gui library
ii libqtscript4-network 0.1.0-3build1
Qt Script bindings for the Qt 4 Network libr
ii libqtscript4-sql 0.1.0-3build1
Qt Script bindings for the Qt 4 SQL library
ii libqtscript4-uitools 0.1.0-3build1
Qt Script bindings for the Qt 4 UiTools libr
ii libqtscript4-xml 0.1.0-3build1
Qt Script bindings for the Qt 4 XML library


dpkg -l | grep firefox
{returns nothing - ff isn't installed with the KUbuntu package manager.}


# dpkg -l | grep qt
ii gtk2-engines-qtcurve 1.0.2-1ubuntu1
This is a set of widget styles for Gtk2 base
ii ibus-qt4 1.2.0.20091217-1
qt-immodule for ibus (QT4)
ii language-selector-qt 0.5.8
Language selector for Kubuntu Linux
ii libaqbanking29-plugins-qt 4.2.3-1
plugins needed by libaqbanking29
ii libavahi-qt3-1 0.6.25-1ubuntu6
Avahi Qt 3 integration library
ii libdbusmenu-qt2 0.3.2-0ubuntu1
a Qt library that implements the DBusMenu sp
ii libibus-qt1 1.2.0.20091217-1
qt-immodule for ibus (QT4)
ii libindicate-qt0 0.2.5-0ubuntu1
Qt bindings for libindicate
ii libpackagekit-qt-12 0.5.7-0ubuntu2
Library for accessing PackageKit using Qt.
ii libpolkit-qt-1-0 0.95.1-1fakesync1
PolicyKit-qt-1 library
ii libpoppler-qt4-3 0.12.4-0ubuntu5
PDF rendering library (Qt 4 based shared lib
ii libqt3-mt 3:3.3.8-b-6ubuntu2
Qt GUI Library (Threaded runtime version), V
ii libqt4-assistant 4:4.6.2-0ubuntu5
Qt 4 assistant module
ii libqt4-dbg 4:4.6.2-0ubuntu5
Qt 4 library debugging symbols
ii libqt4-dbus 4:4.6.2-0ubuntu5
Qt 4 D-Bus module
ii libqt4-designer 4:4.6.2-0ubuntu5
Qt 4 designer module
ii libqt4-help 4:4.6.2-0ubuntu5
Qt 4 help module
ii libqt4-network 4:4.6.2-0ubuntu5
Qt 4 network module
ii libqt4-opengl 4:4.6.2-0ubuntu5
Qt 4 OpenGL module
ii libqt4-qt3support 4:4.6.2-0ubuntu5
Qt 3 compatibility library for Qt 4
ii libqt4-script 4:4.6.2-0ubuntu5
Qt 4 script module
ii libqt4-scripttools 4:4.6.2-0ubuntu5
Qt 4 script tools module
ii libqt4-sql 4:4.6.2-0ubuntu5
Qt 4 SQL module
ii libqt4-sql-mysql 4:4.6.2-0ubuntu5
Qt 4 MySQL database driver
ii libqt4-sql-sqlite 4:4.6.2-0ubuntu5
Qt 4 SQLite 3 database driver
ii libqt4-svg 4:4.6.2-0ubuntu5
Qt 4 SVG module
ii libqt4-test 4:4.6.2-0ubuntu5
Qt 4 test module
ii libqt4-webkit 4:4.6.2-0ubuntu5
Qt 4 WebKit module
ii libqt4-xml 4:4.6.2-0ubuntu5
Qt 4 XML module
ii libqt4-xmlpatterns 4:4.6.2-0ubuntu5
Qt 4 XML patterns module
ii libqtcore4 4:4.6.2-0ubuntu5
Qt 4 core module
ii libqtgui4 4:4.6.2-0ubuntu5
Qt 4 GUI module
ii libqtscript4-core 0.1.0-3build1
Qt Script bindings for the Qt 4 Core library
ii libqtscript4-gui 0.1.0-3build1
Qt Script bindings for the Qt 4 Gui library
ii libqtscript4-network 0.1.0-3build1
Qt Script bindings for the Qt 4 Network libr
ii libqtscript4-sql 0.1.0-3build1
Qt Script bindings for the Qt 4 SQL library
ii libqtscript4-uitools 0.1.0-3build1
Qt Script bindings for the Qt 4 UiTools libr
ii libqtscript4-xml 0.1.0-3build1
Qt Script bindings for the Qt 4 XML library
ii libqwt5-qt4 5.2.0-1build1
Qt4 widgets library for technical applicatio
ii pinentry-qt4 0.7.6-1
Qt-4-based PIN or pass-phrase entry dialog f
ii python-qt4 4.7.2-0ubuntu1
Python bindings for Qt4
ii python-qt4-dbus 4.7.2-0ubuntu1
DBus Support for PyQt4
ii qtoctave 0.8.2+dfsg-2ubuntu1
A Qt front-end to Octave

== Join in the Global weekly meetings, via VOIP, about all Free SW HW & Culture
http://sites.google.com/site/berkeleytip/


--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 07-31-2010, 12:43 PM
Lindsay Mathieson
 
Default firefox-bin:26987): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64 ; jor kubuntu

On Sat, 31 Jul 2010 05:49:13 am giovanni_re wrote:
> I'm getting this message.
> (firefox-bin:26987): Gtk-WARNING **:
> /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class:
> ELFCLASS64
>
> when I start FF.


It looks like you might be running the 23bit version of firefox against a 64bit
install - or maybe the other way around.


> Since FF from mozilla seems to use the gtk stuff, but the KUbuntu FF
> version maybe uses QT stuff, what would seem to be the best way to
> resolve this error?


Not the case - the kubuntu firefox still uses GTK, but there' s been some
hackery to make it use the KDE file dialogs.

--
Lindsay
http://blackpaw.jalbum.net/home

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 

Thread Tools




All times are GMT. The time now is 02:44 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org