FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Kubuntu User

 
 
LinkBack Thread Tools
 
Old 01-12-2008, 09:28 AM
Donn
 
Default Aptitude wants to remove KOffice

Don't really know, but I have found that:
aptitude dist-upgrade
can fix some of these things.

Let us know what you discover.

d


--
Fonty Python and other dev news at:
http://otherwiseingle.blogspot.com/

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 01-12-2008, 10:08 AM
Thomas Olsen
 
Default Aptitude wants to remove KOffice

On Saturday 12 January 2008 11:28:00 Donn wrote:
> Don't really know, but I have found that:
> aptitude dist-upgrade
> can fix some of these things.
>
> Let us know what you discover.
>
> d

It doesn't fix it but informs me that koffice is broken:

tol@hp-laptop:~$ sudo aptitude dist-upgrade
[sudo] password for tol:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
koffice2
The following packages are unused and will be REMOVED:
apturl deborphan docbook-xml gksu gnome-app-install gnome-icon-theme karbon
kexi kivio kivio-data
kpresenter kpresenter-data kspread kthesaurus kugar kword kword-data
libbonoboui2-0 libbonoboui2-common
libcairo-perl libcroco3 libgail-common libgail18 libgksu2-0 libglade2-0
libglib-perl
libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgnomecanvas2-0
libgnomecanvas2-common
libgnomeui-0 libgnomeui-common libgsf-1-114 libgsf-1-common libgtk2-perl
libgtkhtml2-0 libgtop2-7
libgtop2-common liblaunchpad-integration0 libpqxx-2.6.9 librsvg2-2
librsvg2-common libscrollkeeper0
libvte-common libvte9 libwv2-1c2 python-cairo python-gconf python-gdbm
python-glade2 python-gst0.10
python-gtk2 python-gtkhtml2 python-launchpad-integration python-numeric
python-pyorbit python-sexy
python-vte scrollkeeper sgml-data software-properties-gtk synaptic
The following NEW packages will be automatically installed:
dbus-x11 kdebase-runtime libphonon4
The following packages will be automatically REMOVED:
kdebase-runtime-bin
The following NEW packages will be installed:
dbus-x11 kdebase-runtime libphonon4
The following packages will be REMOVED:
kdebase-runtime-bin
The following packages will be upgraded:
kate kcontrol kde-icons-oxygen kde4libs-bin kdebase-bin kdebase-data
kdebase-kio-plugins
kdebase-runtime-bin-kde4 kdebase-runtime-data kdelibs5 kdelibs5-data
kdepasswd kdepimlibs-data
kdepimlibs5 kdeprint kdesktop kdm kfind khelpcenter kicker klipper kmenuedit
konqueror
konqueror-nsplugins konsole ksmserver ksplash ksysguardd kwin libdb4.4
libkonq4 libsoprano4 tzdata
33 packages upgraded, 3 newly installed, 64 to remove and 0 not upgraded.
Need to get 1434kB/95,1MB of archives. After unpacking 141MB will be freed.
The following packages have unmet dependencies:
koffice2: Depends: kdebase-runtime-bin but it is not installable
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:
koffice2

Keep the following packages at their current version:
ksmserver [4:3.5.8-0ubuntu2 (gutsy, now)]

Score is 189

Accept this solution? [Y/n/q/?]

Any idea whats going on?

/Thomas

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 01-12-2008, 10:27 AM
Donn
 
Default Aptitude wants to remove KOffice

> Any idea whats going on?
Urgh. This stuff hurts my head. It looks like you are in the soup. Have you
been experimenting with KDE4.0 at all?

Perhaps you should let it remove what it wants to, then do another update and
another dist-upgrade. Keep going until it does not report anymore broken
stuff, then try to install koffice again.

Also, aptitude has a gui! Just run aptitude on it's own - perhaps that will
show you something otherwise missed.

Good luck,
d

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 01-12-2008, 11:59 AM
Clay Weber
 
Default Aptitude wants to remove KOffice

On Saturday 12 January 2008 1:12:17 am Thomas Olsen wrote:
> Hi
>
> When I run:
>
> sudo aptitude safe-upgrade
>
> aptitude responds:
>
> tol@hp-laptop:~$ sudo aptitude safe-upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Reading extended state information
> Initializing package states... Done
> Building tag database... Done
> The following packages are unused and will be REMOVED:
> apturl deborphan docbook-xml gksu gnome-app-install gnome-icon-theme
> karbon kexi kivio kivio-data
> kpresenter kpresenter-data kspread kthesaurus kugar kword kword-data
> libbonoboui2-0 libbonoboui2-common
> libcairo-perl libcroco3 libgail-common libgail18 libgksu2-0 libglade2-0
> libglib-perl
> libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgnomecanvas2-0
> libgnomecanvas2-common
> libgnomeui-0 libgnomeui-common libgsf-1-114 libgsf-1-common libgtk2-perl
> libgtkhtml2-0 libgtop2-7
> libgtop2-common liblaunchpad-integration0 libpqxx-2.6.9 librsvg2-2
> librsvg2-common libscrollkeeper0
> libvte-common libvte9 libwv2-1c2 python-cairo python-gconf python-gdbm
> python-glade2 python-gst0.10
> python-gtk2 python-gtkhtml2 python-launchpad-integration python-numeric
> python-pyorbit python-sexy
> python-vte scrollkeeper sgml-data software-properties-gtk synaptic
> The following packages have been kept back:
> kde4libs-bin kdelibs5 kdepimlibs5
> The following packages will be upgraded:
> kdelibs5-data kdepimlibs-data libdb4.4 libsoprano4 tzdata
> 5 packages upgraded, 0 newly installed, 63 to remove and 3 not upgraded.
> Need to get 0B/4880kB of archives. After unpacking 131MB will be freed.
> Do you want to continue? [Y/n/?] n
>
>
> Why does it want to remove KOffice? I dont want that to happen.
>
> My / etc/apt/sources.list looks like this:
>
> # deb cdrom:[Kubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016.1)]/
> gutsy main restricted
> # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
> # newer versions of the distribution.
>
> # Line commented out by installer because it failed to verify:
> # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy main restricted
> # Line commented out by installer because it failed to verify:
> # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy main restricted
>
> ## Major bug fix updates produced after the final release of the
> ## distribution.
> # Line commented out by installer because it failed to verify:
> # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
> # Line commented out by installer because it failed to verify:
> # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates main
> restricted
>
> ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
> ## team, and may not be under a free licence. Please satisfy yourself as to
> ## your rights to use the software. Also, please note that software in
> ## universe WILL NOT receive any review or updates from the Ubuntu security
> ## team.
> # Line commented out by installer because it failed to verify:
> deb http://dk.archive.ubuntu.com/ubuntu/ gutsy universe main restricted
> multiverse
> # Line commented out by installer because it failed to verify:
> # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy universe
> # Line commented out by installer because it failed to verify:
> # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates universe
> # Line commented out by installer because it failed to verify:
> # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates universe
>
> ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
> ## team, and may not be under a free licence. Please satisfy yourself as to
> ## your rights to use the software. Also, please note that software in
> ## multiverse WILL NOT receive any review or updates from the Ubuntu
> ## security team.
> # Line commented out by installer because it failed to verify:
> # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy multiverse
> # Line commented out by installer because it failed to verify:
> # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy multiverse
> # Line commented out by installer because it failed to verify:
> # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
> # Line commented out by installer because it failed to verify:
> # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
>
> ## Uncomment the following two lines to add software from the 'backports'
> ## repository.
> ## N.B. software from this repository may not have been tested as
> ## extensively as that contained in the main release, although it includes
> ## newer versions of some applications which may provide useful features.
> ## Also, please note that software in backports WILL NOT receive any review
> ## or updates from the Ubuntu security team.
> deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted
> universe multiverse
> # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy-backports main
> restricted universe multiverse
>
> ## Uncomment the following two lines to add software from Canonical's
> ## 'partner' repository. This software is not part of Ubuntu, but is
> ## offered by Canonical and the respective vendors as a service to Ubuntu
> ## users.
> deb http://archive.canonical.com/ubuntu gutsy partner
> # deb-src http://archive.canonical.com/ubuntu gutsy partner
>
> # Line commented out by installer because it failed to verify:
> # deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
> # Line commented out by installer because it failed to verify:
> # deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
> # Line commented out by installer because it failed to verify:
> # deb http://security.ubuntu.com/ubuntu gutsy-security universe
> # Line commented out by installer because it failed to verify:
> # deb-src http://security.ubuntu.com/ubuntu gutsy-security universe
> # Line commented out by installer because it failed to verify:
> # deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
> # Line commented out by installer because it failed to verify:
> deb http://security.ubuntu.com/ubuntu/ gutsy-security universe main
> multiverse restricted
> deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates universe main
> multiverse restricted
> # deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse
> deb http://packages.medibuntu.org/ gutsy free non-free
>
>
> /Thomas

Many of your repositories have been disabled, probably due to some temporary
problem with the servers you are using

You can delete all the lines with the message
"# Line commented out by installer because it failed to verify:"
and you will also need to remove the "#" from all the lines that begin
with "deb", as well as those with "deb-src" if you need access to the source
packages.

Then updating/upgrading should be fixed.

--
Clay Weber
http://kubuntuforums.net
http://claydoh.com
http://emacdogsports.com

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 01-12-2008, 01:19 PM
Thomas Olsen
 
Default Aptitude wants to remove KOffice

On Saturday 12 January 2008 13:59:11 Clay Weber wrote:
> On Saturday 12 January 2008 1:12:17 am Thomas Olsen wrote:
> > Hi
> >
> > When I run:
> >
> > sudo aptitude safe-upgrade
> >
> > aptitude responds:
> >
> > tol@hp-laptop:~$ sudo aptitude safe-upgrade
> > Reading package lists... Done
> > Building dependency tree
> > Reading state information... Done
> > Reading extended state information
> > Initializing package states... Done
> > Building tag database... Done
> > The following packages are unused and will be REMOVED:
> > apturl deborphan docbook-xml gksu gnome-app-install gnome-icon-theme
> > karbon kexi kivio kivio-data
> > kpresenter kpresenter-data kspread kthesaurus kugar kword kword-data
> > libbonoboui2-0 libbonoboui2-common
> > libcairo-perl libcroco3 libgail-common libgail18 libgksu2-0 libglade2-0
> > libglib-perl
> > libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl
> > libgnomecanvas2-0 libgnomecanvas2-common
> > libgnomeui-0 libgnomeui-common libgsf-1-114 libgsf-1-common
> > libgtk2-perl libgtkhtml2-0 libgtop2-7
> > libgtop2-common liblaunchpad-integration0 libpqxx-2.6.9 librsvg2-2
> > librsvg2-common libscrollkeeper0
> > libvte-common libvte9 libwv2-1c2 python-cairo python-gconf python-gdbm
> > python-glade2 python-gst0.10
> > python-gtk2 python-gtkhtml2 python-launchpad-integration python-numeric
> > python-pyorbit python-sexy
> > python-vte scrollkeeper sgml-data software-properties-gtk synaptic
> > The following packages have been kept back:
> > kde4libs-bin kdelibs5 kdepimlibs5
> > The following packages will be upgraded:
> > kdelibs5-data kdepimlibs-data libdb4.4 libsoprano4 tzdata
> > 5 packages upgraded, 0 newly installed, 63 to remove and 3 not upgraded.
> > Need to get 0B/4880kB of archives. After unpacking 131MB will be freed.
> > Do you want to continue? [Y/n/?] n
> >
> >
> > Why does it want to remove KOffice? I dont want that to happen.
> >
> > My / etc/apt/sources.list looks like this:
> >
> > # deb cdrom:[Kubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016.1)]/
> > gutsy main restricted
> > # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
> > # newer versions of the distribution.
> >
> > # Line commented out by installer because it failed to verify:
> > # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy main restricted
> > # Line commented out by installer because it failed to verify:
> > # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy main restricted
> >
> > ## Major bug fix updates produced after the final release of the
> > ## distribution.
> > # Line commented out by installer because it failed to verify:
> > # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
> > # Line commented out by installer because it failed to verify:
> > # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates main
> > restricted
> >
> > ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the
> > Ubuntu ## team, and may not be under a free licence. Please satisfy
> > yourself as to ## your rights to use the software. Also, please note that
> > software in ## universe WILL NOT receive any review or updates from the
> > Ubuntu security ## team.
> > # Line commented out by installer because it failed to verify:
> > deb http://dk.archive.ubuntu.com/ubuntu/ gutsy universe main restricted
> > multiverse
> > # Line commented out by installer because it failed to verify:
> > # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy universe
> > # Line commented out by installer because it failed to verify:
> > # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates universe
> > # Line commented out by installer because it failed to verify:
> > # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates universe
> >
> > ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the
> > Ubuntu ## team, and may not be under a free licence. Please satisfy
> > yourself as to ## your rights to use the software. Also, please note that
> > software in ## multiverse WILL NOT receive any review or updates from the
> > Ubuntu ## security team.
> > # Line commented out by installer because it failed to verify:
> > # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy multiverse
> > # Line commented out by installer because it failed to verify:
> > # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy multiverse
> > # Line commented out by installer because it failed to verify:
> > # deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
> > # Line commented out by installer because it failed to verify:
> > # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
> >
> > ## Uncomment the following two lines to add software from the 'backports'
> > ## repository.
> > ## N.B. software from this repository may not have been tested as
> > ## extensively as that contained in the main release, although it
> > includes ## newer versions of some applications which may provide useful
> > features. ## Also, please note that software in backports WILL NOT
> > receive any review ## or updates from the Ubuntu security team.
> > deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted
> > universe multiverse
> > # deb-src http://dk.archive.ubuntu.com/ubuntu/ gutsy-backports main
> > restricted universe multiverse
> >
> > ## Uncomment the following two lines to add software from Canonical's
> > ## 'partner' repository. This software is not part of Ubuntu, but is
> > ## offered by Canonical and the respective vendors as a service to Ubuntu
> > ## users.
> > deb http://archive.canonical.com/ubuntu gutsy partner
> > # deb-src http://archive.canonical.com/ubuntu gutsy partner
> >
> > # Line commented out by installer because it failed to verify:
> > # deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
> > # Line commented out by installer because it failed to verify:
> > # deb-src http://security.ubuntu.com/ubuntu gutsy-security main
> > restricted # Line commented out by installer because it failed to verify:
> > # deb http://security.ubuntu.com/ubuntu gutsy-security universe
> > # Line commented out by installer because it failed to verify:
> > # deb-src http://security.ubuntu.com/ubuntu gutsy-security universe
> > # Line commented out by installer because it failed to verify:
> > # deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
> > # Line commented out by installer because it failed to verify:
> > deb http://security.ubuntu.com/ubuntu/ gutsy-security universe main
> > multiverse restricted
> > deb http://dk.archive.ubuntu.com/ubuntu/ gutsy-updates universe main
> > multiverse restricted
> > # deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse
> > deb http://packages.medibuntu.org/ gutsy free non-free
> >
> >
> > /Thomas
>
> Many of your repositories have been disabled, probably due to some
> temporary problem with the servers you are using
>
> You can delete all the lines with the message
> "# Line commented out by installer because it failed to verify:"
> and you will also need to remove the "#" from all the lines that begin
> with "deb", as well as those with "deb-src" if you need access to the
> source packages.

Oops - didn't notice those lines. Must pay more attention.

> Then updating/upgrading should be fixed.

Thanks.
>
> --
> Clay Weber
> http://kubuntuforums.net
> http://claydoh.com
> http://emacdogsports.com



--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 

Thread Tools




All times are GMT. The time now is 08:26 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org