Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Kubuntu User (http://www.linux-archive.org/kubuntu-user/)
-   -   Konqueror crashing at launch with KDE 4.2.1 on Kubuntu Intrepid (http://www.linux-archive.org/kubuntu-user/258517-konqueror-crashing-launch-kde-4-2-1-kubuntu-intrepid.html)

"Terrell Prude' Jr." 03-06-2009 10:50 PM

Konqueror crashing at launch with KDE 4.2.1 on Kubuntu Intrepid
 
Thanks, Paul. Looks like the APT repositories are still in a state of
flux. I'm getting a "public key is not available" message.

So, I did try rebooting the box (not yet logging in), Ctrl-Alt-F3'ing
into a vty, and renaming .kde/ and .kde4/. Then logged in, everything
got recreated, but still no joy. Konqueror still SIGSEGV's as described
below.

This is just one more glitch in far too many for a "release" version of
KDE. On my production box, I'm going back to KDE 3.5.x. That one works
without fussing at me. Hopefully KDE4 on Kubuntu will be properly baked
by then. However, I will maintain a test box with Kubuntu
Intrepid/Jaunty for testing purposes, so I haven't totally given up.

--TP

pkaplan1@comcast.net wrote:
> No idea, as I upgraded w/ no problem, but three simple suggestions.
> First, try sudo apt-get update then sudo apt-get upgrade again. Then
> logout/login. You may have missed a key package update. Second, try
> rebooting the machine, not just logout/login. If those don't work,
> rename your ~/.kde directory, then logout/login. KDE will rebuild the
> directory (you'll have to reset your configs), but this may solve the
> problem.
> Paul
> ----- Original Message -----
> From: "Terrell Prude' Jr." <microman@cmosnetworks.com>
> To: kubuntu-users@lists.ubuntu.com
> Sent: Thursday, March 5, 2009 8:53:48 PM GMT -05:00 US/Canada Eastern
> Subject: Konqueror crashing at launch with KDE 4.2.1 on Kubuntu Intrepid
>
> Hello folks,
>
> I just upgraded my Kubuntu Intrepid's KDE from 4.2.0 to 4.2.1 today,
> from the "kubuntu-experimental" repositories. I use Konqueror as my
> main Web browser and file manager.
>
> Right after the KDE upgrade, rebooting, and logging back in, I tried
> running Konqueror from the menu. An entry appeared in the Task
> Manager like Konqueror was starting up, but...no Konqueror itself
> appeared. After 30 seconds, the taskbar entry disappeared. The same
> thing happened when I tried running it from an icon in the Panel.
> Clearly, something was amiss.
>
> I then tried running Konqueror from a Konsole prompt to see if I could
> get any more info. Right at launch, Konqueror crashed with a
> SIGSEGV. Additionally, a small window titled "Konqueror - The KDE
> Crash Handler" popped up with the following message.
>
> A Fatal Error Occurred
>
> The application Konqueror (konqueror) crashed and caused the
> signal 11 (SIGSEGV).
> Please help us improve the software you use by filing a report at
> http://bugs.kde.org. Useful details include how to reproduce the
> error, documents that were loaded, etc.
>
>
> Clicking "Show details" shows a string of "(no debugging symbols
> found)" messages. Apparently Konqueror was compiled with the symbols
> stripped, which I kinda expect in "release" software. Immediately
> thereafter, I get a second box entitled "Sorry - The KDE Crash
> Handler", basically telling me it can't create a valid backtrace.
> Again, expected when a "stripped" program crashes.
>
> The messages from the Konsole window are as follows.
>
> terrell@tprude01:~$ konqueror
> konqueror(6565) KServiceFactory::findServiceByDesktopPath:
> "findServiceByDesktopPath: searchproviders/locate.desktop not found"
> konqueror(6565) KServiceFactory::findServiceByDesktopPath:
> "findServiceByDesktopPath: searchproviders/.desktop not found"
> KCrash: Application 'konqueror' crashing...
> sock_file=/home/terrell/.kde/socket-tprude01/kdeinit4__0
> terrell@tprude01:~$
>
>
> Konqueror used to work just fine in KDE 4.2.0. Anybody have any ideas
> what's going on?
>
> Thanks!
>
> --TP
>
>
>
> -- kubuntu-users mailing list kubuntu-users@lists.ubuntu.com Modify
> settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/kubuntu-users


--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users


All times are GMT. The time now is 04:54 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.