FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Kubuntu User

 
 
LinkBack Thread Tools
 
Old 03-06-2009, 12:53 AM
"Terrell Prude' Jr."
 
Default Konqueror crashing at launch with KDE 4.2.1 on Kubuntu Intrepid

Hello folks,



I just upgraded my Kubuntu Intrepid's KDE from 4.2.0 to 4.2.1 today,
from the "kubuntu-experimental" repositories.* I use Konqueror as my
main Web browser and file manager.



Right after the KDE upgrade, rebooting, and logging back in, I tried
running Konqueror from the menu.* An entry appeared in the Task Manager
like Konqueror was starting up, but...no Konqueror itself appeared.*
After 30 seconds, the taskbar entry disappeared.* The same thing
happened when I tried running it from an icon in the Panel.* Clearly,
something was amiss.



I then tried running Konqueror from a Konsole prompt to see if I could
get any more info.* Right at launch, Konqueror crashed with a SIGSEGV.*
Additionally, a small window titled "Konqueror - The KDE Crash Handler"
popped up with the following message.




A Fatal Error Occurred
The application Konqueror
(konqueror) crashed and caused the signal 11 (SIGSEGV).

Please help us improve the software you use by filing a report at http://bugs.kde.org.
Useful details include how to reproduce the error, documents that were
loaded, etc.






Clicking "Show details" shows a string of "(no debugging symbols
found)" messages.* Apparently Konqueror was compiled with the symbols
stripped, which I kinda expect in "release" software.* Immediately
thereafter, I get a second box entitled "Sorry - The KDE Crash
Handler", basically telling me it can't create a valid backtrace.*
Again, expected when a "stripped" program crashes.



The messages from the Konsole window are as follows.



terrell@tprude01:~$ konqueror

konqueror(6565) KServiceFactory::findServiceByDesktopPath:
"findServiceByDesktopPath: searchproviders/locate.desktop not found"

konqueror(6565) KServiceFactory::findServiceByDesktopPath:
"findServiceByDesktopPath: searchproviders/.desktop not found"

KCrash: Application 'konqueror' crashing...

sock_file=/home/terrell/.kde/socket-tprude01/kdeinit4__0

terrell@tprude01:~$




Konqueror used to work just fine in KDE 4.2.0.* Anybody have any ideas
what's going on?



Thanks!



--TP













--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 03-06-2009, 01:46 AM
 
Default Konqueror crashing at launch with KDE 4.2.1 on Kubuntu Intrepid

No idea, as I upgraded w/ no problem, but three simple suggestions. *First, try sudo apt-get update then sudo apt-get upgrade again. *Then logout/login. *You may have missed a key package update. *Second, try rebooting the machine, not just logout/login. *If those don't work, rename your ~/.kde directory, then logout/login. *KDE will rebuild the directory (you'll have to reset your configs), but this may solve the problem.Paul
----- Original Message -----
From: "Terrell Prude' Jr." <microman@cmosnetworks.com>
To: kubuntu-users@lists.ubuntu.com
Sent: Thursday, March 5, 2009 8:53:48 PM GMT -05:00 US/Canada Eastern
Subject: Konqueror crashing at launch with KDE 4.2.1 on Kubuntu Intrepid



Hello folks,



I just upgraded my Kubuntu Intrepid's KDE from 4.2.0 to 4.2.1 today,
from the "kubuntu-experimental" repositories.* I use Konqueror as my
main Web browser and file manager.



Right after the KDE upgrade, rebooting, and logging back in, I tried
running Konqueror from the menu.* An entry appeared in the Task Manager
like Konqueror was starting up, but...no Konqueror itself appeared.*
After 30 seconds, the taskbar entry disappeared.* The same thing
happened when I tried running it from an icon in the Panel.* Clearly,
something was amiss.



I then tried running Konqueror from a Konsole prompt to see if I could
get any more info.* Right at launch, Konqueror crashed with a SIGSEGV.*
Additionally, a small window titled "Konqueror - The KDE Crash Handler"
popped up with the following message.




A Fatal Error Occurred
The application Konqueror
(konqueror) crashed and caused the signal 11 (SIGSEGV).

Please help us improve the software you use by filing a report at http://bugs.kde.org.
Useful details include how to reproduce the error, documents that were
loaded, etc.






Clicking "Show details" shows a string of "(no debugging symbols
found)" messages.* Apparently Konqueror was compiled with the symbols
stripped, which I kinda expect in "release" software.* Immediately
thereafter, I get a second box entitled "Sorry - The KDE Crash
Handler", basically telling me it can't create a valid backtrace.*
Again, expected when a "stripped" program crashes.



The messages from the Konsole window are as follows.



terrell@tprude01:~$ konqueror

konqueror(6565) KServiceFactory::findServiceByDesktopPath:
"findServiceByDesktopPath: searchproviders/locate.desktop not found"

konqueror(6565) KServiceFactory::findServiceByDesktopPath:
"findServiceByDesktopPath: searchproviders/.desktop not found"

KCrash: Application 'konqueror' crashing...

sock_file=/home/terrell/.kde/socket-tprude01/kdeinit4__0

terrell@tprude01:~$




Konqueror used to work just fine in KDE 4.2.0.* Anybody have any ideas
what's going on?



Thanks!



--TP














--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 03-06-2009, 09:01 PM
P Kapat
 
Default Konqueror crashing at launch with KDE 4.2.1 on Kubuntu Intrepid

On Thu, Mar 5, 2009 at 8:53 PM, Terrell Prude' Jr.
<microman@cmosnetworks.com> wrote:
> Hello folks,
>
> I just upgraded my Kubuntu Intrepid's KDE from 4.2.0 to 4.2.1 today, from
> the "kubuntu-experimental" repositories.* I use Konqueror as my main Web
> browser and file manager.

Ah, so that is the reason I was not getting any 4.2.1 updates since I
moved to backports. How long before 4.2.1 gets to backports?

[snip]

> A Fatal Error Occurred

[/snip]

Thanks, this will make me more prepared when upgrading...

Take a look at this post:
http://www.freehackers.org/thomas/2009/03/06/updating-to-kde-421-delete-your-plasma-files-again/


--
Regards
PK
--------------------------------------
http://counter.li.org #402424

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 03-06-2009, 09:35 PM
P Kapat
 
Default Konqueror crashing at launch with KDE 4.2.1 on Kubuntu Intrepid

On Thu, Mar 5, 2009 at 9:46 PM, <pkaplan1@comcast.net> wrote:
> No idea, as I upgraded w/ no problem, but three simple suggestions. *First,
> try sudo apt-get update then sudo apt-get upgrade again. *Then logout/login.
> *You may have missed a key package update. *Second, try rebooting the
> machine, not just logout/login. *If those don't work, rename your ~/.kde
> directory, then logout/login. *KDE will rebuild the directory (you'll have
> to reset your configs), but this may solve the problem.
> Paul

Renaming ~/.kde will "lose" (i know it is not removing) the user data
too, eg, RSS feeds, addressbook, basket data (if any), bookmarks, ....
- these are not config/guirc files - these are user data!!! The KDE
team should also make the distinction between USER data and
system/application data. For example, ~/.kde/share/apps/kpdf/* is
application data but ~/.kde/share/apps/kabc/* is a mix of USER and
application data.

Leaving aside the issue of KDE's instability, this distinction is
important from a regular backup point of view too. I do not want to
back up cache or various GUI rc files or application's data, but I DO
want to backup MY data which is stuck inside the ~/.kde!!! This to me
a huge flaw is the KDE architecture.

--
Regards
PK
--------------------------------------
http://counter.li.org #402424

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 

Thread Tools




All times are GMT. The time now is 12:59 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org