Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Kubuntu User (http://www.linux-archive.org/kubuntu-user/)
-   -   problems with locales (solved) (http://www.linux-archive.org/kubuntu-user/2024-problems-locales-solved.html)

"N.F." 11-21-2007 11:01 AM

problems with locales (solved)
 
Received from / Ricevuta da: Alexander Smirnov* [11/21/07 09:00]:

N.F. wrote:


Hi there,

since updating the tzdata package this morning
(which failed) I cannot fix the locale vars on my Gutsy.
as you can see:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "it_IT",
LC_ALL = (unset),
LANG = "it_IT.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or
directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up tzdata (2007i-0ubuntu0.7.10) ...
dpkg: error processing tzdata (--configure):
subprocess post-installation script returned error exit status 10
Errors were encountered while processing:
tzdata



Anybody experienced the same problem ?
Any solution ?


thanks

Nico


i'm not sure, but you can try to recompile the locale
>sudo locale-gen it_IT.UTF-8
and then try install tzdata again

another workaround is to set locale variable to en_US.utf8 for apt
>LANG=en_US.UTF-8 apt-get install --reinstall tzdata



OK

setting another time zone did the trick:

TZ_LOCALTIME='Europe/London' sudo dpkg --configure tzdata





thanks for your help



n.




--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users


All times are GMT. The time now is 10:04 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.