FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Kubuntu Development

 
 
LinkBack Thread Tools
 
Old 01-29-2011, 09:46 PM
Andrew Coles
 
Default Extra conflicts for marble-data, marble-plugins

Hi,

The marble-data and marble-plugins packages from KDE 4.6 are incompatible with libmarblewidget10 (the version from KDE 4.5).* Currently, it's possible to have them installed alongside libmarblewidget.so.10, but any application using the widget will crash upon attempting to initialise it (I found out about the problem by people finding their self-compiled versions of digikam crash on loading after upgrading to 4.6).* I've checked with Dennis Nienhüser - one of the Marble devs - and he confirms that there's no way the two could work together.


So, please could someone add libmarblewidget10 as a conflict with marble-data and marble-plugins >= 4.6, and push updated packages to the backports PPA?

Thanks,

Andrew

--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 02-01-2011, 06:16 PM
Jonathan Riddell
 
Default Extra conflicts for marble-data, marble-plugins

On Sat, Jan 29, 2011 at 10:46:30PM +0000, Andrew Coles wrote:
> Hi,
>
> The marble-data and marble-plugins packages from KDE 4.6 are incompatible
> with libmarblewidget10 (the version from KDE 4.5). Currently, it's
> possible to have them installed alongside libmarblewidget.so.10, but any
> application using the widget will crash upon attempting to initialise it
> (I found out about the problem by people finding their self-compiled
> versions of digikam crash on loading after upgrading to 4.6). I've
> checked with Dennis Nienhu:ser - one of the Marble devs - and he confirms
> that there's no way the two could work together.
>
> So, please could someone add libmarblewidget10 as a conflict with
> marble-data and marble-plugins >= 4.6, and push updated packages to the
> backports PPA?

I've made this change in our packaging in bzr now, it can be uploaded after alpha 2 later this week.

Jonathan

--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 02-01-2011, 09:41 PM
Andrew Coles
 
Default Extra conflicts for marble-data, marble-plugins

On Tue, Feb 1, 2011 at 7:16 PM, Jonathan Riddell <jriddell@ubuntu.com> wrote:

> * *So, please could someone add libmarblewidget10 as a conflict with

> * *marble-data and marble-plugins >= 4.6, and push updated packages to the

> * *backports PPA?



I've made this change in our packaging in bzr now, it can be uploaded after alpha 2 later this week.



Thanks Jonathan, much appreciated.

Andrew


--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 

Thread Tools




All times are GMT. The time now is 12:14 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org