FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Kubuntu Development

 
 
LinkBack Thread Tools
 
Old 02-12-2010, 10:42 AM
Kwan Chan
 
Default upgrade to kde sc 4.4 dependency broken

I'm on Kubuntu Karmic 64bit. I've already upgrade to the kde 4.4 earlier today. then I was trying to run a dist-upgrade, I got this error.*

do you guys have this problem?*


root@kwan-laptop:/home/yunkwan# proxychains aptitude dist-upgradeProxyChains-3.1 (http://proxychains.sf.net) * * * * * * * * * * *Reading package lists... Done * * * * * * * * * * * * * * * * * *

Building dependency tree * * * * * * * * * * * * * * * * * * * **Reading state information... Done * * * * * * * * * * * * * * * *Reading extended state information * * * * * * * * * * * * * * **

Initializing package states... Done * * * * * * * * * * * * * * *The following packages are BROKEN: * * * * * * * * * * * * * * ****libplasma3 * * * * * * * * * * * * * * * * * * * * * * * * * **

The following packages will be upgraded: * * * * * * * * * * * ****kdelibs5-data * * * * * * * * * * * * * * * * * * * * * * * * *1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Need to get 4,067kB of archives. After unpacking 0B will be used. * * *The following packages have unmet dependencies: * * * * * * * * * * * ***libplasma3: Depends: kdelibs5-data (= 4:4.4.0-0ubuntu1~karmic1~ppa1) but 4:4.4.0-0ubuntu1~karmic1~ppa2 is to be installed.

open: 48; closed: 141; defer: 0; conflict: 89 * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * **The following actions will resolve these dependencies: * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * **


Remove the following packages:akregator * * * * * * * * * **amarok * * * * * * * * * * * *apport-kde * * * * * * * * * *apturl-kde * * * * * * * * * *

ark * * * * * * * * * * * * **dolphin * * * * * * * * * * **dragonplayer * * * * * * * * *gdebi-kde * * * * * * * * * **gwenview * * * * * * * * * * *install-package * * * * * * **

jockey-kde * * * * * * * * * *k3b * * * * * * * * * * * * **kaddressbook * * * * * * * * *kamera * * * * * * * * * * * *kappfinder * * * * * * * * * *kate * * * * * * * * * * * * *

kcm-gtk * * * * * * * * * * **kde-style-qtcurve * * * * * **kde-window-manager * * * * * *kde-zeroconf * * * * * * * * *kdebase * * * * * * * * * * **kdebase-bin * * * * * * * * **

kdebase-plasma * * * * * * * *kdebase-runtime * * * * * * **kdebase-runtime-bin-kde4 * * *kdebase-workspace * * * * * **kdebase-workspace-bin * * * **kdebase-workspace-data * * * *

kdebase-workspace-kgreet-pluginskdebase-workspace-libs4+5 * * **kdebluetooth * * * * * * * * * *kdegraphics-strigi-plugins * * *kdemultimedia-kio-plugins * * **
kdepasswd * * * * * * * * * * **
kdepim-groupware * * * * * * * *kdepim-kresources * * * * * * **kdepim-runtime * * * * * * * * *kdepim-strigi-plugins * * * * **kdepim-wizards * * * * * * * * *
kdesudo * * * * * * * * * * * **
kdm * * * * * * * * * * * * * **kfind * * * * * * * * * * * * **khelpcenter4 * * * * * * * * * *kipi-plugins * * * * * * * * * *klipper * * * * * * * * * * * **
kmag * * * * * * * * * * * * * *
kmail * * * * * * * * * * * * **kmess * * * * * * * * * * * * **kmix * * * * * * * * * * * * * *kmousetool * * * * * * * * * * *knotes * * * * * * * * * * * * *
konq-plugins * * * * * * * * * *
konqueror * * * * * * * * * * **konqueror-nsplugins * * * * * **konqueror-plugin-searchbar * * *konqueror-plugins * * * * * * **konsole * * * * * * * * * * * **
kontact * * * * * * * * * * * **
kopete * * * * * * * * * * * * *korganizer * * * * * * * * * * *kpackagekit * * * * * * * * * **kppp * * * * * * * * * * * * * *krdc * * * * * * * * * * * * * *
krfb * * * * * * * * * * * * * *
ksnapshot * * * * * * * * * * **ksysguard * * * * * * * * * * **ksystemlog * * * * * * * * * * *ktimetracker * * * * * * * * * *ktorrent * * * * * * * * * * * *
kubuntu-desktop * * * * * * * **
kubuntu-firefox-installer * * **kubuntu-konqueror-shortcuts * **kvkbd * * * * * * * * * * * * **kwalletmanager * * * * * * * * *kwin-style-qtcurve * * * * * * *
kwrite * * * * * * * * * * * * *
language-selector-qt * * * * * *libk3b6 * * * * * * * * * * * **libk3b6-extracodecs * * * * * **libkcddb4 * * * * * * * * * * **libkdcraw8 * * * * * * * * * * *
libkdepim4 * * * * * * * * * * *
libkexiv2-8 * * * * * * * * * **libkipi7 * * * * * * * * * * * *libkleo4 * * * * * * * * * * * *libkonq5 * * * * * * * * * * * *libkonqsidebarplugin4 * * * * **
libkopete4 * * * * * * * * * * *
libkorundum4-ruby1.8 * * * * * *libkpgp4 * * * * * * * * * * * *libksieve4 * * * * * * * * * * *libkwineffects1 * * * * * * * **libkworkspace4 * * * * * * * * *
liblancelot0 * * * * * * * * * *
libmimelib4 * * * * * * * * * **libplasma-applet-system-monitor4libplasma3 * * * * * * * * * * *libplasmaclock4 * * * * * * * **libsmokekde4-2 * * * * * * * * *
libweather-ion4 * * * * * * * **
okular * * * * * * * * * * * * *okular-extra-backends * * * * **openoffice.org-kde * * * * * * *plasma-dataengines-addons * * **plasma-dataengines-workspace * *
plasma-desktop * * * * * * * * *
plasma-scriptengine-python * * *plasma-widget-facebook * * * * *plasma-widget-folderview * * * *plasma-widget-googlecalendar * *plasma-widget-indicatordisplay *
plasma-widget-kimpanel * * * * *
plasma-widget-kubuntu-qa-feedbackplasma-widget-lancelot * * * * **plasma-widget-quickaccess * * * *plasma-widgets-addons * * * * * *plasma-widgets-workspaceprinter-applet

python-kde4quasselsoftware-properties-kdesystem-config-printer-kdesystemsettingsupdate-manager-kdeupdate-notifier-kdeusb-creator-kde

userconfigvirtuosoconverter
Downgrade the following packages:mplayerthumbs [4:4.4.0-0ubuntu1~karmic1~ppa1 (karmic, now) -> 1.2-kde4.3.2-0ubuntu1 (karmic)]


Leave the following dependencies unresolved:gtk2-engines-qtcurve recommends kde-style-qtcurvekonq-plugins-l10n recommends konq-plugins (>= 4:4.2.4)ktorrent-data recommends ktorrent (>= 3.2.4+dfsg.1-1ubuntu1)

amarok-common recommends amarok (>= 2:2.2.2-0ubuntu1~karmic1~ppa1)kdelibs5 recommends kdebase-runtime (>= 4:4.2.2)kdebase-runtime-data-common recommends khelpcenter4Score is 3788


Accept this solution? [Y/n/q/?] ^C

--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 02-12-2010, 10:58 AM
Sebastian Kügler
 
Default upgrade to kde sc 4.4 dependency broken

On Friday 12 February 2010 12:42:56 Kwan Chan wrote:
> I'm on Kubuntu Karmic 64bit. I've already upgrade to the kde 4.4 earlier
> today. then I was trying to run a dist-upgrade, I got this error.
>
>
> do you guys have this problem?
>
> root@kwan-laptop:/home/yunkwan# proxychains aptitude dist-upgrade
> ProxyChains-3.1 (http://proxychains.sf.net)
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Reading extended state information
> Initializing package states... Done
> The following packages are BROKEN:
> libplasma3
> The following packages will be upgraded:
> kdelibs5-data
> 1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> Need to get 4,067kB of archives. After unpacking 0B will be used.
> The following packages have unmet dependencies:
> libplasma3: Depends: kdelibs5-data (= 4:4.4.0-0ubuntu1~karmic1~ppa1) but
> 4:4.4.0-0ubuntu1~karmic1~ppa2 is to be installed.
> open: 48; closed: 141; defer: 0; conflict: 89
>
>
> The following actions will resolve these dependencies:
>
>
>
> Remove the following packages:
> akregator
> amarok
> apport-kde
> apturl-kde
> ark
> dolphin
> dragonplayer
> gdebi-kde
> gwenview
> install-package
> jockey-kde
> k3b
> kaddressbook
> kamera
> kappfinder
> kate
> kcm-gtk
> kde-style-qtcurve
> kde-window-manager
> kde-zeroconf
> kdebase
> kdebase-bin
> kdebase-plasma
> kdebase-runtime
> kdebase-runtime-bin-kde4
> kdebase-workspace
> kdebase-workspace-bin
> kdebase-workspace-data
> kdebase-workspace-kgreet-plugins
> kdebase-workspace-libs4+5
> kdebluetooth
> kdegraphics-strigi-plugins
> kdemultimedia-kio-plugins
> kdepasswd
> kdepim-groupware
> kdepim-kresources
> kdepim-runtime
> kdepim-strigi-plugins
> kdepim-wizards
> kdesudo
> kdm
> kfind
> khelpcenter4
> kipi-plugins
> klipper
> kmag
> kmail
> kmess
> kmix
> kmousetool
> knotes
> konq-plugins
> konqueror
> konqueror-nsplugins
> konqueror-plugin-searchbar
> konqueror-plugins
> konsole
> kontact
> kopete
> korganizer
> kpackagekit
> kppp
> krdc
> krfb
> ksnapshot
> ksysguard
> ksystemlog
> ktimetracker
> ktorrent
> kubuntu-desktop
> kubuntu-firefox-installer
> kubuntu-konqueror-shortcuts
> kvkbd
> kwalletmanager
> kwin-style-qtcurve
> kwrite
> language-selector-qt
> libk3b6
> libk3b6-extracodecs
> libkcddb4
> libkdcraw8
> libkdepim4
> libkexiv2-8
> libkipi7
> libkleo4
> libkonq5
> libkonqsidebarplugin4
> libkopete4
> libkorundum4-ruby1.8
> libkpgp4
> libksieve4
> libkwineffects1
> libkworkspace4
> liblancelot0
> libmimelib4
> libplasma-applet-system-monitor4
> libplasma3
> libplasmaclock4
> libsmokekde4-2
> libweather-ion4
> okular
> okular-extra-backends
> openoffice.org-kde
> plasma-dataengines-addons
> plasma-dataengines-workspace
> plasma-desktop
> plasma-scriptengine-python
> plasma-widget-facebook
> plasma-widget-folderview
> plasma-widget-googlecalendar
> plasma-widget-indicatordisplay
> plasma-widget-kimpanel
> plasma-widget-kubuntu-qa-feedback
> plasma-widget-lancelot
> plasma-widget-quickaccess
> plasma-widgets-addons
> plasma-widgets-workspace
> printer-applet
> python-kde4
> quassel
> software-properties-kde
> system-config-printer-kde
> systemsettings
> update-manager-kde
> update-notifier-kde
> usb-creator-kde
> userconfig
> virtuosoconverter
>
> Downgrade the following packages:
> mplayerthumbs [4:4.4.0-0ubuntu1~karmic1~ppa1 (karmic, now) ->
> 1.2-kde4.3.2-0ubuntu1 (karmic)]
>
> Leave the following dependencies unresolved:
> gtk2-engines-qtcurve recommends kde-style-qtcurve
> konq-plugins-l10n recommends konq-plugins (>= 4:4.2.4)
> ktorrent-data recommends ktorrent (>= 3.2.4+dfsg.1-1ubuntu1)
> amarok-common recommends amarok (>= 2:2.2.2-0ubuntu1~karmic1~ppa1)
> kdelibs5 recommends kdebase-runtime (>= 4:4.2.2)
> kdebase-runtime-data-common recommends khelpcenter4
> Score is 3788
>
> Accept this solution? [Y/n/q/?] ^C

Try again, the needed packages is now there apparently.
--
sebas

http://www.kde.org | http://vizZzion.org | GPG Key ID: 9119 0EF9

--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 

Thread Tools




All times are GMT. The time now is 06:07 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org