FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Kubuntu Development

 
 
LinkBack Thread Tools
 
Old 01-16-2010, 04:28 PM
Vishal Rao
 
Default Progress bar animations for KDE 4.4 ?

I noticed Kubuntu Lucid does not have smooth animated progress bars which I've seen after installing KDE built off the branch in Arch.

Why is this and will it be available/enabled in Lucid final? (Assuming I'm not doing something wrong...)


I've got nvidia 8800GT with the properietary 195.30 beta drivers on x86_64...

--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 01-16-2010, 05:39 PM
Richard JOHNSON
 
Default Progress bar animations for KDE 4.4 ?

On Sat, Jan 16, 2010 at 10:58:20PM +0530, Vishal Rao wrote:
> I noticed Kubuntu Lucid does not have smooth animated progress bars which
> I've seen after installing KDE built off the branch in Arch.
>
> Why is this and will it be available/enabled in Lucid final? (Assuming I'm
> not doing something wrong...)
>
> I've got nvidia 8800GT with the properietary 195.30 beta drivers on
> x86_64...

They are smooth for me and I am using hardware that isn't as powerful
graphics wise to what you are using (I don't think). I am using all Intel
hardware here. In order for any of us to come up with a why it is doing
this, I think we need a bit more information.

Can you try and explain which application(s) it is happening in, so I can
see what I get? I know with certain apps that I use (Konqueror and
KDevelop), any progress bars seem smooth.

FYI: For anyone that wants to say, it isn't happening with $x but it is
with Kubuntu, please either give more information that might be able to
help troubleshoot such an issue, otherwise we will more than likely put it
off as trolling at best. I use openSUSE, Fedora, Arch, Kubuntu, Debian, and
Mandriva on the same machine, because a lot of people keep saying, "Well
in foo it doesn't do it but in bar it does." Thus far I haven't been able
to validate a single complaint, because they are all abusing memory the
same and all crashing in the same exact spot. Well, KRunner is an
exception, but that seems to be a libc issue from my understanding.

--
Name| Richard JOHNSON
Title| Developer
WWW| http://www.ubuntu.com
Email| nixternal@ubuntu.com
GnuPG| 3578 0981 A21D D662 2A96 7623 F4C1 838C D8C4 4738
--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 01-16-2010, 07:18 PM
Vishal Rao
 
Default Progress bar animations for KDE 4.4 ?

It didn't work for me with a fresh alpha2 install nor after installing the beta nvidia drivers from nvidia download.

Should I be using default ubuntu nvidia driver installed via hardware drivers?

I've noticed this in konqueror, dolphin (file ops) and kpackagekit (update packages) and also manually by running something like:


dcopRef=$(kdialog --title "DCOP Progress" --progressbar "Initializing . . ." 12)
qdbus $dcopRef org.freedesktop.DBus.Properties.Set org.kde.kdialog.ProgressDialog value 3

Any ideas what I might be doing wrong here?


--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 01-16-2010, 07:43 PM
Richard JOHNSON
 
Default Progress bar animations for KDE 4.4 ?

On Sun, Jan 17, 2010 at 01:48:48AM +0530, Vishal Rao wrote:
> It didn't work for me with a fresh alpha2 install nor after installing the
> beta nvidia drivers from nvidia download.
>
> Should I be using default ubuntu nvidia driver installed via hardware
> drivers?
>
> I've noticed this in konqueror, dolphin (file ops) and kpackagekit (update
> packages) and also manually by running something like:
>
> dcopRef=$(kdialog --title "DCOP Progress" --progressbar "Initializing . . ."
> 12)
> qdbus $dcopRef org.freedesktop.DBus.Properties.Set
> org.kde.kdialog.ProgressDialog value 3
>
> Any ideas what I might be doing wrong here?

Rock on, that's the type of info that makes this a bit easier to work out.
I just gave this a shot in Kubuntu, openSUSE, and Arch, all the latest. I
do notice a bit of jaggy'ness with all 3 using the kdialog/qdbus calls you
listed. It is hard to tell if it is the shading of the animation or what,
it happens so fast

I am going to check out dolphin/konqi on all of them while transferring
some files.

--
Name| Richard JOHNSON
Title| Developer
WWW| http://www.ubuntu.com
Email| nixternal@ubuntu.com
GnuPG| 3578 0981 A21D D662 2A96 7623 F4C1 838C D8C4 4738
--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 01-16-2010, 08:02 PM
Vishal Rao
 
Default Progress bar animations for KDE 4.4 ?

Thanks, I can clearly see the difference in smoothness of jumps (increases) in KDE 4.4 RC1 built from source ( on Arch :P ) so its surely not working for me on current Lucid...

Let me know if there's anything I can try or any other info to post - I'll try the standard nvidia drivers from the default lucid repos in the mean time...


--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 01-17-2010, 11:08 AM
Vishal Rao
 
Default Progress bar animations for KDE 4.4 ?

OK it seems to work after having installed nvidia 185 drivers from the repos! Would you know how/why would the nvidia 195.30 beta drivers downloaded off their site have this thing missing when every other effect appears to have worked?


--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 01-18-2010, 10:35 AM
Sebastian Kügler
 
Default Progress bar animations for KDE 4.4 ?

On Saturday 16 January 2010 18:28:20 Vishal Rao wrote:
> I noticed Kubuntu Lucid does not have smooth animated progress bars which
> I've seen after installing KDE built off the branch in Arch.
>
> Why is this and will it be available/enabled in Lucid final? (Assuming I'm
> not doing something wrong...)
>
> I've got nvidia 8800GT with the properietary 195.30 beta drivers on
> x86_64...

We (KDE upstream) have actually switched off some animations for 4.4, admittedly a
bit late in the cycle. We felt they weren't perfect yet, and didn't want to annoy
people with animations that aren't really done.

You can enable them in the Style settings.

Not sure if this is what you're talking about, but it might be where the confusion
comes from.
--
sebas

http://www.kde.org | http://vizZzion.org | GPG Key ID: 9119 0EF9

--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 01-18-2010, 10:58 PM
Vishal Rao
 
Default Progress bar animations for KDE 4.4 ?

2010/1/18 Sebastian Kügler <sebas@kde.org>

On Saturday 16 January 2010 18:28:20 Vishal Rao wrote:

> I noticed Kubuntu Lucid does not have smooth animated progress bars which

> I've seen after installing KDE built off the branch in Arch.

>

> Why is this and will it be available/enabled in Lucid final? (Assuming I'm

> not doing something wrong...)

>

> I've got nvidia 8800GT with the properietary 195.30 beta drivers on

> x86_64...



We (KDE upstream) have actually switched off some animations for 4.4, admittedly a

bit late in the cycle. We felt they weren't perfect yet, and didn't want to annoy

people with animations that aren't really done.



You can enable them in the Style settings.



Not sure if this is what you're talking about, but it might be where the confusion

comes from.

--

sebas



http://www.kde.org | http://vizZzion.org | GPG Key ID: 9119 0EF9



Thanks for responding with upstream info that some animations are switched off late for 4.4, good enough for me. It's not a big deal of course, I was just curious whether something was wrong with my install, but clearly not. 4.4 is looking very nice (thanks for the great work) and I will look forward to 4.5 with Lucid+1 for an even more slick desktop.


--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 01-18-2010, 11:14 PM
Sebastian Kügler
 
Default Progress bar animations for KDE 4.4 ?

On Tuesday 19 January 2010 00:58:01 Vishal Rao wrote:
> Thanks for responding with upstream info that some animations are switched
> off late for 4.4, good enough for me. It's not a big deal of course, I was
> just curious whether something was wrong with my install, but clearly not.
> 4.4 is looking very nice (thanks for the great work) and I will look
> forward to 4.5 with Lucid+1 for an even more slick desktop.

Or just switch them on again in System Settings | Appearance | Style | Applications |
Configure

Cheers,
--
sebas

http://www.kde.org | http://vizZzion.org | GPG Key ID: 9119 0EF9
--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 01-18-2010, 11:33 PM
Vishal Rao
 
Default Progress bar animations for KDE 4.4 ?

2010/1/19 Sebastian Kügler <sebas@kde.org>



Or just switch them on again in System Settings | Appearance | Style | Applications |

Configure



Yes, forgot to mention that I have them turned on, thanks again :-)
--
"Thou shalt not follow the null pointer for at its end madness and chaos lie."


--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 

Thread Tools




All times are GMT. The time now is 12:52 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org