FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Kubuntu Development

 
 
LinkBack Thread Tools
 
Old 09-07-2008, 08:52 AM
Cesare Tirabassi
 
Default kdesu for kde4

A quickie for all Kubunteros out there.
I read that /usr/bin/kdesu in kde4 is obsoleted.
For Intrepid, should applications that rely on it be patched to rely
on /usr/lib/kde4/libexec/kdesu or on /usr/bin/kdesudo or is there some
mechanism in place that won't break backward compatibility?
Will existing su-to-root (that uses /usr/lib/kde4/libexec/kdesu) work or will
it need patching for Ubuntu?
Existing docs I could find on the subject are not very clear:

LP bugs: 179495, 184491, 197404
http://kubuntuforums.net/forums/index.php?action=printpage;topic=3095801.0
https://wiki.ubuntu.com/HaraldSitter/KdeFour/KdeSudo

Cesare

--
kubuntu-devel mailing list
kubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
 
Old 09-07-2008, 08:52 AM
Cesare Tirabassi
 
Default kdesu for kde4

A quickie for all Kubunteros out there.
I read that /usr/bin/kdesu in kde4 is obsoleted.
For Intrepid, should applications that rely on it be patched to rely
on /usr/lib/kde4/libexec/kdesu or on /usr/bin/kdesudo or is there some
mechanism in place that won't break backward compatibility?
Will existing su-to-root (that uses /usr/lib/kde4/libexec/kdesu) work or will
it need patching for Ubuntu?
Existing docs I could find on the subject are not very clear:

LP bugs: 179495, 184491, 197404
http://kubuntuforums.net/forums/index.php?action=printpage;topic=3095801.0
https://wiki.ubuntu.com/HaraldSitter/KdeFour/KdeSudo

Cesare

--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 
Old 09-07-2008, 12:52 PM
Harald Sitter
 
Default kdesu for kde4

On Sunday 07 September 2008 10:52:10 Cesare Tirabassi wrote:
> A quickie for all Kubunteros out there.
> I read that /usr/bin/kdesu in kde4 is obsoleted.
> For Intrepid, should applications that rely on it be patched to rely
> on /usr/lib/kde4/libexec/kdesu or on /usr/bin/kdesudo or is there some
> mechanism in place that won't break backward compatibility?
> Will existing su-to-root (that uses /usr/lib/kde4/libexec/kdesu) work or
> will it need patching for Ubuntu?
> Existing docs I could find on the subject are not very clear:
>
> LP bugs: 179495, 184491, 197404
> http://kubuntuforums.net/forums/index.php?action=printpage;topic=3095801.0
> https://wiki.ubuntu.com/HaraldSitter/KdeFour/KdeSudo

Every application which can not use KDE internal features should be using
/usr/lib/kde4/libexec/kdesu (one can install KDE without kdesudo which would
make it the only valid path for native kdesu and kdesudo).

I actually think that we shouldn't use su-to-root but provide seperate desktop
files for KDE using X-KDE-SubstituteUID=true in order to have future proof
desktop files. Just a personal opinion though.

Regards,
Harald
--
Ubuntu-motu mailing list
Ubuntu-motu@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-motu
 

Thread Tools




All times are GMT. The time now is 12:59 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org