FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-20-2008, 02:37 PM
 
Default Are some-cvs items synced with actual cvs often?

I'm curious how some-cvs type packages work.

In particular emacs-cvs. I'm running what gentoo tells me is
emacs-23.0.9999.

I have certain font problems that judging by following the emacs-dev
list are now somewhat dealt with in current cvs.

AFter running `emerge --sync' I see that emacs-cvs still shows
emacs-23.0.9999. And no update needed

When I run emacs command M-x version it shows emacs-23.0.60

I think there have been changes in the head of emacs-23 cvs. So how
do I determine if I'm running the latest cvs?

I used to build my own emacs-cvs and update from cvs as needed but
was told I ought to let gentoo handle that by installing emacs-cvs.
That emacs-cvs thru gentoo would accomplish the same thing but would
keep my OS up on what its running.

Now I want to know how closely portage emas-cvs follows the cvs tree.
Is it linked directly to it or is there some delay where gentoo does
whatever to the package?

--
gentoo-user@lists.gentoo.org mailing list
 
Old 05-20-2008, 08:00 PM
Graham Murray
 
Default Are some-cvs items synced with actual cvs often?

reader@newsguy.com writes:

> I think there have been changes in the head of emacs-23 cvs. So how
> do I determine if I'm running the latest cvs?

Run 'emerge emacs-cvs'. The ebuild will do a CVS update and then build
it.
--
gentoo-user@lists.gentoo.org mailing list
 
Old 05-21-2008, 09:29 AM
Neil Bothwick
 
Default Are some-cvs items synced with actual cvs often?

On Tue, 20 May 2008 09:37:47 -0500, reader@newsguy.com wrote:

> AFter running `emerge --sync' I see that emacs-cvs still shows
> emacs-23.0.9999. And no update needed
>
> When I run emacs command M-x version it shows emacs-23.0.60
>
> I think there have been changes in the head of emacs-23 cvs. So how
> do I determine if I'm running the latest cvs?

Check the version of the running Emacs against the latest on the CVS
server. If it differs, emerge it again. CVS ebuilds don't have a specific
version, that would mean creating a new ebuild each time the CVS was
updated, instead they use the latest available from CVS at the time you
run it.


--
Neil Bothwick

Multitasking: Reading in the bathroom.
 

Thread Tools




All times are GMT. The time now is 04:32 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org