Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   freepops plays up (http://www.linux-archive.org/gentoo-user/91702-freepops-plays-up.html)

Mick 05-20-2008 01:26 PM

freepops plays up
 
This is probably simple enough to resolve:

I updated lua recently to:

[D] dev-lang/lua
Installed versions: 5.1.3-r1(08:44:37 05/19/08)
(readline -deprecated -static)

Meanwhile, I am running freepops-0.2.5. Since lua was updated freepops keels
over with a lookup error for lua:
================================
$ freepopsd -v -s michael.users
Tue May 20 11:09:27 2008 freepopsd: INTERNAL: freepops started with loglevel 1
on a little endian machine.
Tue May 20 11:09:27 2008 freepopsd: PID: Cannot create pid
file "/var/run/freepopsd.pid"
freepopsd: symbol lookup error: freepopsd: undefined symbol: luaL_openlib
================================

revdep-rebuild does not show anything. Is it a bug?
--
Regards,
Mick

"Andrey Falko" 05-20-2008 02:08 PM

freepops plays up
 
On Tue, May 20, 2008 at 9:26 AM, Mick <michaelkintzios@gmail.com> wrote:
> This is probably simple enough to resolve:
>
> I updated lua recently to:
>
> [D] dev-lang/lua
> Installed versions: 5.1.3-r1(08:44:37 05/19/08)
> (readline -deprecated -static)
>
> Meanwhile, I am running freepops-0.2.5. Since lua was updated freepops keels
> over with a lookup error for lua:
> ================================
> $ freepopsd -v -s michael.users
> Tue May 20 11:09:27 2008 freepopsd: INTERNAL: freepops started with loglevel 1
> on a little endian machine.
> Tue May 20 11:09:27 2008 freepopsd: PID: Cannot create pid
> file "/var/run/freepopsd.pid"
> freepopsd: symbol lookup error: freepopsd: undefined symbol: luaL_openlib
> ================================
>
> revdep-rebuild does not show anything. Is it a bug?
You tried re-emerging freepops, right? If it works after you re-emerge
it, then there is bug with revdep-rebuild.
You tried it, then you've hit some sort of bug with linking.

So yes, its some sort of bug.
> --
> Regards,
> Mick
>
--
gentoo-user@lists.gentoo.org mailing list

Mick 05-20-2008 02:44 PM

freepops plays up
 
On Tuesday 20 May 2008, Andrey Falko wrote:
> On Tue, May 20, 2008 at 9:26 AM, Mick <michaelkintzios@gmail.com> wrote:
> > This is probably simple enough to resolve:
> >
> > I updated lua recently to:
> >
> > [D] dev-lang/lua
> > Installed versions: 5.1.3-r1(08:44:37 05/19/08)
> > (readline -deprecated -static)
> >
> > Meanwhile, I am running freepops-0.2.5. Since lua was updated freepops
> > keels over with a lookup error for lua:
> > ================================
> > $ freepopsd -v -s michael.users
> > Tue May 20 11:09:27 2008 freepopsd: INTERNAL: freepops started with
> > loglevel 1 on a little endian machine.
> > Tue May 20 11:09:27 2008 freepopsd: PID: Cannot create pid
> > file "/var/run/freepopsd.pid"
> > freepopsd: symbol lookup error: freepopsd: undefined symbol: luaL_openlib
> > ================================
> >
> > revdep-rebuild does not show anything. Is it a bug?
>
> You tried re-emerging freepops, right? If it works after you re-emerge
> it, then there is bug with revdep-rebuild.
> You tried it, then you've hit some sort of bug with linking.
>
> So yes, its some sort of bug.

What do you know! This portage thing is a rather intelligent piece of
engineering ;-)
========================================
* checking freepops-0.2.5.tar.gz ;-) ... [
ok ]
* This package uses the deprecated functions of lua
*
* ERROR: net-mail/freepops-0.2.5 failed.
* Call stack:
* ebuild.sh, line 49: Called pkg_setup
* freepops-0.2.5.ebuild, line 26: Called die
* The specific snippet of code:
* die 'please compile dev-lang/lua with USE=deprecated'
* The die message:
* please compile dev-lang/lua with USE=deprecated
========================================

I'm off to re-emerge lua.

Thanks.
--
Regards,
Mick


All times are GMT. The time now is 10:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.