FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-09-2008, 02:34 PM
 
Default portage & foomatic problem: SOLVED

Selon Alan McKinnon <alan.mckinnon@gmail.com>:
----<snip>----
>
> That version of foomatic is no longer in portage but you have it
> installed and it DEPENDS on something that is also not in portage.
> Apparently, you ran emerge --sync then this happened. It does happen
> sometimes. So: emerge foomatic first, then foomatic-db-ppds to get the
> latest that is in portage.
>
> That might not work due to DEPENDs order, in which case you must unmerge
> all foomatic packages and remerge them from scratch. This is a bit
> drastic with updates and blockers and isn't normally necessary. But
> sometimes it is, this looks like one of those times.
>

Finally, emerge --unmerge foomatic worked, removing no file but removing
"foomatic" from /var/lib/portage world. Updated foomatic-* packages are still
there.
Thanks for the help, I was lost as I didn't realize that emerge was trying to
update a meta-package (foomatic) no more in portage...
Thanks,

--
~adj~


--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 04:46 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org