Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   portage & foomatic problem (http://www.linux-archive.org/gentoo-user/84519-portage-foomatic-problem.html)

05-08-2008 05:34 PM

portage & foomatic problem
 
isba alain # emerge -uD world
returns the following:

Calculating world dependencies /
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

net-print/foomatic-db-ppds:0

('installed', '/', 'net-print/foomatic-db-ppds-20060720', 'nomerge') pulled in
by
('installed', '/', 'net-print/foomatic-3.0.20060601', 'nomerge')

('ebuild', '/', 'net-print/foomatic-db-ppds-3.0.20060720', 'merge') pulled in
by
('installed', '/', 'net-print/cups-1.2.12-r8', 'nomerge')


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

!!! Depgraph creation failed.

What should I do? May I get rid of foomatic package without gettindg into
trouble with cups?
I guess I have to fill a bug report...

--
gentoo-user@lists.gentoo.org mailing list

"Andrey Falko" 05-08-2008 06:06 PM

portage & foomatic problem
 
On Thu, May 8, 2008 at 1:34 PM, <alain.didierjean@free.fr> wrote:
>
> isba alain # emerge -uD world
> returns the following:
>
> Calculating world dependencies /
> !!! Multiple versions within a single package slot have been
> !!! pulled into the dependency graph:
>
> net-print/foomatic-db-ppds:0
>
> ('installed', '/', 'net-print/foomatic-db-ppds-20060720', 'nomerge') pulled in
> by
> ('installed', '/', 'net-print/foomatic-3.0.20060601', 'nomerge')
>
> ('ebuild', '/', 'net-print/foomatic-db-ppds-3.0.20060720', 'merge') pulled in
> by
> ('installed', '/', 'net-print/cups-1.2.12-r8', 'nomerge')
>
>
> It may be possible to solve this problem by using package.mask to
> prevent one of those packages from being selected. However, it is also
> possible that conflicting dependencies exist such that they are
> impossible to satisfy simultaneously. If such a conflict exists in the
> dependencies of two different packages, then those packages can not be
> installed simultaneously.
>
> For more information, see MASKED PACKAGES section in the emerge man page
> or refer to the Gentoo Handbook.
>
> !!! Depgraph creation failed.
>
> What should I do? May I get rid of foomatic package without gettindg into
> trouble with cups?
> I guess I have to fill a bug report...
>
I would try the following first:

emerge -C foomatic-db-ppds
emerge -uD world

> --
> gentoo-user@lists.gentoo.org mailing list
>
>
--
gentoo-user@lists.gentoo.org mailing list

Mick 05-08-2008 06:26 PM

portage & foomatic problem
 
On Thursday 08 May 2008, Andrey Falko wrote:
> On Thu, May 8, 2008 at 1:34 PM, <alain.didierjean@free.fr> wrote:

> > What should I do? May I get rid of foomatic package without gettindg
> > into trouble with cups?
> > I guess I have to fill a bug report...
>
> I would try the following first:
>
> emerge -C foomatic-db-ppds
> emerge -uD world

I unmerged all ppd related packages and emerge -uaDv word came back with the
same message. So, I decided to upgrade to ~x86 ppd packages:

net-print/foomatic-db-ppds-3.0.20080507
net-print/foomatic-db-engine-3.0.20080507

I am about to also upgrade:

net-print/foomatic-db-3.0.20070508

because cups wants to downgrade?!

[D] net-print/cups
Installed versions: 1.2.12-r8

Strangely this is only evident when I use eix -l cups, not when I run
emerge -upDv world.

Then we'll see if I can print anymore . . . o_O
--
Regards,
Mick

Alan McKinnon 05-08-2008 09:04 PM

portage & foomatic problem
 
On Thursday 08 May 2008, alain.didierjean@free.fr wrote:
> isba alain # emerge -uD world
> returns the following:
>
> Calculating world dependencies /
> !!! Multiple versions within a single package slot have been
> !!! pulled into the dependency graph:
>
> net-print/foomatic-db-ppds:0
>

Look at the version numbers of foomatic-db-ppds below:
> ('installed', '/', 'net-print/foomatic-db-ppds-20060720',
> 'nomerge') pulled in by
> ('installed', '/', 'net-print/foomatic-3.0.20060601', 'nomerge')
>
> ('ebuild', '/', 'net-print/foomatic-db-ppds-3.0.20060720', 'merge')
> pulled in by
> ('installed', '/', 'net-print/cups-1.2.12-r8', 'nomerge')

Looks like a sane version number sequence was implemented, and v20060720
(which you have installed) was renamed to 2.0.20060720 (which cups
wants to install. This will never be automated as portage thinks the
new version number is earlier than the older one (!)

So: emerge -avC =foomatic-db-ppds-20060702
emerge -uD world

<snip>

> I guess I have to fill a bug report...

No, it's not a bug

--
Alan McKinnon
alan dot mckinnon at gmail dot com

--
gentoo-user@lists.gentoo.org mailing list

05-09-2008 10:33 AM

portage & foomatic problem
 
Selon Alan McKinnon <alan.mckinnon@gmail.com>:

> On Thursday 08 May 2008, alain.didierjean@free.fr wrote:
> > isba alain # emerge -uD world
> > returns the following:
> >
> > Calculating world dependencies /
> > !!! Multiple versions within a single package slot have been
> > !!! pulled into the dependency graph:
> >
> > net-print/foomatic-db-ppds:0
> >
>
> Look at the version numbers of foomatic-db-ppds below:
> > ('installed', '/', 'net-print/foomatic-db-ppds-20060720',
> > 'nomerge') pulled in by
> > ('installed', '/', 'net-print/foomatic-3.0.20060601', 'nomerge')
> >
> > ('ebuild', '/', 'net-print/foomatic-db-ppds-3.0.20060720', 'merge')
> > pulled in by
> > ('installed', '/', 'net-print/cups-1.2.12-r8', 'nomerge')
>
> Looks like a sane version number sequence was implemented, and v20060720
> (which you have installed) was renamed to 2.0.20060720 (which cups
> wants to install. This will never be automated as portage thinks the
> new version number is earlier than the older one (!)
>
> So: emerge -avC =foomatic-db-ppds-20060702
> emerge -uD world
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Did this..
Got that:

Calculating world dependencies -
emerge: there are no ebuilds to satisfy ">=net-print/foomatic-db-ppds-20060601".
(dependency required by "net-print/foomatic-3.0.20060601" [installed])



!!! Problem resolving dependencies for net-print/foomatic
!!! Depgraph creation failed.

> <snip>
>
> > I guess I have to fill a bug report...
>
> No, it's not a bug
>
OK.





--
gentoo-user@lists.gentoo.org mailing list

Alan McKinnon 05-09-2008 12:58 PM

portage & foomatic problem
 
On Friday 09 May 2008, alain.didierjean@free.fr wrote:

> Calculating world dependencies -
> emerge: there are no ebuilds to satisfy
> ">=net-print/foomatic-db-ppds-20060601". (dependency required by
> "net-print/foomatic-3.0.20060601" [installed])
>
>
>
> !!! Problem resolving dependencies for net-print/foomatic
> !!! Depgraph creation failed.

That version of foomatic is no longer in portage but you have it
installed and it DEPENDS on something that is also not in portage.
Apparently, you ran emerge --sync then this happened. It does happen
sometimes. So: emerge foomatic first, then foomatic-db-ppds to get the
latest that is in portage.

That might not work due to DEPENDs order, in which case you must unmerge
all foomatic packages and remerge them from scratch. This is a bit
drastic with updates and blockers and isn't normally necessary. But
sometimes it is, this looks like one of those times.


--
Alan McKinnon
alan dot mckinnon at gmail dot com

--
gentoo-user@lists.gentoo.org mailing list


All times are GMT. The time now is 06:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.